1 2 Previous Next 17 Replies Latest reply on Aug 30, 2011 9:59 AM by user237425 Go to original post
      • 15. Re: OPS center ERRLABEL
        user237425
        Hello Experts,

        I am also faing the same ERRLABEL problem in solaris 10 Machine.Im getting the following error when i ran OCDoctor.sh script.

        # ./OCDoctor.sh troubleshoot fix
        Ops Center Doctor version 2.02 (Nov 17 2010 [Build 261])
        [Fix mode is enabled]
        ===================== Checking Enterprise Controller... ===========================
        OK: Total number of agents: 0
        OK: Number of agents with inventories: 0
        OK: Enterprise Controller requirements are met
        OK: No broken indexes in the Management DB
        OK: No broken indexes in the Report DB
        OK: Apache logs are smaller than 2 GB
        OK: User scncon is not locked
        Warning: truncating password to 8 characters
        ERROR: scncon password in /var/opt/sun/xvm/persistence/scn-satellite/satellite.properties doesnt match /etc/shadow
        OK: n1gc folder has the right permissions
        OK: All Enterprise Controller packages are installed properly
        OK: All agent packages are installed properly
        OK: All agent patches are installed properly
        OK: Enterprise Controller status is online
        OK: the version is the latest one (11.1.0.1536)
        OK: satadm timeouts were increased
        OK: tar command was properly adjusted in satadm
        OK: scndb user exists
        OK: scndb user does not have any messages printed when logged in
        OK: Logs folder has the right permissions
        OK: Connectivity to the KB public servers works properly
        OK: /usr/jdk/latest points to a 1.6.0 JDK
        OK: No partially installed packages
        OK: No old jobs rerun (CR 6990675)
        OK: No NCP encryption is used
        OK: No credential issues found
        TIP: don't forget to run the 'OCDoctor.sh --tuning' to optimize performance on the EC
        ==================== Checking LOCAL Proxy Controller... ===========================
        OK: Verified a unique Cacao SMF instance.
        OK: ipmiflash points to a binary
        OK: No hidden servers due to proxy communication
        OK: /etc/hosts is a symbolic link
        OK: Proxy status is online
        OK: Found a proxy connection listed in 'sc-console list-connections' - the local proxy is properly configured
        You may run this on remote proxies as well
        OK: no ssh 'Read timed out' messages found
        OK: Admin DB netmask matches the ifconfig output for xnf2 (255.255.255.0)
        ======== Agent controller is installed but not configured, skipping ===============

        I have check /etc/shadow and satellite.properties file.Password is same in both files

        Your help is very much appreciated in advance.

        Thanks,
        chandra

        Edited by: user12106494 on 29-Aug-2011 11:04
        • 16. Re: OPS center ERRLABEL
          User12617625-Oracle
          First thing I would do is run

          /var/opt/sun/xvm/OCDoctor/OCDoctor.sh --update

          You should get up to 3.03.

          Then run --troubleshoot again and see if anything new pops up.

          The rest of my notes:

          Common causes/solutions:

          * Check swap - make sure have over 6gb

          * Make sure nothing else is using port 443:

          /opt/SUNWxvmoc/bin/proxyadm stop -wv
          /opt/SUNWxvmoc/bin/satadm stop -wv
          netstat -an | grep 443

          * Check /etc/hosts, make sure there are not 2 "localhost" entries - 1 with the IP of the EC (which was listed first), and the 2nd on the 127.0.0.1 line. Remove the localhost alias from the line with the IP/hostname of the EC, restart the EC, and it was fine.

          * scncon password changed or something is wrong with it. Use "passwd" as root for scncon and make sure it matches what is set in /var/opt/sun/xvm/persistence/scn-satellite/satellite.properties on the scncon.password line. The scncon password in this file is in clear text. Make sure the scncon and other users are in /etc/shadow.

          "It looks like the login issue had something to do with the OPS Center entries initially being missing from the /etc/shadow file. When I had added them and then got the messages about the scncon acct being locked I had tried using “passwd -u scncon” to unlock the acct, which apparently wasn’t working. I ended up manually editing the shadow file. I’m now able to login as root and with my own user credentials."


          One person had this experience:

          Failure in registering with Oracle Configuration Manager server
          Invalid My Oracle Support credentials.
          Unable to install/configure OCM with /var/opt/sun/xvm/ocm/ccr/bin/setupCCR, error code: 11
          Cannot proceed with Oracle Configuration Manager installation

          Manually executed the following:

          /var/opt/sun/xvm/ocm/ccr/bin/setupCCR

          Came back with issues regarding ORACLE_HOME and JAVA_HOME. Once I fixed/set both of them and re-ran setupCCR, everything works fine.
          • 17. Re: OPS center ERRLABEL
            user237425
            Hi,

            Thanks for providing the tips to resolve the issue.

            I changed the scncon password and updated the satellite.properties with new password clear text.Now everything is working fine.

            Thanks,
            chandra
            1 2 Previous Next