5 Replies Latest reply: Aug 6, 2012 8:59 AM by 765392 RSS

    Apache - Weblogic Connection Issue

    744042
      Hi

      we are facing with Apache weblogic communication issues.

      The communication with Apache and Weblogic works for some time ( few hrs), But after some time we get the below error.

      Let us take one pair. (Apachedevv1 ----> Weblogicdevp1)

      Yesterday evening it was working fine. Today morning I see the below error.

      http://Apachedevv1/

      ##############################################################################
      Failure of server APACHE bridge:

      --------------------------------------------------------------------------------
      No backend server available for connection: timed out after 10 seconds or idempotent set to OFF.
      --------------------------------------------------------------------------------

      Build date/time: Apr 20 2009 21:26:02

      --------------------------------------------------------------------------------
      Change Number: 1211636
      ##############################################################################

      Then I run the below command on Weblogicdevp1

      C:\> telnet Apachedevv1 80

      This is success as the Apache is running on Apachedevv1:80

      Now If I access the URL http://Apachedevv1/ it is success now and I get the weblogic home page.

      Pls let us know if you had face this type of issue earlier.

      Following are the lines added in httpd.conf of Apache.

      <IfModule mod_weblogic.c>
      WebLogicHost Weblogicdevp1
      WebLogicPort 7001
      </IfModule>

      <Location />
      SetHandler weblogic-handler
      </Location>


      I see the below errors in error.log of Apache.

      [Wed Dec 29 09:10:59 2010] [error] [client xx.yy.49.39] ap_proxy: trying GET / at backend host 'xx.yy.86.54/7001; got exception 'CONNECTION_REFUSED [os error=0, line 1715 of ../nsapi/URL.cpp]: Error connecting to host xx.yy.86.54:7001'
      [Wed Dec 29 09:11:03 2010] [error] [client xx.yy.49.39] ap_proxy: trying GET / at backend host 'xx.yy.86.54/7001; got exception 'CONNECTION_REFUSED [os error=0, line 1715 of ../nsapi/URL.cpp]: Error connecting to host xx.yy.86.54:7001'
      [Wed Dec 29 09:11:07 2010] [error] [client xx.yy.49.39] ap_proxy: trying GET / at backend host 'xx.yy.86.54/7001; got exception 'CONNECTION_REFUSED [os error=0, line 1715 of ../nsapi/URL.cpp]: Error connecting to host xx.yy.86.54:7001'


      Thanks