1 2 Previous Next 27 Replies Latest reply: Feb 1, 2011 3:38 AM by 792712 Go to original post RSS
      • 15. Re: Degradation of response time
        792712
        Hi, rucong

        I tried the binary db5_checkpoint -1 and db5_archives -d, but no change.


        What concretely DBXML when I open a container by configuring transactional true ?

        Because it's slow at the opening of the container, not on the execution of the request itself.

        Thx.
        • 16. Re: Degradation of response time
          655560
          Hi, gdievart

          It's good to know that the execution of the request has no degradation.

          For the transactional environment, DBXML (BDB) has to open and deal with log files and region files (including locking subsystem). So it does make sense that transactional environment cost a longer time.

          Since you said that by running db5_recover you can get correct response times. I just doubt if there are something wrong in the environment. It would be great if you can provide a program to reproduce the issue. Thanks.

          You mentioned that "But after a few thousand I/O, opening the container can be counted in seconds". Could you please tell me the exact number? e.g.: 5 seconds, 7 seconds. Thanks.

          Best regards,
          Rucong
          Oracle Berkeley DB XML
          • 17. Re: Degradation of response time
            792712
            Hello, Rucong

            The opening of the container up to 10 seconds.

            Also, yesterday I realized that DBXML did not release the hold of a log file, open for several hours.

            Have you ever encountered this behavior?

            Guillaume.
            • 18. Re: Degradation of response time
              655560
              Hi Guillaume,

              It seems that the environment does not be closed correctly.

              Please:
              * try the flag "DBXML_ADOPT_DBENV" (http://download.oracle.com/docs/cd/E17276_01/html/api_reference/CXX/XmlManager.html).
              * Refer http://download.oracle.com/docs/cd/E17276_01/html/gsg_xml_txn/cxx/envopen.html to check your transactional environment configuration.

              If the problem still can not be solved, please show me your code that how you open/close DB_ENV and/or XmlManager.

              Best regards,
              Rucong
              • 19. Re: Degradation of response time
                792712
                Hi Rucong,

                sorry for this answer so late, but I expected that my environment will take time to respond.

                This time the container will not open even through the prompt DBXML.

                Here is how I instantiate my environment and I open the containers.


                /* Exemples of my code */
                define("ENV", '/myDataDir/...');
                define("FLAGS", DB_CREATE | DB_INIT_LOCK | DB_INIT_LOG | DB_INIT_MPOOL | DB_INIT_TXN | DB_THREAD | DB_RECOVER | DB_REGISTER);

                $oEnv = new Db4Env();
                $oEnv->open(ENV, FLAGS);
                $oManager = new XmlManager($oEnv, DBXML_ALLOW_EXTERNAL_ACCESS | DBXML_ALLOW_AUTO_OPEN | DBXML_ADOPT_DBENV);

                // Test exist
                $oManager->existsContainer('myContainer.dbxml');

                $bEnable = IS_WRITE ? true : false;
                $oConfig = new XmlContainerConfig();
                $oConfig->setTransactional($bEnable);
                $oContainer = $oManager->createContainer('myContainer.dbxml', $oConfig);

                I don't understand.

                When I delete my environment (__db *) and I recreated, I have no problem.

                Edited by: gdievart on 31 janv. 2011 04:16
                • 20. Re: Degradation of response time
                  792712
                  No one else has encounter this problem?

                  Small clarification:
                  I'm in auto indexing mode if it helps

                  Thx.
                  • 21. Re: Degradation of response time
                    637288
                    Hi,

                    could you please create a container once more with auto-indexing off. Then check whether you have the same problem again.
                    Can you also post your updated code. If it doesn't help, the original data and the code would be helpful to try to reproduce the problem on my machine as well.

                    Vyacheslav
                    • 22. Re: Degradation of response time
                      792712
                      Hi detonator,

                      I can't provide the complete code, but the procedures followed are those of the above.

                      To know that I insert and remove approximately 500 documents per day + updates.

                      Reading about 50,000 per day or more.

                      I'll try removing the auto-indexing, but I don't see how the index would have any influence on the opening of the container.


                      At the flags that I pass to the opening of my environment, I do not mistake?



                      Thank you for your investment.


                      I will also provide you with my configurations file DB_CONFIG for you to tell me what you think.

                      Edited by: gdievart on 31 janv. 2011 12:46
                      • 23. Re: Degradation of response time
                        637288
                        Hi,

                        Definitely remove auto-indexing. If you can't re-create your container, you should remove auto-indexing, and delete the indexes that you don't need.
                        Which flags are you providing?
                        Can you send you container to me for further checking?

                        Vyacheslav
                        • 24. Re: Degradation of response time
                          792712
                          So I'll test by disabling the auto-indexing.

                          I'm sorry, but I can't provide the container, because the content belongs to the company where I work.

                          I look back after disable auto-indexing.


                          Ty,
                          Guillaume.
                          • 25. Re: Degradation of response time
                            792712
                            My DB_CONFIG

                            set_lk_max_objects 2000
                            set_lg_regionmax 33554432
                            set_lg_dir /path/log
                            set_cachesize 0 26214400 1
                            mutex_set_max 100000
                            set_lk_max_lockers 5000
                            set_lk_max_locks 5000
                            rep_set_request 20000 80000

                            What do you think? I don't make a mistake?
                            • 26. Re: Degradation of response time
                              637288
                              Hi,

                              Looks ok, except that the cache size may be very small for your purposes. You can try to increase the value and then re-create the environment.

                              Also you may want to setup the following flag in DB_CONFIG:
                              set_flags DB_LOG_AUTOREMOVE
                              Vyacheslav
                              • 27. Re: Degradation of response time
                                792712
                                Ok thanks, i try
                                1 2 Previous Next