1 2 Previous Next 18 Replies Latest reply on Jul 20, 2011 1:27 PM by sabir786

    Installing new Apex into oracle 11.1 database

    831141
      install on windows 2003 server - oracle database 11.1 ...
      The Listenerconfig page comes up blank - looking at the glassfish log shows below.
      Jave -version - 1.6.0_23

      I did get the Listener config page to show once but anytime hitting the apply button caused http error... After redeploy of the apex.war can't get that far again...

      Glassfish appears to be working ok...

      ------------------------------
      PWC1406: Servlet.service() for servlet ModApex threw exception java.lang.NoSuchMethodError: java.lang.String.getBytes(Ljava/nio/charset/Charset;)[B at oracle.dbtools.apex.utilities.Text.getBytes(Text.java:31) at oracle.dbtools.apex.ModApex.notifyNotConfigured(ModApex.java:257) at oracle.dbtools.apex.ModApex.doConfig(ModApex.java:98) at oracle.dbtools.apex.ModApex.doGet(ModApex.java:92) at javax.servlet.http.HttpServlet.service(HttpServlet.java:734) at javax.servlet.http.HttpServlet.service(HttpServlet.java:847) at org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:427) at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:315) at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:287) at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:218) at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648) at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593) at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:94) at com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingStandardPipeline.java:98) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:222) at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648) at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593) at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587) at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1093) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:166) at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648) at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593) at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587) at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1093) at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:291) at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:666) at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:597) at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:872) at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:341) at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:263) at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:214) at com.sun.enterprise.web.portunif.PortUnificationPipeline$PUTask.doTask(PortUnificationPipeline.java:382) at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:264) at com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:106)

      thank you                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           
        • 1. Re: Installing new Apex into oracle 11.1 database
          Udo
          Hello,

          which GlassFish version did you deploy the Listener onto? And does this GlassFish actually use the JDK you named? The error you get indicates your GlassFish is using a Java Version prior 1.6

          -Udo
          • 2. Re: Installing new Apex into oracle 11.1 database
            831141
            I downloaded Glassfish from Oracles website version 2.1.1 is on the glassfish main screen...
            • 3. Re: Installing new Apex into oracle 11.1 database
              Udo
              Then your GlassFish is too old. As the documentation states, GlassFish verison 3 or higher (current would be 3.0.1) is required.
              I'd suggest to try again with the current version.

              -Udo
              • 4. Re: Installing new Apex into oracle 11.1 database
                831141
                I'm bad - I've been checking Java versions, and path statements...
                I'll go look for the correct version and update as soon as I try it.
                Thank you
                • 5. Re: Installing new Apex into oracle 11.1 database
                  831141
                  Ok - I've installed Glassfish 3.0.1 (build 22) from Oracles download site.
                  Install and set-up went without a hitch.
                  But when I go to the http://localhost:8080/apexListenerConfigure
                  I get the - resource is not available message.
                  Requested url http://localhost:8080/apex/ListenerConfigure is currently unavailable.
                  • 6. Re: Installing new Apex into oracle 11.1 database
                    831141
                    some additional information -
                    if I stop glassfish and run the Java command
                    java -jar C:\TEMP\Oracle_apex_install\Apex_listener\apex_listener.1.0.2.238.15.24\apex.war
                    then I can access
                    http://localhost:8080/apex
                    I was able to do the admin set-up steps and get into apex ...
                    of course if is shut the command window opened by running the above java command - the listener is nolonger running
                    and so no more access.
                    This suggests to me the apex.war file is ok, and Java install is working....
                    Is Glassfish config the issue? or glassfish install?
                    I've been through the Glassfish config again and can't find anything missing?
                    • 7. Re: Installing new Apex into oracle 11.1 database
                      Udo
                      Does the GlassFish give you any log information that might hint on possible reasons for the "unavailability"?
                      The Listener really does work on the current GlassFish if deployed properly (i.e., step by step as documented). Any "environmental" issue should become recognizable in the log.

                      -Udo
                      • 8. Re: Installing new Apex into oracle 11.1 database
                        831141
                        Well - your right and you must be magical...
                        I stopped and started everything yesterday ....
                        Log files did not show error messages - did show
                        'Loading application apex at /apex'
                        but the browser showed the unavailable message....
                        I did stop glassfish again and ran the Java -jar command and was able to access things... then this morning closed the command window and started glassfish and

                        magically this morning it appears to be working, and I did not change a thing... this makes me nervous?

                        But I'll document and move forward - next step is to set-up as a service on the server. This will be a production application in a week or to for our Finance staff, so I need it to be stable and available without my log on running in windows.

                        I found the directions for setting that up, and will work on today....

                        Thank you for your support and answers and ideas...

                        Edited by: rt701 on Jan 15, 2011 10:25 AM
                        • 9. Re: Installing new Apex into oracle 11.1 database
                          831141
                          After creating the windows service for Glassfish I am not able to access APEX.
                          If I stop the servcie and start Glassfish manually I can Access APEX?
                          No error messages in the logs?
                          Re-boot of the server will be the next step, but I'll need to work with the server SA to complete the re-boot.
                          Any hints or comments are welcome...
                          • 10. Re: Installing new Apex into oracle 11.1 database
                            Udo
                            Could this be a problem with file access permissions? I guess you have different accounts for running it manually or as a service respectively.
                            Are you able to access GlassFish at all when running it as Windows Service?

                            -Udo
                            • 11. Re: Installing new Apex into oracle 11.1 database
                              831141
                              Yes - GlassFish starts as a service without issue and I can access the GUI / url (http://localhost:4848/common/index.jsf) with no issues. Navigation through the tool is fine.
                              After the windows server re-boot same results - Glassfish appears to be working fine but when trying to go to the apex url (http://localhost:8080/apex/apex_admin) returns the message

                              Requested url http://ermdb1test:8080/apex/apex_admin is currently unavailable.

                              I did find in the Glassfish log a message about apex config -
                              Message ID Using Config file
                              Complete Message C:\WINDOWS\TEMP\\apex\apex-config.xml

                              The next message that looks like any kind of error is about the same time I tried to get into APEX -
                              Message ID Cannot refresh Catalog
                              Complete Message Connection refused: connect

                              after stopping the service and starting glassfish manually (with my logon) I see the message
                              Message ID Using Config file
                              Complete Message C:\DOCUME~1\rtaha\LOCALS~1\Temp\\apex\apex-config.xml

                              Looks very much like the apex-config.xml message when running as a service - just different temp locations...

                              Not sure where to look from here?
                              • 12. Re: Installing new Apex into oracle 11.1 database
                                Udo
                                This actually indcicates a problem with file permissions. The Listener tries to access a config file on startup. If you haven't reconfigured the location, it will try the default, which is +${java.io.tmpdir}/apex/apex-config.xml+. If the Listener doesn't find a file there, it tries to create one. You log looks like this fails.
                                You could try to reconfigure the Listener to use a different location (see the section "Configuration File" of the documentation for details) for the config file and put your existing config file (created during the manual startup) there. Next time the service starts up it will look for your configured config file location first and read the file if possible. Make sure, the configured directory and file will be both read- and writable for the service.

                                -Udo
                                • 13. Re: Installing new Apex into oracle 11.1 database
                                  831141
                                  ok - With your help pointing me in the right direction things are working. Here is what I found...
                                  The Java "temp area" defaults to the window temp - which while a user is logged in is
                                  C:\Documents and Settings\username\Local Settings\Temp
                                  But when a service starts - it does not look at user settings it looks at system only settings which for temp on this system is
                                  C:\WINDOWS\Temp

                                  because I completed my apex listener install and configuration before I set glassfish up to run as a service the config file was created in my user temp location.

                                  If I had completed the glassfish set-up and started it as a service before I tried to do the listener setup and configuration, things would have gone much smoother.

                                  Solution - I stopped glassfish and copied the
                                  C:\Documents and Settings\username\Local Settings\Temp\apex
                                  directory to
                                  C:\WINDOWS\Temp
                                  which is the system default temp directory and what Java uses as its default temp work area.

                                  I likely could also have gone through the Listener configure URL - I may try that just for fun. I'm having so much of it...

                                  Thank you for your help - any comments, corrections are welcome.
                                  Documentation shows the search path to find the apex-config.xml on page 53 of the Oracle application Express Listener version 1.0.2. Took a little tracking but hopefully I understand it enough to set the process up again on another server.
                                  • 14. Re: Installing new Apex into oracle 11.1 database
                                    Udo
                                    I'm glad you got it working.
                                    What you describe makes perfect sense. I didn't realize you didn't try to reach the administrative parts of the Listener. The config-file-part really can be confusing sometimes. ;)
                                    If you don't mind, please mark your question as answered and if you like, also mark helpful/correct answers to provide hints for other users hitting this thread.

                                    Thanks,

                                    Udo
                                    1 2 Previous Next