2 Replies Latest reply: Feb 4, 2011 12:30 PM by PHCharbonneau RSS

    Weblogic 10 Slow in prod after 1 - 2 weeks

    831121
      Hello,

      We are using weblogic 10. The systems becomes very slow after 1-2 weeks in production.
      Restarting the servers solves the problems.

      Our application need to remain up 24 x 7. In order to restore the performance we need to restart the servers which causes some downtime.

      Is there any other solution to the problem? Do enterprises normally reatart their production servers on a regular interval?

      Thanks,
      Sastry.
        • 1. Re: Weblogic 10 Slow in prod after 1 - 2 weeks
          user9098154
          Some enterprise cycle on rolling base for a particular interval of time. once in a week.

          setup a job which cycle the jobs on rolling base. and your application will be up and running for 24/7.

          which clear tmp,stage and cache in servers.

          if any other ideas . please let me know.

          Thanks
          Raj
          • 2. Re: Weblogic 10 Slow in prod after 1 - 2 weeks
            PHCharbonneau
            Hi Raj,

            This could be the symptom of a memory leak, building slowly over time. Please capture and share the following data:

            - Before restarting your slow application, capture a JVM Thread Dump
            - Turn on verbose GC (or use any other monitoring tool of your chioce) from your server Java process so you can monitor on a daily basis the Java heap + native (Perm Gen if Sun VM etc.)

            Please provide the specifications of your environment so I can recommend you some troubleshooting tools you can use.

            Regards,
            P-H
            http://javaeesupportpatterns.blogspot.com/