4 Replies Latest reply: Jan 22, 2013 3:43 AM by 804738 RSS

    Weblogic Monitor not working!

      Hi everybody,

      I'm trying monitor the weblogic server of the medrecs application that came with the OATS installation but i can't get it done.
      I configured a new agent with the authentication tool and set up to listen to the 7011 port, also i configured the agent VU in OLT to use this agent, also set up the serverstat data collector with the same 7011 port, and tried to set up a new monitored system, but here is where the erros came, when i go to discover components, it is filled with errors.

      Also tried to configure the serverstats configuration using the data collector i setup earlier and using the default monitored system, it adds the 4 weblogic metrics, but when i hit test, it came with this error

      +"An unhandled exception has occurred in the Application Service. Please retry the action you were performing. If you still experience the same problem, please try the following:+

      +Close your browser and restart Oracle Load Testing.+

      +If the problem continues, restart the Application Service using the Start menu or Services panel.+

      +If the problem persists after restarting the service, please contact Technical Support.+

      +Exception Details:+

      +oracle.oats.core.ApplicationMDBException: Timed out on task id 740 after 240000 ms waiting for a response.: (message id=app.taskTimeout)"+

      I'm trying all this locally on a Windows XP VM and using the weblogic that came with OATS.

      Can anyone help me? what steps should i follow to get the weblogic monitored?


        • 1. Re: Weblogic Monitor not working!
          Hi Cesar,

          Did you copy the weblogic.jar and webservices.jar into the C:\OracleATS\DataCollector\classes\weblogic9.1 directory are restart the agent service?

          • 2. Re: Weblogic Monitor not working!
            Hi Jamie

            I just copied the files, but is still not working, when I hit "Test" after adding the Weblogic metrics, this errors are shown

            Monitor configuration failure alert:
            monitor id=t3://

            (message id=console.configFailureAlert):
            NMP timeout performing Table Get.
            String: my Server

            Same error in all metrics

            The data collector, system is set to the default configurations

            any idea?


            • 3. Re: Weblogic Monitor not working!
              Hi Cesar,

              You should be using JMX as your data source rather than SNMP. An SNMP agent will not be running by default - you would have to configure one. Therefore, you cannot use the Oracle WebLogic Server profile or the metrics contained within. I would recommend utilising JMX and this will give you access to lots of performance metrics for the medrec server.

              1. You should add a Monitored System (Manage -> Systems -> Monitored Systems) where host is localhost, then choose JMX, and set Server Type to Oracle Weblogic, port to 7011 and username/password to weblogic/welcome1.

              2. Then can create a metric for this system (ServerStats -> Metrics -> New). You should be able to choose Discover Components and choose the source for this metric. Repeat for your other metrics required.

              3. Create a configuration to use in your load test (ServerStats -> Configurations). Give it a name and add your metrics created in step 2. Use this configuration Auto-Pilot when you run your load test against the medrec application.

              Hope this helps.

              • 4. Re: Weblogic Monitor not working!

                Eventhough we have add metrics in Serverstats , Serverstats metrics can view run time only. Whether serverstats metrics will get along with Load report ? I mean not displayed after create reports from OLT?

                Any thought on this please share ?

                Edited by: 801735 on Jan 22, 2013 1:42 AM

                Edited by: 801735 on Jan 22, 2013 1:42 AM