2 Replies Latest reply on Jan 27, 2011 9:11 AM by user161771 - oracle

    AdminServer not being able to start via NodeManager and WLST

    834374
      Hi,

      I'm actually very new to NodeManager and WLST. I found this quick start guide http://blogs.oracle.com/jamesbayer/2010/01/weblogic_nodemanager_quick_sta.html and currently facing a problem.

      The error occurs when I'm trying to start AdminServer with NodeManager ---> nmStart('AdminServer')

      I get the following errors:

      -------------
      Starting server AdminServer ...
      Error Starting server AdminServer: weblogic.nodemanager.NMException: Exception while starting server 'AdminServer': java.io.IOException: Server failed to start up. See server o
      t log for more details.
      -------------

      And in AdminServer log,

      -------------

      ####<Jan 26, 2011 2:51:02 AM PST> <Critical> <Security> <US1QCAPPP01> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1296039062409> <BEA-090403> <Authentication for user denied>
      ####<Jan 26, 2011 2:51:02 AM PST> <Critical> <WebLogicServer> <US1QCAPPP01> <AdminServer> <Main Thread> <<WLS Kernel>> <> <> <1296039062409> <BEA-000386> <Server subsystem failed. Reason: weblogic.security.SecurityInitializationException: Authentication for user denied
      weblogic.security.SecurityInitializationException: Authentication for user denied
           at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.doBootAuthorization(Unknown Source)
           at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initialize(Unknown Source)
           at weblogic.security.service.SecurityServiceManager.initialize(Unknown Source)
           at weblogic.security.SecurityService.start(SecurityService.java:141)
           at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
           at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
           at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)

      -------------

      I tried to Google around for clues and found things like boot.properties and nm_password. I've tried both but are not working. I even created a new domain and followed everything again, and it still failed at this stage with the same error.

      Can someone help out with this? Any help is much appreciated (I'm losing hair because of this).
        • 1. Re: AdminServer not being able to start via NodeManager and WLST
          Jay SenSharma MiddlewareMagic
          Hi,

          In "James Bayer's" (http://blogs.oracle.com/jamesbayer/2010/01/weblogic_nodemanager_quick_sta.html) blog you will find a comment at the bottom of the page like following to reset the NodeManager password and to start Managed Server with this password:


          WLST code to change Node Manager Password in WebLogic
          connect(AdminUserName, AdminPassword, 't3://'+AdminServerHost+':'+AdminServerPort)
          edit()
          startEdit()
          
          # Set the Node Manager Password
          cd('/SecurityConfiguration/' + DomainName)
          cmo.setNodeManagerUsername(AdminUserName)
          set('NodeManagerPassword', AdminPassword)
          
          save()
          activate(block="true")
          start managed servers:
          nmConnect(AdminUserName, AdminPassword, AdminServerHost, NodeManagerPort, DomainName, DomainHome, 'ssl')
          nmStart('AdminServer')
          connect(AdminUserName, AdminPassword, 't3://'+AdminServerHost+':'+AdminServerPort)
          start('ManagedServer1', 'Server', block='false')
          .
          .
          Thanks
          Jay SenSharma
          • 2. Re: AdminServer not being able to start via NodeManager and WLST
            user161771 - oracle
            Alvin,

            You can also try starting over with Node Manager. If you left Node Manager in the default location, look in $MW_HOME\wlserver_10.3\common\nodemanager. Rename your nodemanager.properties, nm_data.properties, and nodemanager.domains files to something else such as *.backup. Stop/Start node manager. Now re-enroll the domain with Node Manager with the nmEnroll command. Now try starting with Node Manager and see if you get it. Do you have StartScriptEnabled=true?