6 Replies Latest reply on Jan 28, 2011 8:40 PM by Udo

    Listener configuration problem

    834476
      Hello,

      I've installed the listener to my application server following instruction begining on page 20 of the installation guide.

      Next, I'm trying to do configuration at http://localhost:8888/apex/listenerConfigure.
      I've entered following on the Connection tab screen

      Username: adminlistener
      Password:*******
      Connection Type: Basic
      Hostname: localhost
      Port: 1521
      SID: XE (my local Database Express)

      I'm gettin this error after clicking Apply:

      500 Internal Server Error
      Servlet error:An exception occurred. The current application deployment descriptors do not allow for including it in this response. Please consult the application log for details.

      Being a total novice to the Oracle technology I've no idea what this means and how to fix it.
      Any suggestions are greatly appreciated.
        • 1. Re: Listener configuration problem
          Udo
          Hello,

          if you are on a XE that didn't use any external web server before (e.g. after a fresh XE installation), you have to configure the APEX_PUBLIC_USER first, as documented here:
          http://download.oracle.com/docs/cd/E17556_01/doc/install.40/e15513/otn_install.htm#BABDEEIH

          Unfortunately, this is just part of the APEX Installation Guide, but you have a preinstalled APEX, so you probably didn't perform the steps mentioned there.

          If that's not the reason, could you post the log/console output of your OC4J? (As you posted you followed p. 20ff, I assume you deployed the Listener on a OC4J...) You should see more information (stack trace) which would give a hint on what's wrong.

          -Udo

          Edited by: Udo on 26.01.2011 21:50
          1 person found this helpful
          • 2. Re: Listener configuration problem
            834476
            Hello,

            Thank you for the suggestions.

            The APEX_PUBLIC_USER is unlocked.

            Here's the relevant part of the OC4J log file:

            11/01/27 07:07:37.672 apex: Servlet error

            java.lang.NoSuchMethodError: java.lang.String.getBytes(Ljava/nio/charset/Charset;)[B

                at oracle.dbtools.apex.utilities.Text.getBytes(Text.java:31)

                at oracle.dbtools.apex.ModApex.notifyNotConfigured(ModApex.java:257)

                at oracle.dbtools.apex.ModApex.doConfig(ModApex.java:98)

                at oracle.dbtools.apex.ModApex.doGet(ModApex.java:92)

                at javax.servlet.http.HttpServlet.service(HttpServlet.java:743)

                at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)

                at com.evermind[Oracle Containers for J2EE 10g (10.1.3.1.0) ].server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher
            .java:711)

            at com.evermind[Oracle Containers for J2EE 10g (10.1.3.1.0) ].server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher
            .java:368)

            at com.evermind[Oracle Containers for J2EE 10g (10.1.3.1.0) ].server.http.HttpRequestHandler.doProcessRequest(HttpRequestHandler
            .java:866)

            at com.evermind[Oracle Containers for J2EE 10g (10.1.3.1.0) ].server.http.HttpRequestHandler.processRequest(HttpRequestHandler
            .java:448)

            at com.evermind[Oracle Containers for J2EE 10g (10.1.3.1.0) ].server.http.HttpRequestHandler.serveOneRequest(HttpRequestHandler
            .java:216)

            at com.evermind[Oracle Containers for J2EE 10g (10.1.3.1.0) ].server.http.HttpRequestHandler.run(HttpRequestHandler.java:117)

            at com.evermind[Oracle Containers for J2EE 10g (10.1.3.1.0) ].server.http.HttpRequestHandler.run(HttpRequestHandler.java:110)

            at oracle.oc4j.network.ServerSocketReadHandler$SafeRunnable.run(ServerSocketReadHandler.java:260)

            at com.evermind[Oracle Containers for J2EE 10g (10.1.3.1.0) ].util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor
            .java:303)

            at java.lang.Thread.run(Thread.java:595)



            I've also noticed the Database Express home page has been replaced with APEX homepage (with missing images even though
            I followed instructions to copy them). Is is still possible to use Database Express? And what's the difference between the
            Database Express application building function and APEX?
            • 3. Re: Listener configuration problem
              Udo
              Hello,

              the error message indicates that your OC4J isn't using the appropriate Java version. As denoted in the requirements list of the APEX Listener documentation, you need at least "Java 6 Update 20 JDK or higher".
              If you are unsure which Java version you are currently using, you could enter "java -version" in the command line.

              Concerning your other observation: The "Database Express home page" actually is the APEX start page of the APEX version that ships with your XE database. You probably see the APEX Listeners configuration page first when you haven't configured it before. Probably that is the page you saw at first. You will see the "well known" start page after your Listener is up and running.

              -Udo
              1 person found this helpful
              • 4. Re: Listener configuration problem
                834476
                Udo,

                Thanks again for your suggestions.
                I think my problem is multiple Java versions.

                Issuing "java -version" displays the following:

                "java version 1.5.0_06"
                Java<TM> 2 Runtime Environment, Standard Edition <build 1.5.0_06-b05>
                Java HotSpot Client VM <build 1.5.0_06-b05, mixed mode>

                I don't think it's the right version, is it?

                I do have Java SE Development Kit 6 Update 23 installed on my PC.

                How do I "force" the latest version?

                Derek.
                • 5. Re: Listener configuration problem
                  834476
                  Hi again,

                  I modified may PATH variable and now I'm using Java version 1.6.0_23, which I think is the right one.

                  Unfortunately I still get the same error as described previously.
                  The OC4J log entry is the same as it was under older version of Java.

                  Derek.

                  Edited by: user8655013 on Jan 27, 2011 11:27 AM
                  • 6. Re: Listener configuration problem
                    Udo
                    Hi Derek,

                    as far as I know, OC4J evaluates the environment variable "JAVA_HOME" to determine the Java version it uses. So, if you have your recent Java version in your search path, this does not necessarily mean that OC4J is using it. If you haven't set a JAVA_HOME yet, you could try that. If that doesn't work either, possibly you use a start/stop for controlling your OC4J. Perhaps this (re)sets JAVA_HOME without regard for existing global values.

                    -Udo