This discussion is archived
1 Reply Latest reply: Feb 17, 2011 1:34 PM by 834494 RSS

java.lang.IllegalArgumentException on Zone Management

834494 Newbie
Currently Being Moderated
Hi,

I am unable to use the Solaris Container Manager webapp. I am able to log in to the Oracle Web Console, and then into the SMC. Under "Manage Solaris Containers" it DOES show my host machine and three zones (global + two more), but all links under "Manage Solaris Containers" print an error. The exact stack trace is very long and is here: http://zxcv.pastebin.com/7wcaWM8N (too long to include in this post).

Environment:
- Solaris 10u8
- Sun MC 4.0
- Patches: 143323-03, 138553-09, 143073-01, 139613-04 (Sun Management Center 4.0: Patch for Solaris 10; PRM Patch for Solaris 10; SAM Patch for Solaris 10; SCM Patch for Solaris 10) as recommended by http://forums.halcyoninc.com/showthread.php?t=104
- Tomcat 5.5.30 installed (SUNWtcatu package + patch 122911-24)
- java -version reports "Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_24-b02)" (patches 118666-26, 118667-26)

I've tried restarting webconsole and done es-stop -A and es-start -A.

I have gone all the way through es-setup, and I even tried redoing "es-setup -p PRM" and "es-setup -p SCM" (which did fix another problem I was having).

/usr/local/etc/odbc.ini and odbcinst.ini are symlinks to install-root/SUNWsymon/odbc/etc/odbc.ini and odbcinst.ini.

I've had some trouble with this because the default Tomcat version is 4.0.5 which is way way way too old for my company's Nessus scanner. The Container Manager DID work then. Fortunately for security, one of the patches above enabled the possibility of using the system's tomcat55, gave me Tomcat 5.5.30, and quiesced Nessus. But now the Container Manager won't work.

I use Opera normally, but the same thing happens in IE7.

I've done multiple un- and re-installs, so maybe some cruft is left around. What else should I do besides es-uninst in order to ensure a total uninstall?

Ideas on how to fix the error I'm seeing? Locations of logs to check for errors?

Edited by: 831491 on Jan 26, 2011 10:21 AM to remove invalid link markup
  • 1. Re: java.lang.IllegalArgumentException on Zone Management
    834494 Newbie
    Currently Being Moderated
    Seems the problem was me trying to be clever by trying to disable sunwebconsole's http port.

    Instead, in order to use SMC and pass Nessus scans (no HIGHs at least), you need to:

    (a) Install all SMC patches as noted in the sticky in this Halcyoninc forum (143323-03, 138553-09, 143073-01, 139613-04 as of this writing)
    (b) Install the latest SUNWtcatu patch (122911-xx)
    (c) Firewall off port 6788 (default webconsole http) using IPF. I firewalled it off from everything except localhost and the server's public IP.
    (d) restart webconsole & sunmc* or reboot

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points