3 Replies Latest reply: Feb 3, 2011 2:46 AM by Hungry DBA RSS

    Failing audit vault patch on AV Agent at AV Configuation Assistant

    Hungry DBA

      Applying audit vault patch on top of Audit Vault Agent. Getting following error after 100% installation at the time of Audit Vault Configuation Assistant Components

      Information from Installxxxxxx.log

      OPatch succeeded.

      INFO: Configuration assistant "Oracle Audit Vault Agent One-Off Patches" succeeded
      INFO: Command = oracle.av.common.AvcaCfgPlugIn /oracle/app/oracle/product/10.2.3/av_1/bin/avca -s initialize_agent -agentname agent_hmrac2 -agentusr ${s_agentusr} -agentport 7016 -av HMCSPV0921.HIGHMARK.INTRA:1522:av.HIGHMARK.INTRA -rmiport 3121 -jmsport 3300

      INFO: Configuration assistant "Oracle Audit Vault Configuration Assistant" succeeded
      INFO: All the tools have been executed Successfully
      INFO: The "/oracle/app/oracle/product/10.2.3/av_1/cfgtoollogs/configToolAllCommands" script contains all commands to be executed by the configuration assistants. This file may be used to run the configuration assistants outside of OUI. Note that you may have to update this script with passwords (if any) before executing the same.
      The following configuration scripts need to be executed as the "root" user.
      #Root script to run
      To execute the configuration scripts:
      1. Open a terminal window
      2. Log in as "root"
      3. Run the scripts
      4. Return to this window and click "OK" to continue

      *** End of Installation Page***
      The installation of Oracle Audit Vault Agent 10g was successful.
      WARNING: Do you really want to exit?
      INFO: User Selected: Yes/OK

      INFO: The OUICA command is launched from /oracle/app/oracle/product/10.2.3/av_1/oui/bin/ouica.sh.

      Executed *"/oracle/app/oracle/product/10.2.3/av_1/cfgtoollogs/configToolAllCommands* which has following command and successful.

      [oracle@HMCSPS02 oui]$ cat "/oracle/app/oracle/product/10.2.3/av_1/cfgtoollogs/configToolAllCommands"
      # Copyright (c) 1999, 2009, Oracle. All rights reserved.
      /oracle/app/oracle/product/10.2.3/av_1/bin/avca apply_patchset

      [oracle@HMCSPS02 oui]$ echo $ORACLE_HOME

      [oracle@HMCSPS02 oui]$ sh /oracle/app/oracle/product/10.2.3/av_1/bin/avca apply_patchset
      Deploying to standalone OC4J...
      Restarting agent ...
      Agent restarted successfully.

      Retried component but again failed. Hence executed root.sh and clicked 'Next' button. then message got like 'Agent Installation was successful but some of the components missing,skipped or cancelled which may be functioning properly.

      has my patch upgrade to client was successful or what is the workaround ???

      Any help on this would be appreciated...