This discussion is archived
0 Replies Latest reply: Feb 15, 2011 11:54 AM by 650400 RSS

Error in running web logic/forms locally: wrong signature

650400 Newbie
Currently Being Moderated
Hi,

We are trying to configure oracle forms/reports 11g on each developer machine.
In running form from either forms builder or IE I'm getting an error:

...
Forms Session ID is formsapp.2
The proxy host is null, and the proxy port is 0.
Native HTTP implementation is being used for the connection.
The connection mode is HTTP.
FRM-92090: unexpected fatal error in client-side Java code during startup
Java Exception:
java.lang.RuntimeException: java.lang.SecurityException: class "oracle.forms.engine.Version"'s signer information does not match signer information of other classes in the same package
     at sun.plugin2.applet.Plugin2ClassLoader.checkPackageCerts(Unknown Source)
     at sun.plugin2.applet.Plugin2ClassLoader.access$200(Unknown Source)
     at sun.plugin2.applet.Plugin2ClassLoader$2.run(Unknown Source)
     at java.security.AccessController.doPrivileged(Native Method)
     at sun.plugin2.applet.Plugin2ClassLoader.findClassHelper(Unknown Source)
     at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
     at java.lang.ClassLoader.loadClass(Unknown Source)
     at java.lang.ClassLoader.loadClass(Unknown Source)
     at oracle.forms.engine.Runform.createInitialMessage(Unknown Source)
     at oracle.forms.engine.Runform.sendInitialMessage(Unknown Source)
     at oracle.forms.engine.Runform.startRunform(Unknown Source)
     at oracle.forms.engine.Main.createRunform(Unknown Source)
     at oracle.forms.engine.Main.start(Unknown Source)
     at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
     at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.SecurityException: class "oracle.forms.engine.Version"'s signer information does not match signer information of other classes in the same package
     ... 15 more

I have signed all jar files in \forms\java and \Oramw11gdev\asdev1\jlib and confirmed that they are correctly referenced in registry and default.env. I also verified all jars. Still error is there.

Haven't seen this problem with forms 10g.

Any suggestions?

Env: Win7/32bit, Oracle Forms 11g, Java 1.6, Forms Builder v.11.1.1.3.0; Java Plug-in 1.6.0_18
Using JRE version 1.6.0_18-b07

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points