This discussion is archived
1 Reply Latest reply: Mar 17, 2011 2:34 AM by 710808 RSS

404 Page not found while accessing through OHS

640803 Newbie
Currently Being Moderated
Hi,

I have deployed my ADF Application on Weblogic Server under one Managed Server (http port 7004).

Configuration of Weblogic Server : Weblogic Server 10.3.3.0 with ADF runtime 11.1.1.3.0 and Web Tier Utilities 11.1.1.3.0

To access my application through Managed Server url is http://adf.company.com:7004/ADFApplication

To access my application through OHS url is http://adf.company.com:7777/ADFApplication

If I try this url directly on web browser it works fine. It will take me to login page as expected.

I created also a local webpage which resided outside weblogic server, which will post login details to this url to bypass login and take me to welcome page.

Contents of the html :

<html>
<head>
<title>Login Page for Examples</title>
<body bgcolor="white">
<form method="POST" action='http://adf.company.com:7004/ADFApplication/j_security_check' >
<table border="0" cellspacing="5">
<tr>
<th align="right">Username:</th>
<td align="left"><input type="text" name="j_username" value="user1"></td>
</tr>
<tr>
<th align="right">Password:</th>
<td align="left"><input type="password" name="j_password" value="password1"></td>
</tr>
<tr>
<td align="right"><input type="submit" value="Log In"></td>
<td align="left"><input type="reset"></td>
</tr>
</table>
</form>
</body>
</html>

This works perfectly when I am accessing url to Managed Server . that is 'http://adf.company.com:7004/ADFApplication/j_security_check'

But when I am trying to accessi url through OHS. that is 'http://adf.company.com:7777/ADFApplication/j_security_check' it gives me error
404 Page not found. But if i try one more time it will take me correctly to welcome page.

I checked OHS log also. there i got one error as given below:
Message ID OHS-9999
Message Level 32
VirtualHost main
Relationship ID 0
Component OHS
Module core.c
Message : File does not exist: /user1/weblogic/Oracle/Middleware/Oracle_WT1/instances/instance_adf/config/OHS/ohs_adf/htdocs/ADFApplication;ADFSESSIONID=139hNlFdP8YNJG2yWJcGWxlTJg5ly6QKQQ7GT1pvh9VvsS1vHy0W!39022354, referer: http://myaepinfra.company.com:7777/pls/orasso/ORASSO.wwsso_app_admin.fapp_process_login?p_app_id=ECAA3DF737D66FF5F367E41634802369&p_url_name=&p_url_value=

This happens again once I close current browser instance and take another browser instance.

Following is the entry under mod_wl_ohs.conf

<IfModule weblogic_module>
# WebLogicHost <WEBLOGIC_HOST>
# WebLogicPort <WEBLOGIC_PORT>
# Debug ON
# WLLogFile /tmp/weblogic.log
# MatchExpression *.jsp
WebLogicHost adf.company.com
DynamicServerList Off
WebLogicPort 7001
<Location /ADFApplication>
SetHandler weblogic-handler
WebLogicHost adf.company.com
WebLogicPort 7004
</Location>
MatchExpression *.jsp
</IfModule>

I have no idea, why Web Tier is behaving like this.
Please help to solve this issue.

Thanks in Advance,
Santhosh

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points