1 2 Previous Next 21 Replies Latest reply on Mar 4, 2011 8:50 PM by YoungWinston

    .jar file from Ver 5, will not run with Ver 6

    844187
      I have a little GUI based utility which is a .jar file, that I have been using for years.

      It works just fine with JAVA Version 5.0 (for me, its Update 6). More specifically, I have "J2SE Runtime Environment 5.0 Update 6".

      If I attempt to update to any JAVA Version 6 (like Update 24). it fails to even start. If I click on the .jar file, nothing happens. No errors but also no GUI window opens. I also tried to directly start it with a command line "java -jar xxxx.jar". Still nothing.

      Since I am using Windows 7 Pro 32-bit, I would really like to update to JAVA Ver 6.

      The readme files all claim that JAVA is always back compatible. So, I am at a loss as to even where to start to debug this. Again, all I have is a .jar file with some class files and GIF's within it.

      Can anyone offer me some direction?
        • 1. Re: .jar file from Ver 5, will not run with Ver 6
          jschellSomeoneStoleMyAlias
          ...If I click on the .jar file, nothing happens. No errors
          The first precludes any possibility of the second.

          Instead open a console window and the explicitly run the jar from there.
          So, I am at a loss as to even where to start to debug this
          Install a newer jdk. Install a debugger. Run it in the debugger.
          • 2. Re: .jar file from Ver 5, will not run with Ver 6
            844187
            >

            Instead open a console window and the explicitly run the jar from there.
            OK, how do I do that?
            jschell wrote:
            Install a newer jdk. Install a debugger. Run it in the debugger.
            OK, how do I do that?

            -----

            Remember, I am nothing more than an end user attempting to upgrade his version of JAVA, without suffering from all of his existing JAVA programs (the .jar files) no longer working.

            I need very basic help. I need clear, step by step, instructions.

            Has his problem never happen to anyone else? Honestly, I was hoping that there was some experience I can tap into here, where the same thing happen to others, and someone already knows the solution/fix.
            • 3. Re: .jar file from Ver 5, will not run with Ver 6
              793415
              841184 wrote:
              ..Remember, I am nothing more than an end user ..
              What is to 'remember'? It is the first time it has been mentioned.

              In that case, I would give you the same advice I'd give to any end user when they experience a problem with a piece of Java based software. Take it back to the developer(s). They are the only people who can fix the problem, and the only ones who might deeply care.

              These community forums are not really geared to solving end-user problems, in any case. But if the developers don't know how to fix their own app., they might find some help here. That it is really up to them to ask.
              • 4. Re: .jar file from Ver 5, will not run with Ver 6
                gimbal2
                841184 wrote:
                Has his problem never happen to anyone else?
                Yes, and in all cases the application was broken.
                • 5. Re: .jar file from Ver 5, will not run with Ver 6
                  abillconsl
                  Andrew Thompson wrote:
                  841184 wrote:
                  ..Remember, I am nothing more than an end user ..
                  What is to 'remember'? It is the first time it has been mentioned.

                  In that case, I would give you the same advice I'd give to any end user when they experience a problem with a piece of Java based software. Take it back to the developer(s). They are the only people who can fix the problem, and the only ones who might deeply care.

                  These community forums are not really geared to solving end-user problems, in any case. But if the developers don't know how to fix their own app., they might find some help here. That it is really up to them to ask.
                  There are two things I can think of that the OP can do; one to try to get it to run (though likely not) and one to add some information in his request for help:

                  1. right click on the jarfile and choose 'open with' and 'choose program'. You might need to track down the correct executable to run it in your v6/bin folder;
                  2. hit 'start' | run | and enter 'cmd' and 'OK'. This is how you get your command prompt. Then go to the folder where your jarfile is and type in:
                  java -jar yourjarfilename.jar
                  ... You should see whatever Exceptions pop up on the command. This is what jschell meant earlier. You can give this information to the developer.
                  • 6. Re: .jar file from Ver 5, will not run with Ver 6
                    826856
                    Step by step

                    1. Google for java 1.6 jre installable and download the setup
                    2. run the executable
                    3. Make sure your env variables are all set.


                    You are good to go
                    • 7. Re: .jar file from Ver 5, will not run with Ver 6
                      EJP
                      You are good to go
                      Or not, as the case may be. It depends how broken the application is.
                      • 8. Re: .jar file from Ver 5, will not run with Ver 6
                        793415
                        EJP wrote:
                        You are good to go
                        Or not, as the case may be. It depends how broken the application is.
                        Especially in cases where, as had been stated on the first post:
                        If I attempt to update to any JAVA Version 6 (like Update 24). it fails to even start.
                        (Emphasis mine - so hopefully it sinks in this time.)
                        • 9. Re: .jar file from Ver 5, will not run with Ver 6
                          826856
                          would it be better to check which version they have compiled the jar

                          and install the appropriate jvm.
                          • 10. Re: .jar file from Ver 5, will not run with Ver 6
                            Tolls
                            ML Venkatesh wrote:
                            would it be better to check which version they have compiled the jar

                            and install the appropriate jvm.
                            Did you read the OP?
                            They know it was compiled on Java 5, and runs on 5.
                            They want to upgrade to 6...
                            Getting them to move back to 5 does not solve their problem.
                            1 person found this helpful
                            • 11. Re: .jar file from Ver 5, will not run with Ver 6
                              844187
                              841184 wrote:
                              If I attempt to update to any JAVA Version 6 (like Update 24). it fails to even start.
                              If I click on the .jar file, nothing happens. No errors but also no GUI window opens.
                              I also tried to directly start it with a command line "java -jar xxxx.jar".  Still nothing.
                              abillconsl wrote:2. hit 'start' | run | and enter 'cmd' and 'OK'. This is how you get your command prompt. Then go to the folder where your jarfile is and type in:
                              java -jar yourjarfilename.jar
                              ... You should see whatever Exceptions pop up on the command. This is what jschell meant earlier. You can give this information to the developer.
                              As I mentioned originally, I see nothing. No GUI. No error msgs. It doesn't even appear to be attempting to execute with Ver 6.

                              Edited by: 841184 on Mar 4, 2011 4:03 AM
                              • 12. Re: .jar file from Ver 5, will not run with Ver 6
                                844187
                                EJP wrote:
                                You are good to go
                                Or not, as the case may be. It depends how broken the application is.
                                Isn't JAVA suppose to be back compatible? If my .jar executable works just fine under Ver 5, should it not also run under Ver 6?
                                • 13. Re: .jar file from Ver 5, will not run with Ver 6
                                  EJP
                                  ML Venkatesh, please stop posting irrelevant guesswork here.
                                  • 14. Re: .jar file from Ver 5, will not run with Ver 6
                                    EJP
                                    Of course it should. The way you describe it you have a broken installation of Java 6. Can you run any other Java applications? Can you run java -version? If so, what does it print?
                                    1 2 Previous Next