1 Reply Latest reply on Mar 7, 2011 12:54 PM by Haakon

    java error when trying to install 1.1 standalone on Win 64b server

    Haakon
      Hi,

      just downloaded the new 1.1 release and tried to set it up as a standalone Apex listener on our Windows Server 2008 64-bit database server. Got Oracle 11.2.0.2 64-bit running on it, and are using the java install from that installation to install the Apex listener.

      - unzipped the listener zip-file to d:\temp
      - when trying to install with "java -jar D:\temp\listener\apex.war" I get:

      INFO: Starting: D:\temp\listener\apex.war
      +See: 'java -jar apex.war --help' for full range of configuration options+
      INFO: Extracting to: C:\Users\haakon\AppData\Local\Temp\apex
      SEVERE: java.lang.System.console()Ljava/io/Console;
      java.lang.NoSuchMethodError: java.lang.System.console()Ljava/io/Console;
      at ____embedded.____EntryPoint.apexImages(____EntryPoint.java:103)
      at ____embedded.____EntryPoint.main(____EntryPoint.java:90)

      - trying to specify a specific apex.home & apex.images directory (pointing to the images-directory in a complete installation of Apex 4.0.2) on the java command line results in the same error.
      I can see that the installer has created the apex.home in this last attempt.

      I'm running this as a domain user with admin-rights on the server.
      Is this a 64-bit problem, or something else? Should I use a different java-version than the one installed with the 11.2.0.2 database when trying this?

      Regards,
      Haakon
        • 1. Re: java error when trying to install 1.1 standalone on Win 64b server
          Haakon
          Tried a quick install on my local workstation with Win7 64-bit and java runtime v. 1.6.0_23 and everything worked fine just as documented.

          So, downloaded a new java runtime distro to the Win2008 server and tried installing with that, and eventually I got the listener running. Had to start it twice, since the first startup gave an "Invalid" errormessage when opening the listener configuration page. Second go without any changes to config worked fine.... Don't know why...

          So, problem solved so far :-)