5 Replies Latest reply on Jan 26, 2013 4:49 AM by 987276

    OIM 11g Installation - Oracle_IDM1/bin/config.sh : segmentation fault

    844004
      Hello,

      I'm installing all the components on a single machine : CentOS 5.5 64bits (equivalent to RH5.5).

      Here are the steps that I followed :
      1) I installed Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 and WebLogic Server Version: 10.3.3.0
      2) I applied the Repository Creation Utility ofm_rcu_linux_11.1.1.3.3
      3) I installed SOA Suite ofm_soa_generic_11.1.1.2.0 then patched it using ofm_soa_generic_11.1.1.3.0 (Installation without configuration)
      4) I installed Oracle Identity and Access Management ofm_soa_generic_11.1.1.3.0
      5) I created a Weblogic domain using +$ORACLE_MWHOME/Oracle_IDM1/common/bin/config.sh+
      6) I started Weblogic and the Node Manager
      7) When I run the configuration tool cd $ORACLE_MWHOME/Oracle_IDM1/bin then +./config.sh+ I had a segmentation fault error :
      Preparing to launch Oracle Universal Installer from /tmp/OraInstall2011-03-08_02-13-15PM. Please wait ..../config.sh: line 159: 11022 Segmentation fault      $INSTALLER_DIR/runInstaller -weblogicConfig ORACLE_HOME="$ORACLE_HOME" -invPtrLoc $ORACLE_HOME/oraInst.loc -oneclick $COMMANDLINE -Doracle.config.mode=true

      when I run it using strace, I saw that the installer can't find a libc.mo file :

      open("/usr/share/locale/en_US.UTF-8/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
      open("/usr/share/locale/en_US.utf8/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
      open("/usr/share/locale/en_US/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
      open("/usr/share/locale/en.UTF-8/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
      open("/usr/share/locale/en.utf8/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
      open("/usr/share/locale/en/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
      write(2, "./config.sh: line 159:  8897 Seg"..., 209./config.sh: line 159:  8897 Segmentation fault      $INSTALLER_DIR/runInstaller -weblogicConfig ORACLE_HOME="$ORACLE_HOME" -invPtrLoc $ORACLE_HOME/oraInst.loc -oneclick $COMMANDLINE -Doracle.config.mode=true
      +) = 209+

      So I made a symbolic link to one that actually exists :
      sudo ln -s /usr/share/locale/en_GB/LC_MESSAGES/libc.mo /usr/share/locale/en/LC_MESSAGES/libc.mo

      Now the installer can find it, but I still have a segfault :

      open("/usr/share/locale/en_US.UTF-8/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
      open("/usr/share/locale/en_US.utf8/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
      open("/usr/share/locale/en_US/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
      open("/usr/share/locale/en.UTF-8/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
      open("/usr/share/locale/en.utf8/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
      open("/usr/share/locale/en/LC_MESSAGES/libc.mo", O_RDONLY) = 3
      +fstat(3, {st_mode=S_IFREG|0644, st_size=1474, ...}) = 0+
      mmap(NULL, 1474, PROT_READ, MAP_PRIVATE, 3, 0) = 0x2b2d76c27000
      close(3)                                = 0
      write(2, "./config.sh: line 159:  9160 Seg"..., 209./config.sh: line 159:  9160 Segmentation fault      $INSTALLER_DIR/runInstaller -weblogicConfig ORACLE_HOME="$ORACLE_HOME" -invPtrLoc ORACLE_HOME/oraInst.loc -oneclick $COMMANDLINE -Doracle.config.mode=true
      +) = 209+

      Any idea on what would be the reason for that ?

      Thanks in advance !