This discussion is archived
11 Replies Latest reply: Feb 19, 2013 5:24 AM by user2579984 RSS

WUT-121 The file transfer has been forbidden by the Administrator

561943 Newbie
Currently Being Moderated
I am trying to upload a file on a mapped direcotry (Z:\) on Application Server throug forms using webutil_file_transfer.Client_To_AS_with_progress but recieving
WUT-121 The file transfer has been forbidden by the Administrator error.
  • 1. Re: WUT-121 The file transfer has been forbidden by the Administrator
    FrançoisDegrelle Oracle ACE
    Currently Being Moderated
    Hello,

    Did you allow this drive in the webutil.cfg file ?

    Francois
  • 2. Re: WUT-121 The file transfer has been forbidden by the Administrator
    Amatu Allah Guru
    Currently Being Moderated
    Hi
    WUT-121 This file transfer has been forbidden by the Administrator.
    
    Type: User
    
    Description: The Administrator has forbidden file transfers in the webutil.cfg file.
    
    Resolution: If the restriction is not deliberate, update your webutil.cfg file with the correct permissions.
    So u have to enable this in ur webutil.cfg as Francois Mentioned.

    just try to change this in ur webutil.cfg
    #NOTE: By default the file transfer is disabled as a security measure
    transfer.database.enabled=TRUE
    transfer.appsrv.enabled=TRUE
    transfer.appsrv.workAreaRoot=d:\temp
    transfer.appsrv.accessControl=TRUE
    #List transfer.appsrv.read.<n> directories
    #transfer.appsrv.read.1=d:\temp
    #any access on the disk client
    transfer.appsrv.read.1=d:\
    transfer.appsrv.read.2=c:\
    pls note that the directory temp should be share mode. & full access to everyone who will access the directory.


    Hope this helps...

    Regards,

    Abdetu...
  • 3. Re: WUT-121 The file transfer has been forbidden by the Administrator
    561943 Newbie
    Currently Being Moderated
    yes i have the entry of mapped directory in webutil configuration file. when i upload the file on d:\temp then file is uploading successfully but no uploading on mapped drictory.

    #NOTE: By default the file transfer is disabled as a security measure
    transfer.database.enabled=TRUE
    transfer.appsrv.enabled=TRUE
    transfer.appsrv.workAreaRoot=C:\webutil\log
    transfer.appsrv.accessControl=TRUE
    #List transfer.appsrv.read.<n> directories
    #transfer.appsrv.read.1=C:\webutil\log
    #transfer.appsrv.read.2=C:\webutil\lib
    transfer.appsrv.read.1=D:\temp
    #transfer.appsrv.read.1=D:\data
    #transfer.appsrv.read.1=Z:\

    #List transfer.appsrv.write.<n> directories
    #transfer.appsrv.write.1=C:\webutil\log
    #transfer.appsrv.write.2=C:\webutil\lib
    transfer.appsrv.write.1=D:\temp
    #transfer.appsrv.write.1=D:\data
    #transfer.appsrv.write.1=Z:\
  • 4. Re: WUT-121 The file transfer has been forbidden by the Administrator
    Amatu Allah Guru
    Currently Being Moderated
    Al-Salamu Alikum We Rahmatu Allah We Barakatu...

    Faisal i suggest not using webutil as a directory name cause it's a reserved word pls use test and share it Fully...

    and what is Z ? PLs follow the steps and sequence i gave it to u as it is and try if it works try to modify it we will c ?!

    Hope this helps...

    Regards,

    Abdetu...
  • 5. Re: WUT-121 The file transfer has been forbidden by the Administrator
    561943 Newbie
    Currently Being Moderated
    wswb,

    dear Z:\ is mapped directory on application server(192.168.0.82) which full path is \\10.50.2.202\TEST_MAP. i have mapped a diretory on as which is on another machine. i want to upload on this mapped directory. file is uploading on server drives but not on this mapped dir.
  • 6. Re: WUT-121 The file transfer has been forbidden by the Administrator
    CraigB Guru
    Currently Being Moderated
    Looking at your settings, the entry for the Z-Drive is commented out:
    #transfer.appsrv.write.1=Z:\ 
    Remove the "#" to uncomment the line. Also, is the Z-Drive mapped to the Application Server or only on the Client PC?

    Craig B-)

    If someone's response is helpful or correct, please mark it accordingly.
  • 7. Re: WUT-121 The file transfer has been forbidden by the Administrator
    561943 Newbie
    Currently Being Moderated
    after uncommented i am recieving same error. Z-Drive is mapped to the Application Server only, it is not mapped on client.
  • 8. Re: WUT-121 The file transfer has been forbidden by the Administrator
    Amatu Allah Guru
    Currently Being Moderated
    Al-Salamu Alikum We Rahmatu Allah We Barakatu..

    To eliminate the error, pls just change the
    transfer.appsrv.read.1=Z:\    
    
    transfer.appsrv.write.1=Z:\    
    InTo > * as follows:

    transfer.appsrv.read.1=*
    
    transfer.appsrv.write.1=*
    This works Well in Windows XP

    Hope it helps u Solving ur Problem... :)

    Regards,

    Abdetu...
  • 9. Re: WUT-121 The file transfer has been forbidden by the Administrator
    Andreas Weiden Guru
    Currently Being Moderated
    Again that bad advice.... :(

    I would definitely do not use * for transfer.appsrv.write.1 because it opens up the whole applicationserver for writing. You can overwrite any file accessible to the oracle-user, even all the application-server config-files.

    So you should try to open as less directories as possible. Start with a local drive, and if that succeeds, try a network drive. As far as i remember there were some problems recorded with using webutil and network-drives.
  • 10. Re: WUT-121 The file transfer has been forbidden by the Administrator
    Charon Explorer
    Currently Being Moderated
    Apart from all the other points, under which user did you map the directory to "Z"?

    If you didn't change this, the Application-Server will run under the user "SYSTEM". If you logged into your Server as the Administrator and mapped the directory there, the user "SYSTEM" wouldn't know about this. Apart from that, usually the user "SYSTEM" has no access to others computers/servers in you domain. You could grant him this access through you Active-Directory, but i wouldn't recommend this.

    We had a similar problem and created a new user to run our Application-Server under, and this user has just a few finely crafted access rights to others servers. We didn't use mapped directories though, but used UNC-paths instead. This way there is no need to map the directory. If the user has access rights he can use the UNC-path.

    (attention, we didn't use this with the webutil transfer folders, so it might not work)

    Regards and good luck
    Markus

    Edited by: Charon on Mar 11, 2011 1:23 PM
  • 11. Re: WUT-121 The file transfer has been forbidden by the Administrator
    user2579984 Newbie
    Currently Being Moderated
    Dear all.
    I've managed to get this bug also.
    Most of the time spent to resolve it was taken to realize the fact that
    we have TWO PLACES where transfer.* parameters are stored,
    namely webutil.cfg and formsweb.cfg files of the instance.

    After that everything has become easy. I've just assigned the same values to the similiar transfer.* parameters in BOTH files not wasting tiime
    to discover which of these files truely contain transfer.* parameters affecting file transfer. As it was advised in the thread I used the following values:
    transfer.database.enabled=TRUE
    transfer.appsrv.enabled=TRUE
    transfer.appsrv.workAreaRoot=
    transfer.appsrv.accessControl=FALSE
    transfer.appsrv.read.1=*
    transfer.appsrv.write.1=*

    accepting that '*' are security holes.

    Regards,
    Alexey.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points