This discussion is archived
3 Replies Latest reply: Mar 16, 2011 6:10 AM by rukbat RSS

My one Sun machine is not able to ssh another machine of Sun

845297 Newbie
Currently Being Moderated
My one Sun machine is not able to ssh another machine of Sun. Although I have configured the ssh successfully

( SunOS sunbox2 5.9 Generic_118558-34 sun4u sparc SUNW,Sun-Blade-2500 )

ERROR

bash-2.05# ssh sunbox2
/etc/ssh/ssh_config: line 34: Bad configuration option: PermitRootLogin
/etc/ssh/ssh_config: terminating, 1 bad configuration options

bash-2.05# ssh sunbox1
/etc/ssh/ssh_config: line 34: Bad configuration option: PermitRootLogin
/etc/ssh/ssh_config: terminating, 1 bad configuration options

sunbox1
bash-2.05# cat /.ssh/authorized_keys2
ssh-rsa AAAAB3NzaC1yc2EAAAABIwAAAIEArjG/CP71Uh+V6NwOnyA9wZheyhnIKDo7tX57WxtZBFwfkhRQuPFyBQktRe6ApGcG0F/t7j69AIoJ+Jw/hmYCLHmErr+qqVUC2bTtIqXhV2UTUaYQVOVp4S8cgDA3X4ysG5gO76f4Md5q+TvdczkKSQDR9bJ5dJnVgpQ5f8CKJd8= root@sunbox1
ssh-rsa AAAAB3NzaC1yc2EAAAABIwAAAIEAzFyIpD//mOzZMlNAXF0o0KjSSt6yDwKeyoAqo1cKIZVNRpSTufyNlBUJldrOwRZS4h55qLiUNkvSZKhGtzrkGoOLtUdAhNdw7gtVNwjeHy2eKMEqnZBZICVqSIt8UIBK4Aw81lHZbSJ9ioymEtu7KLHsn6N3Pky0mqyDxAZNiUc= root@sunbox2




bash-2.05# cat /etc/ssh/ssh_config
# Copyright (c) 2001 by Sun Microsystems, Inc.
# All rights reserved.
#
# ident "@(#)ssh_config 1.2 01/10/08 SMI"
#
# This file provides defaults for ssh(1).
# The values can be changed in per-user configuration files $HOME/.ssh/config
# or on the command line of ssh(1).

# Configuration data is parsed as follows:
# 1. command line options
# 2. user-specific file
# 3. system-wide file /etc/ssh/ssh_config
#
# Any configuration value is only changed the first time it is set.
# host-specific definitions should be at the beginning of the
# configuration file, and defaults at the end.

# Example (matches compiled in defaults):
#
# Host *
# ForwardAgent no
# ForwardX11 no
# PubkeyAuthentication yes
# PasswordAuthentication yes
# FallBackToRsh no
# UseRsh no
# BatchMode no
# CheckHostIP yes
# StrictHostKeyChecking ask
# EscapeChar~
GSSAPIKeyExchange no
GSSAPIAuthentication no
PermitRootLogin yes
bash-2.05#





sunbox2

bash-2.05# cat /.ssh/authorized_keys2
ssh-rsa AAAAB3NzaC1yc2EAAAABIwAAAIEAzFyIpD//mOzZMlNAXF0o0KjSSt6yDwKeyoAqo1cKIZVNRpSTufyNlBUJldrOwRZS4h55qLiUNkvSZKhGtzrkGoOLtUdAhNdw7gtVNwjeHy2eKMEqnZBZICVqSIt8UIBK4Aw81lHZbSJ9ioymEtu7KLHsn6N3Pky0mqyDxAZNiUc= root@sunbox2
ssh-rsa AAAAB3NzaC1yc2EAAAABIwAAAIEArjG/CP71Uh+V6NwOnyA9wZheyhnIKDo7tX57WxtZBFwfkhRQuPFyBQktRe6ApGcG0F/t7j69AIoJ+Jw/hmYCLHmErr+qqVUC2bTtIqXhV2UTUaYQVOVp4S8cgDA3X4ysG5gO76f4Md5q+TvdczkKSQDR9bJ5dJnVgpQ5f8CKJd8= root@sunbox1




bash-2.05# cat /etc/ssh/ssh_config
# Copyright (c) 2001 by Sun Microsystems, Inc.
# All rights reserved.
#
# ident "@(#)ssh_config 1.2 01/10/08 SMI"
#
# This file provides defaults for ssh(1).
# The values can be changed in per-user configuration files $HOME/.ssh/config
# or on the command line of ssh(1).

# Configuration data is parsed as follows:
# 1. command line options
# 2. user-specific file
# 3. system-wide file /etc/ssh/ssh_config
#
# Any configuration value is only changed the first time it is set.
# host-specific definitions should be at the beginning of the
# configuration file, and defaults at the end.

# Example (matches compiled in defaults):
#
# Host *
# ForwardAgent no
# ForwardX11 no
# PubkeyAuthentication yes
# PasswordAuthentication yes
# FallBackToRsh no
# UseRsh no
# BatchMode no
# CheckHostIP yes
# StrictHostKeyChecking ask
# EscapeChar ~
GSSAPIKeyExchange no
GSSAPIAuthentication no
PermitRootLogin yes
bash-2.05#

Edited by: 842294 on Mar 16, 2011 12:41 AM

Edited by: 842294 on Mar 16, 2011 1:13 AM

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points