8 Replies Latest reply: Mar 21, 2011 12:51 PM by 389675 RSS

    VirtualBox Additions

      I am trying to install the VIrtualBox Additions 4.0.4_70112 with Windows 7 host and an Oracle Linux 5 guest system. When I run the /etc/init.d/vboxadd setup I receive the following error. My current kernel is I did a full yum update prior to this.

      [root@localhost ~]# /etc/init.d/vboxadd setup
      Removing existing VirtualBox DKMS kernel modules/etc/init.d/vboxadd: line 343: uninstall: command not found
      [  OK  ]
      Removing existing VirtualBox non-DKMS kernel modules [  OK  ]
      Building the VirtualBox Guest Additions kernel modules
      The headers for the current running kernel were not found. If the following
      module compilation fails then this could be the reason.
      The missing package can be probably installed with
      yum install kernel-devel-2.6.18-238.el5xen
      Your system does not seem to be set up to build kernel modules.
      Look at /var/log/vboxadd-install.log to find out what went wrong.
      Once you have corrected it, you can run

      /etc/init.d/vboxadd setup

      to build them.

      Doing non-kernel setup of the Guest Additions [  OK  ]
        • 1. Re: VirtualBox Additions
          Avi Miller-Oracle
          Did you even read the error? It tells you how to fix it:
           # yum install kernel-devel-2.6.18-238.el5xen
          # /etc/init.d/vboxadd setup
          You probably need to install the Public Yum repository data from http://public-yum.oracle.com before yum will install that package.
          • 2. Re: VirtualBox Additions
            Yes, it says that I am up to date

            [root@localhost ~]# yum install kernel-devel
            Setting up Install Process
            Package kernel-devel-2.6.18-238.el5.x86_64 already installed and latest version
            Nothing to do
            • 3. Re: VirtualBox Additions
              I just did a yum install kernel-xen-devel and then ran sh ./VBoxLinuxAdditions.run . Everything ran fine, now it just keeps rebooting and giving me the following error

              <0>kernel panic - not syncing: fatal exception
              • 4. Re: VirtualBox Additions
                Herbert van den Bergh-Oracle
                Install the regular kernel, not the xen kernel. The xen kernel is modified to run on top of a Xen hypervisor, and may conflict with the virtualbox guest additions.

                yum install kernel kernel-devel
                edit /boot/grub/grub.conf and make the regular kernel the default, and reboot
                • 5. Re: VirtualBox Additions
                  Here is a snap-shot of my grub.conf, what should I change. I am fairly new to Linux. Thanks for your help

                  # grub.conf generated by anaconda
                  # Note that you do not have to rerun grub after making changes to this file
                  # NOTICE: You have a /boot partition. This means that
                  # all kernel and initrd paths are relative to /boot/, eg.
                  # root (hd0,0)
                  # kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
                  # initrd /initrd-version.img
                  title Oracle Linux Server (2.6.18-238.el5xen)
                       root (hd0,0)
                       kernel /xen.gz-2.6.18-238.el5
                       module /vmlinuz-2.6.18-238.el5xen ro root=/dev/VolGroup00/LogVol00 rhgb quiet
                       module /initrd-2.6.18-238.el5xen.img
                  title Oracle Linux Server (2.6.18-238.el5)
                       root (hd0,0)
                       kernel /vmlinuz-2.6.18-238.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
                       initrd /initrd-2.6.18-238.el5.img
                  title Enterprise Linux (2.6.18-8.el5xen)
                       root (hd0,0)
                       kernel /xen.gz-2.6.18-8.el5
                       module /vmlinuz-2.6.18-8.el5xen ro root=/dev/VolGroup00/LogVol00 rhgb quiet
                       module /initrd-2.6.18-8.el5xen.img
                  title Enterprise Linux-base (2.6.18-8.el5)
                       root (hd0,0)
                       kernel /vmlinuz-2.6.18-8.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet divider=10
                       initrd /initrd-2.6.18-8.el5.img
                  • 6. Re: VirtualBox Additions
                    Herbert van den Bergh-Oracle
                    Change "default=0" to "default=1" and reboot
                    • 7. Re: VirtualBox Additions
                      Thanks so much. I was able to load the Additions.

                      One last question.

                      I have a 1920X1080 monitor. I changed the /etc/X11xorg/conf file to put the mode in, but the 1920X1080 is not showing up in the Screen Resolution under System Preferences. Any ideas.

                      Section "Screen"
                      Identifier "Screen[0]"
                      Device "Device[0]"
                      Monitor "Monitor[0]"
                      SubSection "Display"
                      Depth 24
                      Modes "1920X1080" "1280X960" "1024X768" "800X600"
                      • 8. Re: VirtualBox Additions
                        This was solved by pressing Right-Ctrl and C