2 Replies Latest reply on Apr 6, 2011 12:26 PM by 802051

    7000 series and NFS for ESX VM Storage

      We currently use iSCSI LUNs on our 7310 to store all our VMs, and I wanted to try out NFS since it is supposed to give better performance.

      Here's where I'm hitting a snag.

      The 7310 is configured with 6 NICs - from this there are 3 IPMP groups of two NICs each:
      1 group for our "main" network for CIFS clients and VMs to access on one subnet -
      ...and the other 2 are dedicated for iSCSI - and respectively

      Our VSphere environment has each host with 8 NICs - we have 3 virtual switches:
      1 made from 4 NICs configured on the "main" .128 network (this is a standard VM network)
      ...and the other 2 comprised of 2 NICs each for iSCSI (these are VMKernel virtual switches) on the .130 and .131 subnets

      I know that to use any SAN-based storage (whether it be iSCSI or NFS etc.) ESX uses this "VMKernel" connection type. What I want to do is not have to create a seperate VMKernel port switch on the ESX side, and instead re-use the ones that are already in use for iSCSI, or simply have another way of testing out NFS-based storage on a separate network without having to re-use the "main" .128 network...

      The problem is that I cannot get the 7310 to export NFS from any share over anything other than the "main" .128 network - whenever I create a new share it doesn't ask me which network to export it on. Is it possible to force it to be exported over a different interface/IPMP group/IP address? I presume this is because the IPMP groups used for iSCSI are already configured as iSCSI targets. Can anyone confirm?
        • 1. Re: 7000 series and NFS for ESX VM Storage
          I think the shares are automatically exported via all of the interfaces. You have to create NFS exceptions if you want to lock down NFS per network. Have you tried just mounting the share using one of the other networks?
          • 2. Re: 7000 series and NFS for ESX VM Storage
            Many thanks - telling ESX to connect to the 7310's IP address on one of the other subnets DOES appear to work!

            My brain must still be addled from some other recent issues we've been having...absolutely no idea why I hadn't tried it already...

            I stand by the fact that the BUI is ambigious, however - it still mentions that it's exported on only one of the networks...

            Thanks again...