13 Replies Latest reply on Jun 7, 2011 9:45 PM by 707211

    Missing data after up-to-load batch loader with source adapter

    851939
      Hi

      I'm using FDM and ERPI 11.1.2 in order to load data from Oracle eBS R12 to Hyperion PLanning 11.1.2.

      I have created several locations to load many data.
      When Importing, Validating and Exporting each of them directly via the Workflow in FDM, everything is ok.

      When I use Batch Loader (with one blank file per location in the outbox folder), everything is ok (no error with the processing) but only 2 of my 5 files are loaded into Planning.

      Any ideas?

      Thanks in advance for your help!

      Fanny
        • 1. Re: Missing data after up-to-load batch loader with source adapter
          WPaffhausen
          Hello,

          Are they loaded into FDM? If you clear the data you can verify.
          Also there is logging in the adapter you can turn on to review as well. Check the ReadMe and then review that log.

          Thank you,
          • 2. Re: Missing data after up-to-load batch loader with source adapter
            851939
            yes, the data are well loaded into FDM

            No error in the adapter log. Data are correctly loaded into ERPI table (But difficult to know which one are loaded because my 5 locations use the same ERPI source and the same import format - only mapping are differents

            and the 5 associated .dat files are well generated in the outbox folder

            Edited by: user13713728 on Apr 15, 2011 4:47 PM
            that's ok for the deletion :-)
            • 3. Re: Missing data after up-to-load batch loader with source adapter
              JTF85
              Have you reviewed the Essbase logs to confirm that the file was not loaded and then the data inadvertantly cleared? If you are clearing data before you load the FDM file you may want to check the sequencing, try loading each file and see if it works, then load them sequentially to see where it is failing.

              JTF
              1 person found this helpful
              • 4. Re: Missing data after up-to-load batch loader with source adapter
                851939
                You're right, data are well loaded but then deleted.

                I test with 2 locations.

                Directly in FDM (Workflow section):
                After loading location 1 (replace into FDM ; replace into Planning) => Data 1 are ok
                After loading location 2 (replace into FDM ; merge into Planning) => Data 1 are ok, Data 2 are ok

                Via Batch Loader (locations loaded separately, not with the same Batch execute) :
                After loading location 1 (replace into FDM ; replace into Planning) => Data 1 are ok
                After loading location 2 (replace into FDM ; append into Planning) => Data 1 are cleared, Data 2 are ok

                Fanny
                • 5. Re: Missing data after up-to-load batch loader with source adapter
                  JTF85
                  You may want to check any calc scripts that may run as a result of the export, you may have to modify the calc script to prevent clearing data in the respective target.

                  JTF
                  1 person found this helpful
                  • 6. Re: Missing data after up-to-load batch loader with source adapter
                    851939
                    You're right, once again :-)

                    I've checked in the Essbase log : "clear" calc script is executed before each load, even the second one with a _RA.txt extension (which normally means Replace into FDM, Append into Planning, isnt't it?).

                    Another great idea to explain this behaviour? :-s
                    • 7. Re: Missing data after up-to-load batch loader with source adapter
                      851939
                      That is ok when I use RM.txt (probably like "Merge", the same as into FDM web) for the second file (instead of RA.txt) even if it is not in the authorized value in the admin guide...

                      Does anyone have the behaviour definition of RR, RA and _RM extensions?                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           
                      • 8. Re: Missing data after up-to-load batch loader with source adapter
                        TonyScalese
                        The first character is the load method to FDM, second character is the load method to the target system:

                        RR = Replace, Replace
                        RM = Replace, Merge
                        RA = Replace,Append
                        • 9. Re: Missing data after up-to-load batch loader with source adapter
                          WPaffhausen
                          Fanny,

                          Please keep in mind that Essbase has no concept of "Replace or Merge". Essbase only knows of addition/subtraction methodologies.

                          To do a "replace" FDM creates the clear script in the Load Action.
                          To do a "merge" you will need to create a LoadRule inside of Essbase that can read the FDM formatted .DAT file. Then you populate the stringLoad variable in the adapter options.

                          Hopefully this helps...
                          • 10. Re: Missing data after up-to-load batch loader with source adapter
                            851939
                            Yes but what I don't understand is why FDM does a clear before an "Append" process.
                            I thought that "Append" was the same as in Essbase.

                            But thanks to all of you for your help! That's ok now!

                            Fanny
                            • 11. Re: Missing data after up-to-load batch loader with source adapter
                              WPaffhausen
                              Hello,

                              You did not clearly did not read what I wrote. Essbase does not have "Append".
                              Essbase only uses rules files to either add, subtract, multiply, divide.

                              A clear (via replace/append in FDM terms) is only done via a clear script. To override that behavior you will need to do a string load.

                              Thank you,
                              • 12. Re: Missing data after up-to-load batch loader with source adapter
                                851939
                                Sorry I really don't understand what you mean :-/

                                When I do a Replace in FDM/ERPI/PLanning => a clear script is executed before the load
                                When I do a Merge in FDM/ERPI/Plannig => no clear script is executed before the load, data are added : and I don't have created any Essbase data rule

                                but warning, there are the same data in Oracle eBS, but mapped on different members into Planning
                                So data are added to the same perimeter "Month, Year, Scenario", but not on the same members on other axis (Account, Entity, ...)

                                Location 1 : Account1 - CostCenter1 - 100 loaded into Hyperion Planning on AccountA - EntityA
                                Location 2 : Account1 - CostCenter1 - 100 loaded into Hyperion Planning on AccountA - EntityB

                                Sorry, I do my best but perhaps it is my english :-/
                                • 13. Re: Missing data after up-to-load batch loader with source adapter
                                  707211
                                  Fanny,

                                  Was there anything specific you had to do to integrate the batch loader to initiate a import from ERPi or does the default batch loader script just kickoff the process at the import stage?

                                  Thanks