3 Replies Latest reply: Apr 19, 2011 8:43 AM by 740056 RSS

    Session keeps running when the query has a syntax error

    740056
      I have a weird scenario.

      Take this query for example: select distinct physassignednum from hsi.docdeficiency where delinqlevel> 0 and dfcystatus in (1,6));

      This query has a syntax error as there is an additional bracket at the end. I know that. When I run it on STJOSE database the session keeps running and never returns. Even if I stop it, it does not. I try to disconnect, it says "Connection is currently busy. Try again?" This behavior is pretty consistent on STJOSET. If I run this query on UMASS database it gives me this error (as expected)

      ORA-00933: SQL command not properly ended
      00933. 00000 - "SQL command not properly ended"
      *Cause:   
      *Action:
      Error at Line: 1 Column: 99

      I do not know what is wrong with the STJOSE database connection that causes the session to hang and never return.

      Please help.
      -Nags
      Oracle Database 11g Enterprise Edition Release 11.1.0.7.0 - 64bit Production (both databases)
      SQL Developer Version 3.0.04 Build Main-04.34