7 Replies Latest reply on May 10, 2011 5:12 PM by 840339

    Problem with a signed applet and a user machine.

      Hello. I´m having some problems with a signed applet with some dependences.
      In one particular computer the applet doesn´t load.

      The java version installed in that computer is 1.6.0_25.

      The invocation tag:
      <applet name=applet id="applet" code=Applet/RequestApplet.class width=155 height=21 archive="RequestApplet.jar " MAYSCRIPT>
         <param id="parametro1" name="usuario" value="<Computed Value>">
      The RequestApplet.jar and dependences:
         bcmail-jdk13-145.jar(signed by bouncy castle), jce-ext-jdk13-145.jar(signed by bouncy castle), AbsoluteLayout.jar, plugin.jar, RequestApplet.jar(signed by me)
      *this files are all in the same folder.

      The requestApplet.jar manifest:
      Manifest-Version: 1.0
      Ant-Version: Apache Ant 1.7.1
      X-COMMENT: Main-Class will be added automatically by build
      Class-Path: bcmail-jdk13-145.jar jce-ext-jdk13-145.jar plugin.jar Abso
      Created-By: 10.0-b23 (Sun Microsystems Inc.)
      Main-Class: Applet.RequestApplet
      Name: Applet/ResponseApplet$1.class
      SHA1-Digest: fO5IPiwEH3OhvlprhBecmMIAVJI=
      Name: Applet/NewJApplet.class
      SHA1-Digest: 6XSpm7lQEQRi39TegoUYv2aFJrk=
      Name: Applet/ResponseApplet.class
      SHA1-Digest: v1EbKUFB+QdvO05xx8UzAMNIyRs=
      Name: Applet/ResponseApplet$4.class
      SHA1-Digest: XH4I67psXZTelpz0AMAYc/Ej8QY=
      Name: Applet/RequestApplet$1.class
      SHA1-Digest: KAP5sAC4Thv/6GClkFAdGUVzgYA=
      Name: Applet/ResponseApplet$5.class
      SHA1-Digest: CVPnKrW2SgNEkRzYnVnQe3KGrIU=
      Name: Applet/ResponseApplet$3.class
      SHA1-Digest: SjfW1k1K7BA9m3AxmHi+jvRE+9o=
      Name: Applet/ResponseApplet$2.class
      SHA1-Digest: 3Pu18CZMLuEh7/n3y7XxFSkuNQY=
      Name: Applet/RequestApplet.class
      SHA1-Digest: Tky85es5+o371adetH9XVEI2Z+o=
      The error:
      java.lang.RuntimeException: java.lang.NoClassDefFoundError: org/bouncycastle/jce/provider/BouncyCastleProvider
           at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
           at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
           at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.NoClassDefFoundError: org/bouncycastle/jce/provider/BouncyCastleProvider
           at java.lang.Class.getDeclaredConstructors0(Native Method)
           at java.lang.Class.privateGetDeclaredConstructors(Unknown Source)
           at java.lang.Class.getConstructor0(Unknown Source)
           at java.lang.Class.newInstance0(Unknown Source)
           at java.lang.Class.newInstance(Unknown Source)
           at sun.plugin2.applet.Plugin2Manager$12.run(Unknown Source)
           at java.awt.event.InvocationEvent.dispatch(Unknown Source)
           at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
           at java.awt.EventQueue.access$000(Unknown Source)
           at java.awt.EventQueue$1.run(Unknown Source)
           at java.awt.EventQueue$1.run(Unknown Source)
           at java.security.AccessController.doPrivileged(Native Method)
           at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
           at java.awt.EventQueue.dispatchEvent(Unknown Source)
           at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
           at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
           at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
           at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
           at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
           at java.awt.EventDispatchThread.run(Unknown Source)
      Caused by: java.lang.ClassNotFoundException: org.bouncycastle.jce.provider.BouncyCastleProvider
           at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
           at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Unknown Source)
           at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
           at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
           at java.lang.ClassLoader.loadClass(Unknown Source)
           ... 20 more
        • 1. Re: Problem with a signed applet and a user machine.
          It should not be necessary (given the manifest), but does it work if all the archives are explicitly listed in the <tt>archive</tt> attribute of the <tt>applet</tt> element?

          ..should be..
          And now I notice, package names should be lower case.
          • 2. Re: Problem with a signed applet and a user machine.
            Thanks. I´ll try with your tips. But if i put all the dependences in archive I get this error.

            The tag:
            <applet name=applet id="applet" CODEBASE="." code="Applet/RequestApplet.class" width=155 height=21 archive="bcmail-jdk13-145.jar, jce-ext-jdk13-145.jar, AbsoluteLayout.jar, plugin.jar, RequestApplet.jar " MAYSCRIPT>
               <param id="parametro1" name="usuario" value="<Computed Value>">
            The error:
            Java Plug-in 1.6.0_25
            Usar versión JRE 1.6.0_25-b06 Java HotSpot(TM) Client VM
            Directorio local del usuario = C:\Documents and Settings\Administrator
            c:   borrar ventana de consola
            f:   finalizar objetos en la cola de finalización
            g:   liberación de recursos
            h:   presentar este mensaje de ayuda
            l:   volcar lista del cargador de clases
            m:   imprimir sintaxis de memoria
            o:   activar registro
            q:   ocultar consola
            r:   recargar configuración de norma
            s:   volcar propiedades del sistema y de despliegue
            t:   volcar lista de subprocesos
            v:   volcar pila de subprocesos
            x:   borrar antememoria del cargador de clases
            0-5: establecer nivel de rastreo en <n>
            basic: Receptor de progreso agregado: sun.plugin.util.GrayBoxPainter$GrayBoxProgressListener@f39b3a
            basic: Plugin2ClassLoader.addURL parent called for http://desarrollo.isaltda.com.uy/CertReq.nsf/bcmail-jdk13-145.jar
            basic: Plugin2ClassLoader.addURL parent called for http://desarrollo.isaltda.com.uy/CertReq.nsf/jce-ext-jdk13-145.jar
            basic: Plugin2ClassLoader.addURL parent called for http://desarrollo.isaltda.com.uy/CertReq.nsf/AbsoluteLayout.jar
            basic: Plugin2ClassLoader.addURL parent called for http://desarrollo.isaltda.com.uy/CertReq.nsf/plugin.jar
            basic: Plugin2ClassLoader.addURL parent called for http://desarrollo.isaltda.com.uy/CertReq.nsf/RequestApplet.jar
            • 3. Re: Problem with a signed applet and a user machine.
              Francisco26 wrote:
              In one particular computer the applet doesn´t load.
              You mean that on one machine it isn't working, but on many others it is working? Or you just tried on one machine only?
              • 4. Re: Problem with a signed applet and a user machine.
                No, I have tried in a lot of computers but in two the applet doesn´t load. (one of them is the computer of a client). That computer had java 1.5.0_7 and when I update to 1.6.0_25 the error appear (i don´t touch any configuration).
                My computer has 1.6.0_25 and have not problem.
                • 5. Re: Problem with a signed applet and a user machine.
                  still if it is on isolated machines, it might be difficult to track down the real issue because you don't know what has been done to said machine by its 'human controller'.

                  Did you try in different browsers?
                  • 6. Re: Problem with a signed applet and a user machine.
                    Yes, mozilla and IE.
                    • 7. Re: Problem with a signed applet and a user machine.
                      Hi. i´m a little confused. I have unmarked in the JVM in the java plug-in section, activate java plug-in new generation and it works (in the computer with problems). But in my computer is marked and works too. Is this logical?