1 Reply Latest reply: Oct 22, 2011 11:38 AM by CyberNinja RSS

    Solaris 10 client - ldap_search: Can't connect to LDAP server


      I have following configuration:
      - openLDAP server in Solaris 10 zone called ldap
      - native LDAP client in different Solaris 10 zone called mail on the same SPARC machine

      I can't get ldapsearch results after ldapclient initialization.
      [root@mail ~]# ldapsearch -b dc=pov,dc=pl objectclass=*
      ldap_search: Can't connect to the LDAP server - Connection refused

      But I am able to get data from LDAP server if address of the server is specified:
      [root@mail ~]# ldapsearch -b dc=pov,dc=pl -h objectclass=*
      version: 1
      dn: ou=users,dc=pov,dc=pl
      objectClass: organizationalUnit
      ou: Users

      Here is ldapclient config:
      [root@mail ~]# ldapclient list
      NS_LDAP_SEARCH_BASEDN= dc=pov,dc=pl
      NS_LDAP_AUTH= none

      What am I missing?
        • 1. Re: Solaris 10 client - ldap_search: Can't connect to LDAP server
          Hi, I'm no exprert but I will try to help you. Are you still working on this?

          This what my stuff looks like:
          # ldapclient list
          NS_LDAP_FILE_VERSION= 2.0
          NS_LDAP_BINDDN= uid=proxyagent,ou=People,dc=deathnote,dc=net
          NS_LDAP_BINDPASSWD= {NS1}ecfa88f3a945c411
          NS_LDAP_SEARCH_BASEDN= dc=deathnote,dc=net
          NS_LDAP_AUTH= none
          NS_LDAP_CACHETTL= 0
          NS_LDAP_SERVICE_SEARCH_DESC= passwd:ou=People,dc=deathnote,dc=net
          NS_LDAP_SERVICE_SEARCH_DESC= shadow:ou=People,dc=deathnote,dc=net
          NS_LDAP_SERVICE_SEARCH_DESC= group:ou=People,dc=deathnote,dc=net
          NS_LDAP_SERVICE_AUTH_METHOD= pam_ldap:simple

          [root@light migration]# cat user00.ldif
          dn: uid=user00,ou=People,dc=deathnote,dc=net
          uid: user00
          cn: user00
          objectClass: account
          objectClass: posixAccount
          objectClass: shadowAccount
          objectClass: top
          loginShell: /bin/bash
          uidNumber: 805
          gidNumber: 501
          homeDirectory: /home/user00
          gecos: ldap user

          Also update you hosts file and add your server to the domain.
          I hope this helps.

          Edited by: CyberNinja on Oct 22, 2011 12:37 PM