This discussion is archived
8 Replies Latest reply: May 18, 2011 4:11 AM by 855458 RSS

Oracle DB 11.2.0.2.0 install - Ubuntu 11.04 - library dependency problem

586814 Newbie
Currently Being Moderated
Hi -
Spent the good part of the weekend trying to install Oracle Database 11.2.0.2.0 on Ubuntu 11.04 (Natty Narwhal). Unsuccessful in getting it work, so far.

Here is my setup -
Intel D820 Dual Core PC with 4 GB of RAM, and sufficient disk space.
Ubuntu 11.04 - 64 bit OS.
Oracle Database 11.2.0.2.0 - downloaded the Linux x86_64 version.

So basically I am trying to install a 64 bit database on a machine with a 64 bit OS.

Here is the problem -
1. The installer identifies a number of packages (libraries) as not being available. Problem is, these ARE AVAILABLE in the PC.
2. If I ignore the above warnings, then I end up with an error message when the libraries are being linked, while installing the database.

The error message points to a "client_sharedlib". I read through a number of discussions in this forum that discussed how to resolve this problem - but none worked for me.

I understand that Ubuntu is not one of the certified platforms. But can anyone help resolve this problem? I can post log messages from the installation process based on the response I get from folks here.

Thank you.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points