8 Replies Latest reply: Nov 30, 2012 7:48 AM by 977258 RSS

    Apex configuration issue

    user13653962
      getting following error when runnin apex @apex_epg_config /tmp script


      SQL> @apex_epg_config /tmp
      
      PL/SQL procedure successfully completed.
      
      
      PL/SQL procedure successfully completed.
      
      
      Directory created.
      
      declare
      *
      ERROR at line 1:
      ORA-22288: file or LOB operation FILEOPEN failed
      No such file or directory
      ORA-06512: at "SYS.XMLTYPE", line 296
      ORA-06512: at line 18
      
      
      
      Commit complete.
      
      
      PL/SQL procedure successfully completed.
      
      declare
      *
      ERROR at line 1:
      ORA-31001: Invalid resource handle or path name "/images"
      ORA-06512: at "XDB.DBMS_XDB", line 449
      ORA-06512: at line 37
      
      
      timing for: Load Images
      Elapsed: 00:00:00.27
      
      Session altered.
      
      
      PL/SQL procedure successfully completed.
      
      
      Commit complete.
      
      
      Session altered.
      
      
      Directory dropped.
      
      SQL> exit
      Awais
        • 1. Re: Apex configuration issue
          Javid Hesenov
          Run apex_epg_config.sql passing the file system path to the base directory where the Oracle Application Express software was unzipped. For example if your apex directory is /u01/app/apex
          then run
          @apex_epg_config /u01/app
          • 2. Re: Apex configuration issue
            user3482435
            I'm having this problem....

            I have edited apex_epg_config_core.sql

            old
            create directory APEX_IMAGES as '&1/apex/images';

            new
            create directory APEX_IMAGES as '&1\apex\images';

            It now appears to create a directory correctly ie with \ instead of / (I'm on Windows)

            but I still get this error!
            old 47: if '&IMGUPG' != '' then
            new 47: if '' != '' then
            old 48: l_mv_folder := '&IMGUPG';
            new 48: l_mv_folder := '';
            declare
            *
            ERROR at line 1:
            ORA-22288: file or LOB operation FILEOPEN failed
            The system cannot find the path specified.
            ORA-06512: at "SYS.XMLTYPE", line 296
            ORA-06512: at line 18

            Edited by: user3482435 on 27-Apr-2012 07:38
            • 3. Re: Apex configuration issue
              user540573
              I am also having this issue, however I have not edited any files. I have read many threads(mostly old) and tried several different things, but cannot get past this error.
              Am hoping that someone will be able to identify what I am doing wrong, and provide me with a solution.

              I am performing a brand new Apex 4.1.1 install on a newly installed database(OracleXE112_Win32) on Windows 7.
              .
              I have been carefully following along with the instructions(http://docs.oracle.com/cd/E23903_01/doc/doc.41/e21673/otn_install.htm#BEHGEFDI) for the Oracle XML DB HTTP Server with the embedded PL/SQL gateway.
              Now i am stuck at the step to run the Configuration script apex_epg_config.sql.

              I unziipped the Apex Install files at C:\hold by double-clicking the apex_4.1.1 zipfile.

              So the hold directory contanis the apex_4.1.1_en folder: C:\hold\apex_4.1.1_en\apex
              And looks like this:
              C:\hold\apex_4.1.1_en>dir
              Volume in drive C is System
              Volume Serial Number is 1854-2523

              Directory of C:\hold\apex_4.1.1_en

              09/11/2012 03:47 PM <DIR> .
              09/11/2012 03:47 PM <DIR> ..
              09/11/2012 04:45 PM <DIR> apex
              0 File(s) 0 bytes
              3 Dir(s) 57,709,846,528 bytes free

              Positioned at C:\hold\apex_4.1.1_en\apex, the following is what I typed and what happened:
              C:\hold\apex_4.1.1_en\apex>
              C:\hold\apex_4.1.1_en\apex>sqlplus /nolog

              SQL*Plus: Release 11.2.0.2.0 Production on Tue Sep 11 19:37:59 2012

              Copyright (c) 1982, 2010, Oracle. All rights reserved.

              SQL> connect SYS as SYSDBA
              Enter password:
              Connected.
              SQL>
              SQL> @apex_epg_config C:\hold

              PL/SQL procedure successfully completed.
              PL/SQL procedure successfully completed.

              old 1: create directory APEX_IMAGES as '&1/apex/images'
              new 1: create directory APEX_IMAGES as 'C:\hold/apex/images'

              Directory created.

              old 47: if '&IMGUPG' != '' then
              new 47: if '' != '' then
              old 48: l_mv_folder := '&IMGUPG';
              new 48: l_mv_folder := '';
              declare
              *
              ERROR at line 1:
              ORA-22288: file or LOB operation FILEOPEN failed
              The system cannot find the path specified.
              ORA-06512: at "SYS.XMLTYPE", line 296
              ORA-06512: at line 18

              Commit complete.
              PL/SQL procedure successfully completed.
              PL/SQL procedure successfully completed.
              timing for: Load Images
              Elapsed: 00:00:02.88
              Session altered.
              PL/SQL procedure successfully completed.
              Commit complete.
              Session altered.
              Directory dropped.
              SQL>

              Thanks so much in advance for any help anyone can provide!
              • 4. Re: Apex configuration issue
                Mehabub Sheikh
                This issue happens because of two reasons generally.
                1. Path was not correct. Let say you have unzipped apex under folder C:\apex_4.1.1. Then you need to specify the path as C:\apex_4.1.1
                2. There must not be any space in the folder name. e.g let say you have unzipped under folder C:\apex 4.1.1 and if you provide the path for image folder as C:\apex 4.1.1 the installation will fail.

                Once you fixed above two, you should be able to run the script successfully.

                Thanks,
                Mehabub

                Edited by: Mehabub Sheikh on Sep 12, 2012 6:22 AM
                • 5. Re: Apex configuration issue
                  Hilary Farrell-Oracle
                  Hi Colleen,

                  You have mentioned that you extracted the contents of the zip file to the following path: C:\hold\apex_4.1.1_en\ i.e. that folder contains a folder called apex. So in SQL*Plus, you would need to execute the script as follows:
                  SQL> @apex_epg_config C:\hold\apex_4.1.1_en\
                  I hope this helps.

                  Regards,
                  Hilary
                  • 6. Re: Apex configuration issue
                    Hilary Farrell-Oracle
                    Hi,

                    You should not edit the installation files. I would recommend that you back out your changes, and execute the apex_epg_config.sql script, passing the file system path to the base directory where the Oracle Application Express software was unzipped. For example, with Colleen's post above, she has unzipped the contents of the zip file to the following location C:\hold\apex_4.1.1_en\ - and that folder contains an apex folder. The apex folder contains all of the installation scripts, and an images directory. So when it comes to running apex_epg_config.sql, the path to be passed in is C:\hold\apex_4.1.1_en\, in Colleen's case:
                    SQL> @apex_epg_config C:\hold\apex_4.1.1_en\
                    So you will need to ensure that you pass in the correct path for your environment.

                    I hope this helps.

                    Regards,
                    Hilary
                    • 7. Re: Apex configuration issue
                      user540573
                      Thanks you SO much. Your response made perfect sense and worked! Thanks also, to all who responsed!
                      • 8. Re: Apex configuration issue
                        977258
                        I found an issue thath does not accept &1 or $ORACLE_HOME in the path . you have to put full fixed path.
                        Thanks for all !!!