6 Replies Latest reply: Jun 1, 2011 12:59 PM by 865750 RSS

    automount problem

    865750
      Hello,

      I have run into an automount problem with a single home directory. Automounts are shared out using our NIS server, a Solaris 9 system. The home directories are exported out from a Solaris 10 system using zfs. After the pain of creating an entry for each of the shared out home directories in the auto.home map on the NIS server (zfs limitation), the setup has worked fine for over 4 years. Recently one users home directory has stopped being mapped by the automounter. Below are some of the steps taken to try and troubleshoot the problem:


      The problem users home directory was shared out to a new mount point in the auto.home map and automounter maps it to all systems. When the mount point is changed back to the original mount point automounter does not map it to other systems.


      A test homedirectory was created, and mounted using the problem mount point, and it will not get mapped with automounter. Use any other mount point, and it gets shared out normally by automounter.


      Both the NIS server and the home directory server were rebooted, the reboots did not clear up the problem.


      When I check the mnttab file on any systems in the NIS domain where the home directory should mount, there is no autofs entry for the problem home directory.


      Some systems that have not restarted their automount daemon can mount the problem homedirectory with the automounter, but as soon as autofs is disabled, then started again, the directory will not mount with automounter.


      The problem home directory can be manually mounted with an nfs mount command.


      Any ideas on what is going on, or steps that might be used to troubleshoot the issue more would be greatly appreciated. I am trying to avoid building a new auto.home map from scratch....but it is looking like what I might have to do.


      Thanks,

      John

      Edited by: 862747 on Jun 1, 2011 9:59 AM
        • 1. Re: automount problem
          bobthesungeek76036
          <pre>ypmatch <username> auto_home</pre>

          and see what server:mountpoint is being shared. Then:

          <pre>showmount -e <server></pre>

          and see how the NFS share is being presented to the network.

          If you have the /net mountpoint enabled you could try to 'cd' to:

          <pre>/net/<server>/<mountpoint></pre>

          from the ypmatch above and see if that works.
          • 2. Re: automount problem
            865750
            ypmatch does not seem to recognize the auto.home map. Not sure why, but ypcat does find the auto.home map, and it matches what the homedir server is exporting for the file-system in question via showmount:


            ypcat auto.home |grep -i userid


            -rw starbuck:/usr/home/div/userid

            showmount -e starbuck|grep -i userid


            /usr/home/div/userid trusted



            /mnt is not enabled in the environment, it is an empty directory on all systems.


            This is an odd problem. I am thinking the auto.home map in the server might have some type of corrupt entry for the mount point /home/div/userid, that is causing it to be ignored in the auto.home map by the NIS domain.

            If I could find docs on how to modify the compiled version of the map to get rid of any entry for the problem mount point, I would try that.
            • 3. Re: automount problem
              bobthesungeek76036
              Your semantics are confusing. You original post referenced auto_home but your latest post referenced auto.home. Which is it? You need to be careful that you match with your NIS environment. If ypmatch isn't finding your map then I would figure out why. That is the mechanism that autofs will use to lookup the information.
              • 4. Re: automount problem
                865750
                Sorry about that. I typed auto_home originally because that is what the src file for automounts is saved as in /var/yp/src. However ypcat does not recognize the map auto_home. It does recognize the map auto.home. I have modified the original message so it matches the second post to avoid confusion. Reviewing the Makefile in /var/yp, it has this note:


                "# It is somewhat confusing to note that Solaris 2.x uses /etc/auto_master
                # instead of the 4.x /etc/auto.master file name because of NIS+ treating a
                # "." in a special way."
                • 5. Re: automount problem
                  bobthesungeek76036
                  You say "ypmatch" doesn't recognize the map. What is the exact error message you receive when trying to lookup someone in the auto.home map?
                  • 6. Re: automount problem
                    865750
                    o.k. I really should pay more attention to the details. ypmatch does work when auto.home is used as the map. The error message output by ypmatch was different when I used the correct map name:



                    bash# ypmatch userid auto_home
                    Can't match key userid in map auto_home. Reason: no such map in server's domain.



                    bash# ypmatch userid auto.home
                    Can't match key userid in map auto.home. Reason: no such key in map.


                    If I use a valid key lookup for auto.home it responds back with the same output as the showmount:



                    bash# ypmatch /home/div/userid auto.home
                    -rw starbuck:/usr/home/div/userid


                    bash# showmount -e starbuck|grep userid
                    /usr/home/div/userid trusted