This discussion is archived
0 Replies Latest reply: Jun 7, 2011 10:51 PM by 673340 RSS

java.lang.securityexception: method 'getadministrationurl' cannot be invok

673340 Newbie
Currently Being Moderated
We have a webcenter domain spanning over two nodes. The admin server along with webcenter managed servers are on acomsl3.cos.agilent.com server and we have another set of web center managed servers on acomsl4.cos.agilent.com. We created thd domain on acomsl3 along with the managed servers and its associations on these two nodes and the same was taken and deployed on acomsl4 via pack/unpack command.

Currently there are two issues which we are facing :

1. If we start the managed server WC_Spaces_sl4 on acomsl4 using acomsl3 Admin server url , it fails giving the following error :

j940dc0de85:2db0d1d8:13028a632fe:-8000-000000000000000e> <1306352157572> <BEA-080003> <RuntimeException thrown by rmi server: weblogic.rmi.internal.AdminAccessOnlyServerRef@1f, implementation: 'weblogic.server.channels.RemoteChannelServiceImpl@ae0ba72', oid: '31', implementationClassName: 'weblogic.server.chan
nels.RemoteChannelServiceImpl'

java.lang.SecurityException: Method 'getAdministrationURL' cannot be invoked without administrator access.
java.lang.SecurityException: Method 'getAdministrationURL' cannot be invoked without administrator access

at weblogic.rmi.internal.AdminAccessOnlyServerRef.getWorkManager(AdminAccessOnlyServerRef.java:29)
at weblogic.rmi.internal.BasicServerRef.getWorkManager(BasicServerRef.java:442)
at weblogic.rmi.internal.BasicServerRef.dispatch(BasicServerRef.java:358)
at weblogic.rmi.internal.BasicServerRef.dispatch(BasicServerRef.java:1022)
at weblogic.rjvm.RJVMImpl.dispatchRequest(RJVMImpl.java:1141)

without administrator


2. We tried starting the same managed server on acomsl4 using admin server on acomsl4 (this one came via the domain pack/unpack).

This works , but we cannot do any deployment through acomsl4 admin server as the em console for some reason does not come up. It gives 503 error if we try http://acomsl4.cos.agilent.com:<admin server port>/em. But console works on acomsl4.

Any comments please?

Thanks,

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points