6 Replies Latest reply: Jun 14, 2011 9:27 AM by 868525 RSS

    Integration Broker - PTool 8.50 - Pinging remote node errors out

    868525
      Hi! I am trying to configure default local nodes on HCM 9.1 and FSCM 9.1, both systems have PeopleTools 8.50.
      HCM 9.1 is installed on Windows 7 Home Premium. DB is Oracle 10g
      FSCM 9.1 is installed on Windows 2003 server. DB is Oracle 10g

      Problem:
      =====
      When I ping remote node from HCM 9.1 it displayes the following message
      “PeopleSoftTargetConnector - The application server is down (or not responding). Check AppServer URL.”

      When I ping the remote node from FSCM 9.1 then I get the following message:
      “PSFT Authentication token failed for Node PSFT_HR. (158,454)”

      Setup Details:
      =========
      Here are steps I followed on both systems:

      FSCM 9.1. side :
      =========
      1.Defined local gateway. http://<My-Machine B>:/PSIGW/PeopleSoftListeningConnector When I ping it from Gateway page, it shows it is active.

      2.Renamed default node PSFT_EP to PSFT_TRN. Before renaming ran the appmsgpurgeall.dms script from <PS_HOME>\scripts\ to make sure there are no references to PSFT_EP in runtime tables. This is PS supplied dms script and they recommend to run this script before renaming any node (It should be done at the initial setup time).

      3.On the Node page, PSFT_TRN node is defined as default node. Specified the default user Id as ‘PTINT’ the common User id created by cloning ‘VP1’. On the ‘Connectors’ tab Gateway ID is ‘LOCAL’ and connector id is ‘PSFTTARGET’. From the ‘Connectors’ tab Pinged the PSFT_TRN node and it was pinged successfully.

      4.On Gateway Properties page, defined "APP Server URL" as ‘<Machine Name B>:9000, user Id/pwd as ‘PTINT’ and tool release as ‘8.50’.
      5.Defined PSFT_TRN node, with APP Server URL as ‘<Machine Name B>:9000, user Id/pwd as ‘PTINT’ and tool release as ‘8.50’. When I ping this node, it is pinged successfully.
      6.Inserted another node PSFT_HR, with APP Server URL as ‘<Machine Name A>:9000, user Id/pwd as ‘PTINT’ and tool release as ‘8.50’. When I ping PSFT_HR node from this page I get the following error:
      “PSFT Authentication token failed for Node PSFT_HR. (158,454)”

      HCM 9.1. side:
      =========
      1.Defined local gateway. http://<My-Machine A>:/PSIGW/PeopleSoftListeningConnector. When I ping it from Gateway page, it shows it is active.
      2.On the Node page made sure ‘PSFT_HR’ node is default and active. Specified the default user Id as ‘PTINT’ the common User id created by cloning ‘PS’. On the ‘Connectors’ tab Gateway ID is ‘LOCAL’ and connector id is ‘PSFTTARGET’. From the ‘Connectors’ tab clicked on ‘Ping Node’ button for PSFT_HR node and it was pinged successfully.
      3.On Gateway Properties page, defined "APP Server URL" as '<Machine Name A>:9000', user Id/pwd as ‘PTINT’ and tool release as ‘8.50’.
      4.Defined PSFT_TRN node, with "APP Server URL" as ‘<Machine Name B>:9000', user Id/pwd as ‘PTINT’ and tool release as ‘8.50’. When I ping this node, the following message is displayed:
      “PeopleSoftTargetConnector - The application server is down (or not responding). Check AppServer URL.”

      Basically, I am unable to ping remote node on both systems. Local node ping successfully on both systems.
      Has any one encountered similar problem and found a solution?

      Thanks

      Raj

      Edited by: 865522 on Jun 13, 2011 2:18 PM
        • 1. Re: Integration Broker - PTool 8.50
          Nicolas.Gasparotto
          Are the machines pingable from each other ? How are the \WINDOWS\system32\drivers\etc\hosts file (if not using DNS server) ?
          Do the nodes defined as trusted nodes (Peopletools -> Security) ? Do the nodes defined within a user/password ?

          Nicolas.
          • 2. Re: Integration Broker - PTool 8.50
            868525
            Yes, I could ping both machines from each other.
            Here is the host file contents from Windows 7:
            127.0.0.1 localhost
            ::1 localhost
            127.0.0.1 activate.adobe.com
            192.168.1.106 RAJ-PC

            Here is from Window 2003 server:
            127.0.0.1 localhost
            192.168.1.100 saroja

            Both nodes are listed under PeopleTools>Security Objects> Single Signon
            Both nodes are secured with userid/pwd on Node page.

            One of my machine had fire wall on, so I swtiched the fire wall off. Now machine A can ping both nodes but machine B can ping only local node. Pinging remote node displays "User name not defined in database".


            Raj

            Edited by: Raj on Jun 13, 2011 11:37 PM
            • 3. Re: Integration Broker - PTool 8.50
              Nicolas.Gasparotto
              1. Try to add the remote IP address and name of server in each hosts file
              2. Trusted node, I mean are the remote nodes added in "Peopletools -> Security -> Security Objects -> Single Signon" ?

              Nicolas.
              • 4. Re: Integration Broker - PTool 8.50
                868525
                Finally, I was able to ping remote nodes from both systems. Problem was, I was logged in as 'PS' user of HCM system and as 'VP1' user on FSCM system but in node definition default user id was 'PTINT' (I created PTINT user id on both systems). When I logged in on both systems as 'PTINT' and pinged remote node, it pinged successfully.
                Thanks Nicolas for your time.

                Raj
                • 5. Re: Integration Broker - PTool 8.50
                  Nicolas.Gasparotto
                  Raj,
                  That's rather strange, I never ever connect on local db as the "messaging user" to be able to ping the remote node.
                  Are you sure you specified "Authentication Option"=Password in the remote node definition (and given the password) ?

                  Nicolas.
                  • 6. Re: Integration Broker - PTool 8.50
                    868525
                    Yes, Nicolas. That's what I thought too. Just to test whether my "messaging user" password is correct I looged in as "messaging user", and to my surprise I was able to ping remote node. My laptops are not on network.
                    Do you think that I should be able to ping remote node by not logging in as "messaging user"? I will give it a try and see how it goes. I will let you know the outcome.


                    Thanks a lot.

                    Raj