This discussion is archived
2 Replies Latest reply: Jun 16, 2011 11:39 AM by user54003 - oracle RSS

JVM

PVM Newbie
Currently Being Moderated
Hi All,

I am working on UCM 11g deployed on WebLogic 10.3.4. When we open System Audit Information from UCM home, it was giving error *"java.lang.OutOfMemoryError: allocLargeObjectOrArray"*. I have increased the following parameters in setDomains.sh file:-

XMS_SUN_32BIT="256"
XMX_SUN_32BIT="2048"

WLS_MEM_ARGS_32BIT="-Xms256m -Xmx2048m"

After restarting the Admin and Managed server, we are not getting the error.
But the system audit information says Total JVM Memory --- 512M.

Why it is not showing 2048M?

Do i need to set any parameters in any of other files in order to reflect JVM Memory value?

Please advise.

Thanks,
Manikandan
  • 1. Re: JVM
    RenévanWijk Oracle ACE
    Currently Being Moderated
    The memory parameter are unfortunately scattered over the whole setDomainEnv file, so you
    can easily edit the wrong parameters which will not be picked-up.

    A good way to proceed is to use the USER_MEM_ARGS variable.

    Usually at the top of the file you can see the following entries:
    WL_HOME="/home/oracle/bea/wlserver_10.3"
    export WL_HOME
    
    BEA_JAVA_HOME="/home/oracle/bea/jrockit_160_05_R27.6.2-20"
    export BEA_JAVA_HOME
    
    SUN_JAVA_HOME="/home/oracle/bea/jdk160_11"
    export SUN_JAVA_HOME
    beneath these entries you can add the variable USER_MEM_ARGS (which will override all the other JVM configuration), for example,
    # Memory arguments
    USER_MEM_ARGS="-Xms512m -Xmx512m ..."
    export USER_MEM_ARGS
    
    # if you want to use JRockit as the JVM you have to set the JAVA_VENDOR
    JAVA_VENDOR="Oracle"
    export JAVA_VENDOR
    
    # the following is part of the original script
    if [ "${JAVA_VENDOR}" = "Oracle" ] ; then
  • 2. Re: JVM
    user54003 - oracle Newbie
    Currently Being Moderated
    Manikandan, Assuming you have set the JVM heap values at correct location in setDomain.sh... you need to be mindful that at restart weblogic JVM will not reach maximum, As you have set minimum to -Xms256... it will start at 256 and gradually increase upto 2048 when required. I presume when you restarted the server, it only felt the need to reach 512MB based on the objects created.

    If you want the server to start at 2048MB, set the heap settings to -Xms2048m -Xmx2048m.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points