2 Replies Latest reply: Jun 17, 2011 7:54 AM by Tommyreynolds-Oracle RSS

    rhn_register failing

    755353
      Hi

      tried to register a new linux 5.6 with redhat.com but its failing ...

      rhn_register
      We can't contact the Red Hat Network Server. â â â
      â â â â â
      â â Double check the location provided - is â â â
      â â 'https://xmlrpc.rhn.redhat.com/XMLRPC' correct? â â â
      â â If not, you can correct it and try again. â â â
      â â â â â
      â â Make sure that the network connection on this â â â
      â â system is operational. â â â
      â â â â â
      â â This system will not be able to successfully â â â
      â â receive software updates from Red Hat without â â â
      â â connecting to a Red Hat Network server â â â
      â â


      I already have configure proxy and can access redhat.com via firefox browser with no problem.
      network guys think port 8080 and 443 are both open ... they can see some denied connections to port 443 but its because of missing username ( annonymous).
      when i run rhn_register it doesnt get to the stage where I have to input redhat username/password. ....

      so a little confused as to what causing the issue? is it network firewall ? or me ?
        • 1. Re: rhn_register failing
          755353
          does rhn_register uses ftp to download from redhat.com?
          apparently there is a bug in our proxy which blocks ftp connections ... i wondered if this is the cause
          • 2. Re: rhn_register failing
            Tommyreynolds-Oracle
            Use the netcat tool (nc) to test your connectivity. Do this:
            # dig xmlrpx.rhn.redhat.com
            # tracepath xmlrpc.rhn.redhat.com
            # nc -vz xmlrpc.rhn.redhat.com/XMLRPC 443
            and show us the exact output.

            This recipe checks:
            <li>Can your DNS resolve the server?
            <li>Can you at least ping the server? If not, how far do you get?
            <li>Do you have a firewall that blocks the https post (443).