1 2 Previous Next 18 Replies Latest reply: Nov 2, 2011 7:23 AM by 897442 RSS

    11g Release 2 installation on Oracle Linux 6

    TheHades0210
      Aloha!

      I I'am installing 11g Release 2 Database on Oracle Linux 6 but i stumble on this problem, that i cant install the said application, either I,m running the wrong file or i downloaded the wrong installation kit for OL 6.

      1) I downloaded "Oracle Database 11g Release 2 (11.2.0.1.0) for Linux x86" installer. Extracted it and paste it on Oracle Linux 6 OS.

      2) I access the directory where i paste the said installer and run "runInstaller" file and i'm having a prompt saying "Permission denied".

      Could it be that the installation kit I downloaded is not for Oracle Linux 6. Is there something that I miss thats why I'm having this prompt?

      Thanks in advance.

      Hades,
        • 1. Re: 11g Release 2 installation on Oracle Linux 6
          Dude!
          Based on the information you provided there are too many unknown variables in order to troubleshoot your problem.

          You may find the following link useful in helping you to install Oracle:
          http://www.oracle-base.com/articles/11g/OracleDB11gR2InstallationOnOracleLinux6.php

          Afaik, Oracle 11g is not yet supported under Enterprise Linux 6 yet.
          • 2. Re: 11g Release 2 installation on Oracle Linux 6
            TheHades0210
            Aloha Dude,

            My problem is i have a Oracle Linux 6 OS on a virtual box and i want to install 11g database on it. I want to test the installation of both OL-6 and 11g, but i stumble upon the installation of 11g database. Is this because i used a wrong installation kit of 11g database("Oracle Database 11g Release 2 (11.2.0.1.0) for Linux x86") or it is because i miss something during the installation of the said database.

            Thanks,
            • 3. Re: 11g Release 2 installation on Oracle Linux 6
              Dude!
              It is not possible to say, but if the installation kit is what you say it is, it should work. The problem might be related to how you provide the installation source, i.e. local disk or DVD, and/or how you invoke the installer. If you use Virtualbox you might be using the iso installation image, in which case Linux, by default, will not mount your installation media with execute privileges. Based on what you have, you can deal with the problem in a number of different ways, but I won't go into details based on guessing what you have.

              I'm afraid you will need to follow the installation instructions or provide more detailed information. I imagine that following the installation instructions and outlining the exact point where you fail will be the most effective and least frustrating way to get your problem solved.

              If you are installing Oracle under Virtualbox for the purpose of studying, then install Oracle under a support version, such as Oracle Linux 5.6, and install Oracle Linux 6 in a separate VM.
              • 4. Re: 11g Release 2 installation on Oracle Linux 6
                TheHades0210
                I am using the installation kit that I have downloaded (2 compressed files, which i extracted on windows platform and /copied it to OL 6 via LAN), as you may have noticed, this issue concern on the same OS i have posted last time regarding YUM update which I have manage to update the YUM server and the packages.

                Basing on the link you provided earlier, under SETUP... since i am using virtual box, how can i install the packages..or do need to install this packages, are these not included on the update on the packages i mentioned...how can i check if these are present or need to update?

                ( From Oracle Linux 6 DVD
                cd /media/cdrom/Server/Packages
                rpm -Uvh binutils-2*x86_64*
                rpm -Uvh glibc-2*x86_64* nss-softokn-freebl-3*x86_64*)...

                Also the adding of user...

                (groupadd -g 501 oinstall
                groupadd -g 502 dba
                groupadd -g 503 oper
                groupadd -g 504 asmadmin
                groupadd -g 506 asmdba
                groupadd -g 505 asmoper

                useradd -u 502 -g oinstall -G dba,asmdba,oper oracle
                passwd oracle
                )

                This will be run on the terminal?

                Thanks for the time spent and sorry for the hustle...
                • 5. Re: 11g Release 2 installation on Oracle Linux 6
                  Dude!
                  The instructions above assume some Linux experience. Unzip, rpm, etc. are standard Linux commands that need to be entered in a terminal. I would not recommend to extract the installation source in Windows and copy it to Linux because a lot can go wrong there, i.e. filename and text content conversion and files starting with a dot (.) may not be copied.

                  I'm afraid you will be pretty much on your own installing Oracle 11g under Oracle Linux 6. Why bother, it is not supported yet. Oracle Linux 5.6 will do just fine, in particular with Virtualbox and you should find all sorts of tutorials and answers for whatever problem you may run into.

                  I think your best option will be to install Oracle Linux 5.6 and install the yum oracle-validated package, which will do all the necessary package installation, set kernel parameters and even create the oracle account for you.

                  Alternatively you can download pre-build VM templates for Virtualbox from http://www.oracle.com/technetwork/community/developer-vm/index.html which might save you altogether.
                  • 6. Re: 11g Release 2 installation on Oracle Linux 6
                    TheHades0210
                    Thanks for your time man. :)

                    Hades
                    • 7. Re: 11g Release 2 installation on Oracle Linux 6
                      TheHades0210
                      Hi Dude,

                      One question... i did all the procedure on the link regarding 11g installation on Linux and im on the part now which i have run ./runInstaller on the terminal but im having this error..

                      [root@ol6 database]# ./runInstaller
                      ./runInstaller: line 135: [: too many arguments
                      ./runInstaller: line 139: /home/oracle/Downloads/Oracle(Linux: No such file or directory

                      i did extract the installation kit on Linux OS. Im on the directory where the extracted kit is, before running ./runInstaller...
                      Please enlighten my primitive knowledge on Linux.

                      Thanks,
                      • 8. Re: 11g Release 2 installation on Oracle Linux 6
                        Dude!
                        I think I remember this error somehow.... Do you have spaces in the directory name were you put the installation? If so, please remove any spaces and try again.
                        • 9. Re: 11g Release 2 installation on Oracle Linux 6
                          TheHades0210
                          Thanks again man...its running.. Great help.
                          • 10. Re: 11g Release 2 installation on Oracle Linux 6
                            TheHades0210
                            Hi dude,

                            I did manage to install 11gR2 on OL6 but stumble upon some errors/prompts during installation regarding missing packages,

                            package: gcc-3.4.6
                            package: elfutils-libelf-devel-0.97
                            package: glibc-devel-2.3.4
                            package: glibc-headers-2.3.4
                            package: gcc-c++-3.4.6

                            and so on...

                            on the guide i'm using (http://www.oracle-base.com/articles/11g/OracleDB11gR2InstallationOnOracleLinux6.php), under SETUP, i tried installing packages from OLE6 DVD and the mentioned packages above cant be installed because of some dependencies, that i need to install first. I'm not sure if the required packages are on OLE6 media kit or not. If this is the case that i have missing packages, what best i can do? If the packages are not on the kit, is there a link where i can DL the missing packages?

                            Thanks in advance.

                            Hades,
                            • 11. Re: 11g Release 2 installation on Oracle Linux 6
                              Dude!
                              I didn't get a change to install Oracle 11g under Oracle Linux 6 yet.

                              You will certainly have more luck installing Oracle 11g under Oracle Linux 5 where you can install the "oracle-validated" package that will take care of software requirements and installation dependencies, as mentioned earlier. Since you are using VirtualBox, there is no requirement that would force you to use version 6.
                              • 12. Re: 11g Release 2 installation on Oracle Linux 6
                                TheHades0210
                                Aloha dude,

                                Thank you. This time i will try OLE5. :)

                                Hades
                                • 13. Re: 11g Release 2 installation on Oracle Linux 6
                                  Helios-GunesEROL
                                  Hi;

                                  Any oracle versions are not certified wiht OEL or RHEL 6 yet. But tim has already site entery

                                  Please see:
                                  Oracle Database 11g Release 2 (11.2) Installation On Oracle Linux 6,
                                  http://www.oracle-base.com/articles/11g/OracleDB11gR2InstallationOnOracleLinux6.php

                                  Regard
                                  Helios
                                  • 14. Re: 11g Release 2 installation on Oracle Linux 6
                                    TheHades0210
                                    Hi Dude,

                                    I did manage to install OLE 5 and installed successfully 11gR2 on it. I'm on the process of creating an instance on the said database, but i stumble on several errors;

                                    1. ORA-09925: Unable to create audit trail file

                                    after clicking OK i will receive this error;

                                    2. ORA-01017: invalid username/password; log on denied

                                    and after;

                                    3. ORA-01012: not logged on

                                    This prompts appears during the creation on instance. Please refer below for reference.

                                    [oracle@ole5 ~]$ id
                                    uid=501(oracle) gid=501(oinstall) groups=501(oinstall),502(dba),503(oper),504(asmadmin)
                                    [oracle@ole5 ~]$ env|sort
                                    CLASSPATH=/u01/app/oracle/product/11.2.0/db_1/jlib:/u01/app/oracle/product/11.2.0/db_1/rdbms/jlib
                                    COLORTERM=gnome-terminal
                                    DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-AnrEnr2Rfk,guid=64a668470bd8d74af646f6004e0de25b
                                    DESKTOP_SESSION=default
                                    DESKTOP_STARTUP_ID=
                                    DISPLAY=:0.0
                                    G_BROKEN_FILENAMES=1
                                    GDMSESSION=default
                                    GDM_XSERVER_LOCATION=local
                                    GNOME_DESKTOP_SESSION_ID=Default
                                    GNOME_KEYRING_SOCKET=/tmp/keyring-IwnPgJ/socket
                                    GTK_RC_FILES=/etc/gtk/gtkrc:/home/oracle/.gtkrc-1.2-gnome2
                                    HISTSIZE=1000
                                    HOME=/home/oracle
                                    HOSTNAME=ole5.localdomain
                                    INPUTRC=/etc/inputrc
                                    LANG=en_US.UTF-8
                                    LD_LIBRARY_PATH=/u01/app/oracle/product/11.2.0/db_1/lib:/lib:/usr/lib
                                    LESSOPEN=|/usr/bin/lesspipe.sh %s
                                    LOGNAME=oracle
                                    LS_COLORS=no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:.cmd=00;32:.exe=00;32:.com=00;32:.btm=00;32:.bat=00;32:.sh=00;32:.csh=00;32:.tar=00;31:.tgz=00;31:.arj=00;31:.taz=00;31:.lzh=00;31:.zip=00;31:.z=00;31:.Z=00;31:.gz=00;31:.bz2=00;31:.bz=00;31:.tz=00;31:.rpm=00;31:.cpio=00;31:.jpg=00;35:.gif=00;35:.bmp=00;35:.xbm=00;35:.xpm=00;35:.png=00;35:.tif=00;35:
                                    MAIL=/var/spool/mail/oracle
                                    ORACLE_BASE=/u01/app/oracle
                                    ORACLE_HOME=/u01/app/oracle/product/11.2.0/db_1
                                    ORACLE_HOSTNAME=ol5-11gr2.localdomain
                                    ORACLE_SID=DB11G
                                    ORACLE_UNQNAME=DB11G
                                    PATH=/u01/app/oracle/product/11.2.0/db_1/bin:/usr/sbin:/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/oracle/bin
                                    PWD=/home/oracle
                                    SESSION_MANAGER=local/ole5.localdomain:/tmp/.ICE-unix/2727
                                    SHELL=/bin/bash
                                    SHLVL=2
                                    SSH_AGENT_PID=2763
                                    SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
                                    SSH_AUTH_SOCK=/tmp/ssh-AUwvgn2727/agent.2727
                                    TERM=xterm
                                    TMPDIR=/tmp
                                    TMP=/tmp
                                    USERNAME=oracle
                                    USER=oracle
                                    _=/usr/bin/env
                                    WINDOWID=24117329
                                    XAUTHORITY=/tmp/.gdmZKBUXV
                                    XMODIFIERS=@im=none
                                    [oracle@ole5 ~]$

                                    Thanks in advance.

                                    With Thanks,
                                    Hades
                                    1 2 Previous Next