6 Replies Latest reply on Nov 9, 2011 8:38 AM by 898881

    Solaris 11 Express and Intel Z68 chipset motherboards

      New to solaris and want to get it working on my motherboard with a z68 chipset.

      So far unable to install from live cd/text or even tried to preinstall on another system via usb to HDD and then run on the desktop.

      From what I have read.. it should be that the chipset is too new as the last release is from November... is there any way around this issue?

      If there is not... is there any incremental updates for new chipsets? or do I need to wait for the major release?

      How long would you expect to wait for the new chipset support?

      May have to go Ubunntu for now... or freebsd.....

      Any advice would be much appreciated.

        • 1. Re: Solaris 11 Express and Intel Z68 chipset motherboards
          You could try installing Virtual Box under the already installed OS which I would presume to be Windows unless you've already pitched it and installed some version of Linux. Either way is ok since Virtual Box will run on either. Once VB is installed then add a Solaris instance and give it a shot. Should work.

          • 2. Re: Solaris 11 Express and Intel Z68 chipset motherboards

            What is the error message you are getting when you try to install the Solars 11 Express . Can you please post it so we can diagnose further.

            • 3. Re: Solaris 11 Express and Intel Z68 chipset motherboards
              Thanks for the replys..

              No OS.. trying to avoid windows... so haven't installed it... can't use esxi due to compatability... freebsd have some issues too.
              Trying Ubuuntu... but also encountering some issues....

              The install does not get far.. no errors displays.

              Gets me the choice of install types, goes through the .......... loading screen.

              Shows me the SunOS... blah blah version text command line screen and thats it.

              Stuck on that screen and goes nowhere.

              Nothing I can do... can't type.. can't get out of it.. shows me no error.

              • 4. Re: Solaris 11 Express and Intel Z68 chipset motherboards
                Can you tell me what motherboard you tried? I have exactly the same issue with a GigaByte GA-Z68A-D3H-B3.

                If I edit the GRUB boot entry and add "-v" for verbs, I see it enumerate the SPU properties, specify the amount of memory and that's it.

                Without the verbose setting, this corresponds exactly with what you described. The same CPU boots Solaris Express 11 fine on a P67 based motherboard.

                I'd like to determine if it is a problem with GigaByte Z68 motherboards or if it's a problem with Z68 in general.

                • 5. Re: Solaris 11 Express and Intel Z68 chipset motherboards
                  I'm also trying to install Solaris 11 Express using a Z68 motherboard. More specifically a GA-Z68X-UD4-B3 with a i7 2600K CPU. The error I get is the same as above: the boot goes (in verbose mode) until men = 16759924K (0x3fef1d000) and stops there. I tried using other memory configurations with no avail, but maybe the problem is not memory anyway. At least the displaymem at GRUB command prompt goes fine in any memory configuration I tried.

                  Maybe the problem is in the line that usually follows mem = [memory] in Solaris 11 boot: "Using default device instance data". As I'm using actually a USB stick to boot, not a DVD like others with the same problem, the symptom seems to be the same in both cases. I already tried to mess with some variables using kmdb (like cmi_no_init, cmi_panic_on_uncorrectable_error and use_mp) and some NVRAM variables editing the GRUB entry using -B [variable]=[options] (like subs-probe-list, diag-switch? and boot-ncpus). The -m debug does not help at all because in my testing using a VM the actual debug messaging starts after where the boot hangs.

                  Also kmdb commands like ::status, ::showrev, ::stack; ::cpuinfo, ::cpuregs show results identical to my testing VM, which by the way boots normally.

                  Unfortunately I don't know enough about Solaris Express booting process so I recognize this is not a knowledgeable debug method. The flags and variables above mentioned were find googling around and reading man pages for kernel, eeprom and kmdb.

                  Some help and guidance would be very much appreciated here! Kmdb seems to be really powerful but I don't really know how to properly use the tool... Anyone?

                  Edited by: 889172 on Oct 3, 2011 8:24 PM

                  Well, after some more reading and some patience using kbmd ::step and ::step out (to speed up things), I found this:

                  1) <locore_start> calls <main>
                  2) <main> calls <sigcld_list_create> that calls some sub functions and returns control to <main>
                  3) <main> calls <mutex_enter>, <lgrp_init> then <startup>
                  4) <startup> enables kmp (<kmp_enable>), calls <cpuset_only>, <startup_init>, <startup_memlist>, <startup_kmem> (after that x86_features are listed), <startup_vm> (this gives the memory amount), <startup_pci_bios> and finally <startup_modules>
                  5) <startup_modules> calls in succession <microfind>, <get_hwenv>, <process_rtc_config_file>, <sgmtl>, <param_calc>, <mod_setup>, <param_init>, <brand_init>, <seg_init>, <modload> (several times), <moloadonly>, <disp_init>, <set_soft_hostid>, does a lot of stuff (too many :s typing here) and finally calls <clconf_init>
                  6) <clconf_init> jumps to <nomod_zero>, that returns control to <startup_modules>
                  7) <startup_modules> calls <setup_ddi> that calls <read_pciconf_file>, <impl_ddi_init_node_id>, <impl_create_root_class>, <create_devinfo_tree>
                  8) The problem is inside the last function, in some called function or due to some missed jump in the code. I used a ::step out there and didn't have the patience to go back and fine grain it.

                  Is this info useful? I don't have a clue, but after the effort, I had to write it down somewhere to see if anyone with more knowledge than me can help.

                  Edited by: 889172 on Oct 3, 2011 10:49 PM
                  • 6. Re: Solaris 11 Express and Intel Z68 chipset motherboards
                    Disable legacy USB support in the BIOS (both keyboard and storage). This will allow boot to proceed.
                    Unfortunately, this means that it's impossible to install solaris from the USB stick.

                    Just for the record, in my case in pci_autoconfig`process_devfunc, trying to initialize
                    Etron USB3.0 port(s). (MB is Gigabyte GA-Z68XP-UD3)