7 Replies Latest reply: Jul 4, 2011 2:48 AM by Paul M. RSS

    Can not start SQLPLUS without starting iSQLPLUS first. what am I missing ?

    871751
      Installed Oracle 10g . Looks everything was OK.
      Can not start SQLPLUS without starting iSQLPLUS first.* what am I missing ?
        • 1. Re: Can not start SQLPLUS without starting iSQLPLUS first. what am I missing ?
          Paul M.
          Can not start SQLPLUS without starting iSQLPLUS first.*
          What error do you get ? Please post the complete stack.
          • 2. Re: Can not start SQLPLUS without starting iSQLPLUS first. what am I missing ?
            871751
            Here what I'm getting:

            C:\Users\ADM>sqlplus
            Error 6 initializing SQL*Plus
            Message file sp1<lang>.msb not found
            SP2-0750: You may need to set ORACLE_HOME to your Oracle software directory

            C:\Users\ADM>set ORACLE_HOME
            ORACLE_HOME=C:\ORACLE_DB\product\10.2.0\db_1\sqlplus\mesg

            C:\Users\ADM>set SQLPATH
            SQLPATH=C:\ORACLE_DB\product\10.2.0\db_1\sqlplus\admin
            • 3. Re: Can not start SQLPLUS without starting iSQLPLUS first. what am I missing ?
              Paul M.
              C:\Users\ADM>sqlplus
              Error 6 initializing SQL*Plus
              Message file sp1<lang>.msb not found
              SP2-0750: You may need to set ORACLE_HOME to your Oracle software directory
              Try this way :
              C:\>set ORACLE_HOME=C:\ORACLE_DB\product\10.2.0\db_1
              C:\>set PATH=%ORACLE_HOME%\bin;%PATH%
              C:\>set ORACLE_SID=<your SID>
              C:\>sqlplus
              • 4. Re: Can not start SQLPLUS without starting iSQLPLUS first. what am I missing ?
                871751
                thanks for your help but it still doesn't work .
                moreover when I run com as administartor it gives me :
                C:\Windows\system32>sqlplus

                SQL*Plus: Release 10.2.0.1.0 - Production on Sat Jul 2 10:00:14 2011

                Copyright (c) 1982, 2005, Oracle. All rights reserved.

                Enter user-name: scott
                Enter password:
                ERROR:
                ORA-01034: ORACLE not available
                ORA-27101: shared memory realm does not exist


                Enter user-name:
                • 5. Re: Can not start SQLPLUS without starting iSQLPLUS first. what am I missing ?
                  Paul M.
                  Enter user-name: scott
                  Enter password:
                  ERROR:
                  ORA-01034: ORACLE not available
                  ORA-27101: shared memory realm does not exist
                  Seems that your database is down.
                  Enter user-name:
                  Try : */ as sysdba*. If you get "Connected to an idle instance." type startup. What happens?
                  • 6. Re: Can not start SQLPLUS without starting iSQLPLUS first. what am I missing ?
                    871751
                    Microsoft Windows [Version 6.1.7601]
                    Copyright (c) 2009 Microsoft Corporation. All rights reserved.

                    C:\Windows\system32>sqlplus /as sysdba

                    SQL*Plus: Release 10.2.0.1.0 - Production

                    Copyright (c) 1982, 2005, Oracle. All rights reserved.

                    Usage 1: sqlplus -H | -V

                    -H Displays the SQL*Plus version and the
                    usage help.
                    -V Displays the SQL*Plus version.

                    Usage 2: sqlplus [ [<option>] [<logon>] [<start>] ]

                    <option> is: [-C <version>] [-L] [-M "<options>"] [-R <level>] [-S]

                    -C <version> Sets the compatibility of affected commands to the
                    version specified by <version>. The version has
                    the form "x.y[.z]". For example, -C 10.2.0
                    -L Attempts to log on just once, instead of
                    reprompting on error.
                    -M "<options>" Sets automatic HTML markup of output. The options
                    have the form:
                    HTML ON [HEAD text] [BODY text] [TABLE text]
                    [ENTMAP {ON|OFF}] [SPOOL {ON|OFF}] [PRE[FORMAT] {ON|
                    -R <level> Sets restricted mode to disable SQL*Plus commands
                    that interact with the file system. The level can
                    be 1, 2 or 3. The most restrictive is -R 3 which
                    disables all user commands interacting with the
                    file system.
                    -S Sets silent mode which suppresses the display of
                    the SQL*Plus banner, prompts, and echoing of
                    commands.

                    <logon> is: (<username>[<password>][@<connect_identifier>] | /)
                    [AS SYSDBA | AS SYSOPER] | /NOLOG

                    Specifies the database account username, password and connect
                    identifier for the database connection. Without a connect
                    identifier, SQL*Plus connects to the default database.

                    The AS SYSDBA and AS SYSOPER options are database administration
                    privileges.

                    The /NOLOG option starts SQL*Plus without connecting to a
                    database.

                    <start> is: @<URL>|<filename>[.<ext>] [<parameter> ...]

                    Runs the specified SQL*Plus script from a web server (URL) or the
                    local file system (filename.ext) with specified parameters that
                    will be assigned to substitution variables in the script.

                    When SQL*Plus starts, and after CONNECT commands, the site profile
                    (e.g. $ORACLE_HOME/sqlplus/admin/glogin.sql) and the user profile
                    (e.g. login.sql in the working directory) are run. The files may
                    contain SQL*Plus commands.

                    Refer to the SQL*Plus User's Guide and Reference for more information.

                    C:\Windows\system32>
                    • 7. Re: Can not start SQLPLUS without starting iSQLPLUS first. what am I missing ?
                      Paul M.
                      C:\Windows\system32>sqlplus /as sysdba
                      Reread my post, please, and type exactly as posted (there is a blank after /).