13 Replies Latest reply: Jul 4, 2011 7:36 AM by 870313 RSS

    Could not open registry. Registry name: EMPLOYEE

    870313
      I got following error Accessing Peoplesoft portal using PS login

      Pls post the solution
        • 1. Re: Could not open registry. Registry name: EMPLOYEE
          Stephen Phillips
          Here's just some thoughts.

          First, do you know if it just the one user or all of your users? That might help narrow it down to a security concern or a system concern.

          Second, what about trying to go in through the signon.html page. I think the URL should look something like this:
          http://<server name>:<port>/<weblogic domain name>/signon.html

          For me, this is:
          http://skphcm90/HR90DMO/signon.html


          Another thing that might help is looking up what your default portal node is:
          PeopleTools > Portal > Node Definitions, Portal Page

          Since you cannot login, you probably cannot view it online. Here is some SQL that will pull it up from the database:
          SELECT * FROM PSMSGNODEDEFN WHERE LOCALDEFAULTFLG = 'Y';

          For me, this returns PSFT_HR.

          Then, the portal name is in the field PORTAL_NAME:
          SELECT PORTAL_NAME FROM PSMSGNODEDEFN WHERE MSGNODENAME = 'PSFT_HR';

          For me, this returns EMPLOYEE.


          Does it return the same for you?
          • 2. Re: Could not open registry. Registry name: EMPLOYEE
            870313
            Hi Stephen ,

            For me it's return Same.

            SQL> SELECT PORTAL_NAME FROM PSMSGNODEDEFN WHERE MSGNODENAME = 'PSFT_HR';

            PORTAL_NAME
            -----------------------------------------------------------------------------

            EMPLOYEE


            Can you please post me the solution how to solve this issue.?

            Could not open registry. Registry name: EMPLOYEE

            Edited by: 867310 on Jun 29, 2011 6:33 PM
            • 3. Re: Could not open registry. Registry name: EMPLOYEE
              Nicolas.Gasparotto
              What Peopletools and webserver are you working on ? What URL are you using ?
              Could you post the files content of signon.html and start.html ?
              And also results of the query :
              select MSGNODENAME,LOCALDEFAULTFLG,LOCALNODE,PORTAL_NAME 
              from PSMSGNODEDEFN 
              where LOCALDEFAULTFLG='Y';
              Nicolas.
              • 4. Re: Could not open registry. Registry name: EMPLOYEE
                870313
                Currently I am working on PeopleSoft HRMS 9.1 and Peoplesoft Tools 8.51.

                Webserver: Web Logic 10.3

                URL: http://vmpsofthrms91:8000/ps/signon.html

                Resulted query is :

                SQL> select MSGNODENAME,LOCALDEFAULTFLG,LOCALNODE,PORTAL_NAME
                  2  from PSMSGNODEDEFN
                  3  where LOCALDEFAULTFLG='Y';
                
                MSGNODENAME
                -----------------------------------------------------------------
                
                LOC  LOCALNODE
                --- ----------
                PORTAL_NAME
                -----------------------------------------------------------------
                
                PSFT_HR
                Y            1
                EMPLOYEE
                Start.html file look like this :
                <html>
                
                
                <LINK REL="SHORTCUT ICON" HREF="<%=psCtxPath%><%=psHome%>/favicon.ico">
                <frameset rows="82,*" border="0" frameborder="0">
                <frame name="header" SRC="<%=servletLoc%>PORTAL/QE_LOCAL/s/WEBLIB_MENU.ISCRIPT3.FieldFormula.IScript_GetMenuHeader/" FRAMEBORDER="0" marginheight="0" scrolling="no" noresize>
                <frame name="main" SRC="<%=servletLoc%>PORTAL/QE_LOCAL/s/WEBLIB_MENU.ISCRIPT3.FieldFormula.IScript_DrillDown/?Level=0" FRAMEBORDER="0" marginheight="0">
                </frameset>
                </html>
                SIGNON.HTML LOOK LIKE THIS:
                <HTML>
                <HEAD>
                
                
                <meta HTTP-EQUIV='Refresh' CONTENT='1; URL=../psp/ps/?cmd=login'>
                </HEAD>
                </HTML>
                Edited by: 867310 on Jun 29, 2011 6:55 PM

                Edited by: 867310 on Jun 29, 2011 7:02 PM

                Edited by: 867310 on Jun 29, 2011 7:05 PM
                • 5. Re: Could not open registry. Registry name: EMPLOYEE
                  870313
                  Anyone please post your solution it will be helpful . I am unable to find the solution

                  Edited by: 867310 on Jun 29, 2011 7:57 PM
                  • 6. Re: Could not open registry. Registry name: EMPLOYEE
                    Nicolas.Gasparotto
                    867310 wrote:
                    Anyone please post your solution it will be helpful . I am unable to find the solution
                    This is a based volunteers' forum, do not request people responding within an hour. Maybe some other people will come later with an idea, depending of the timezone they are from, that's not always your.
                    If that's really urgent, you could raise a SR to the Oracle support.
                    Thank you,

                    Nicolas.
                    • 7. Re: Could not open registry. Registry name: EMPLOYEE
                      Nicolas.Gasparotto
                      Have you looked for any error message in webserver/appserver logfiles ?

                      Nicolas.
                      • 8. Re: Could not open registry. Registry name: EMPLOYEE
                        870313
                        I am getting following error in APPServ Logs.

                        -----

                        1 PortalRegistry](2) PrdmGet failed with error code 3, portal name EMPLOYEE

                        Edited by: Silambarasan.K on Jul 4, 2011 1:03 PM
                        • 9. Re: Could not open registry. Registry name: EMPLOYEE
                          Stephen Phillips
                          My signon.html page looks the same:


                          <HTML>
                          <HEAD>
                          <meta HTTP-EQUIV='Refresh' CONTENT='1; URL=../psp/HR90DMO/?cmd=login'>
                          </HEAD>
                          </HTML>


                          The different is in the URL, my weblogic domain name is different. Are you sure your domain is "ps"? Just a thought.


                          On Google, I found a few URLs that might be helpful. I am not sure.
                          http://www.peoplesoftfans.com/forums/viewtopic.php?=&p=21517
                          http://peoplesoft.ittoolbox.com/groups/technical-functional/peopletools-l/web-server-problems-967894


                          When you go to http://vmpsofthrms91:8000/ps/signon.html does it refer you to another URL? What is that URL?

                          Thanks,

                          Stephen
                          • 10. Re: Could not open registry. Registry name: EMPLOYEE
                            870313
                            Hi Stephen,

                            This is local machine sign on URL

                            My weblogic Domainname : peoplesoft
                            Site name : ps

                            Edited by: Silambarasan.K on Jul 4, 2011 1:02 PM
                            • 11. Re: Could not open registry. Registry name: EMPLOYEE
                              Nicolas.Gasparotto
                              Hi,

                              What gives the query :
                              SELECT PORTAL_NAME, VERSION, STATUS FROM PSPRDMDEFN;
                              Has it ever worked before or is it a brand new install ?

                              Nicolas.
                              • 12. Re: Could not open registry. Registry name: EMPLOYEE
                                Michel
                                Are you trying to access the page from a Windows Server installation? I know that the enhanced security configuration of IE can cause error message like this one. Try accessing the Peoplesoft page from any other machine then the virtual box if this is the case.
                                • 13. Re: Could not open registry. Registry name: EMPLOYEE
                                  870313
                                  Thanks for all.. issue is solved after reinstalling.