2 Replies Latest reply: Jul 1, 2011 6:06 AM by 872458 RSS

    “Java Cryptography Architecture (JCA) provider” and “Java update” issue!

      We developed our own JCA-provider. We installed it and registered using "Static Registration" procedure (as described in [Installing Providers| http://download.oracle.com/javase/6/docs/technotes/guides/security/crypto/CryptoSpec.html#ProviderInstalling ]). But when the Java stared automatic update process he failed with following error:

      "lib\security\java.security: Old File not found.... " (see http://i.stack.imgur.com/vMhER.jpg)

      After this warning Java update fails and java can't work anymore. JRE return the following error:

      "The procedure entry point _JVM_LoadSystemLibrary@4 could not be located in dynamic link library jvm.dll" (see http://i.stack.imgur.com/pHp1V.jpg)

      We can't do anything. Java is crashed after automatic update....

      Does anybody know what happened and how we need to install/register our JCA-provider to prevent such an error?

      Also you can see description of this issue on [“Java Cryptography Architecture (JCA) provider” and “Java update” issue!| http://stackoverflow.com/questions/6520473/java-cryptography-architecture-jca-provider-and-java-update-issue ]

      P.S. Update was from 1.6.0_24 to 1.6.0_26 version