5 Replies Latest reply: Jul 8, 2011 5:53 AM by user10569054 RSS

    Application Server not reading formsweb.cfg

    user10569054
      Hi all,
      I've installed Apps Fusion middleware Version 12.1 on RHEL 3.3.
      I'm able to access forms through direct path like

      http://appshr:7778/forms/frmservlet?form=Holiday_master.fmx

      but when i try to access using alias like below it gives me error FRM :40010 can not read Form abcd
      http://appshr:7778/forms/frmservlet?form=abcd

      I've set most of the environmental Veriable but still error persists...

      I've had setup same Environment for same machine but OS was Windows Server 2003 R2 and it is worked/ing fine.
      But not getting any idea where i messed up here in Linux?

      any ideas will be appreciated.

      Regards!
        • 1. Re: Application Server not reading formsweb.cfg
          mseberg
          If I remember correctly there are two formsweb.cfg files and one of them does nothing.

          A search will confirm this.

          On my install the "hot" one is here :

          /u01/app/oracle/product/fmw/user_projects/domains/FormsReports/servers/WLS_FORMS/tmp/_WL_user/formsapp_11.1.1/wb1h9e/config/formsweb.cfg

          OR

          Location: <DOMAIN_DIR>/servers/WLS_FORMS/stage/formsapp/11.1.1/formsapp/config.

          As you can see I'm one version version behind you, however I believe it works the same.

          If you find this helpful please mark it so.

          Best Regards

          mseberg

          My default.env is located here :

          Location: <DOMAIN_DIR>/servers/WLS_FORMS/stage/formsapp/11.1.1/formsapp/config

          Edited by: mseberg on Jul 7, 2011 5:13 AM
          • 2. Re: Application Server not reading formsweb.cfg
            user10569054
            Thanks for the reply.
            We tried the other what you told *<DOMAIN_DIR>/servers/WLS_FORMS/stage/formsapp/11.1.1/formsapp/config.* but we didn't find any file there.

            We have two homes, one for DB and for Apps.

            DB Home */data1/u01/app/oracle/Orahome_inv*
            Apps Home */data1/u01/app/oracle/OraHome_frsvr*

            My formsweb.cfg file contents are as below
            ===============================
            WebUtilArchive=frmwebutil.jar,jacob.jar
            WebUtilLogging=off
            WebUtilLoggingDetail=normal
            WebUtilErrorMode=Alert
            WebUtilDispatchMonitorInterval=5
            WebUtilTrustInternal=true
            WebUtilMaxTransferSize=16384
            baseHTMLjinitiator=webutiljini.htm
            baseHTMLjpi=webutiljpi.htm
            archive_jini=frmall_jinit.jar
            archive=frmall.jar
            lookAndFeel=oracle
            [abcd]
            title=test form
            forms=Holiday_master.fmx
            userid=abcd/abcd
            
            ==================
            This is my environment setting
            ========= 
            SSH_CONNECTION=10.2.12.1 4713 10.1.100.101 22
            TMP=/tmp
            PATH=/usr/sbin:/data1/u01/app/oracle/Orahome_inv/bin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/data1/u01/app/oracle/Orahome_inv/dcm/bin:/data1/u01/app/oracle/Orahome_inv/opmn/bin:/data1/u01/app/oracle/Orahome_inv/Apache/Apache/bin
            SHELL=/bin/ksh
            HOSTNAME=appshr
            USER=oracle
            TMPDIR=/tmp
            ORACLE_BASE=/data1/u01/app/oracle
            SSH_CLIENT=10.2.12.1 4713 22
            ORACLE_HOME=/data1/u01/app/oracle/Orahome_inv
            TERM=xterm
            INPUTRC=/etc/inputrc
            G_BROKEN_FILENAMES=1
            ORACLE_SID=appshr
            LANG=en_US.UTF-8
            SSH_TTY=/dev/pts/0
            LOGNAME=oracle
            LS_COLORS=no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
            MAIL=/var/spool/mail/oracle
            FORMS_PATH=/data1/u01/app/oracle/OraHome_frsvr/forms
            HOME=/home/oracle
            HISTSIZE=1000
            LESSOPEN=|/usr/bin/lesspipe.sh %s
            LAMHELPFILE=/etc/lam/lam-helpfile
            SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
            QTDIR=/usr/lib/qt-3.1
            ORACLE_TERM=xterm
            ===================
            is it due to wrong home setting in env file?

            Regards..
            • 3. Re: Application Server not reading formsweb.cfg
              Fabian
              Hi,
              Make the below entry in formsweb.cfg

              [abcd]
              envFile=abcd.env
              form=Holiday_master.fmx
              userid=username/password@net_service_name(entry made in tnsame.ora)
              archive=frmall.jar
              archive_jini=frmall_jinit.jar,frmwebutil.jar,jacob.jar
              imagebase=codebase
              term=frmpcweb.res
              baseHTML=webutilbase.htm
              baseHTMLjinitiator=webutiljini.htm
              baseHTMLjpi=webutiljpi.htm
              WebUtilArchive=frmwebutil.jar,jacob.jar
              PageTitle=test form

              Now search for this parameter "envFile" in formsweb.cfg
              This is env file that is actually pickin up when you hit the url
              http://appshr:7778/forms/frmservlet?form=abcd

              Create a new .env file ie copy the existing .env in the same location and rename it to abcd.env
              Now in abcd.env
              Change the
              ORACLE_HOME=/data1/u01/app/oracle/OraHome_frsvr
              FORMS_PATH=/data1/u01/app/oracle/OraHome_frsvr/forms(path where all your forms are placed)

              Now Instead of this
              http://appshr:7778/forms/frmservlet?form=abcd

              Try
              http://appshr:7778/forms/frmservlet?config=abcd

              Regards
              Fabian
              • 4. Re: Application Server not reading formsweb.cfg
                user10569054
                Thanks.
                We just made change to URL what you said(http://appshr:7778/forms/frmservlet?config=abcd) and worked.

                Regards
                • 5. Re: Application Server not reading formsweb.cfg
                  user10569054
                  Could you tell me why the link we were trying not worked ?

                  Regards!

                  Edited by: user10569054 on Jul 8, 2011 5:52 PM