0 Replies Latest reply on Jul 11, 2011 6:44 PM by clcarter

    vmware x64 linux Fedora 15 Live CD Install

      Just in case anyone wants to give Fedora 15 x64 Live distro a try for an 11gXE install, will leave this question unanswered for a day or two- free helpful points for anyone wanting to add feedback. And "Correct Answer" points to the first post with a correct swap resize command ;)

      Did have a couple minor glitches, one was not remembering/not knowing exactly how to get a swap resize done either command line or finding the right GUI tool.

      An 8GB partition is enough to get the install and configure completed. After swap, boot, et. al. partitions are added and linux install done, root partition had about 5.6G free space left. Of course, if you're installing for a real server you'll want separate drive partitions for program, data, archivelog, backup files, etc., but this is just a Live CD ... and its XE ... and separate partitions is a whole separate topic anyway.

      And the first glitch I had was from disconnecting the primary NIC from the network, a long long time ago. VMConsole would not talk to any VM- its a Windows XP SP2 host, and that's the main reason for leaving the network card disconnected.

      After setting a static IP on the primary NIC, vmconsole worked like a champ. I set a 192.168 address on the same network as the VM bridge interface, without the static IP set on the dead interface the console would not talk to any VM.

      Second glitch was probably from setting the VM memory to 1000M, not 1024M, so when was time to $ rpm -ivh the package, swap space was a few MB short of 1950MB, I think that was the minimum MB figure the package griped on. The disk utility GUI showed a full 2GB swap- but someone must be counting 1000B as one KB, not 1024B, or maybe its the 1000KB vs. 1024KB = 1MB debate.

      Then wasted a bit of time trying to remember how to resize a swap partition, and ended up whacking the VM and starting over, this time on the Live install taking the show/edit volume manager option along the way to be sure it would pass a minimum swap check, took a few MB from root partition and added it to swap.

      First run of a $ sudo ...oracle-xe configure failed- the instance wouldn't start since it did somehow pick up and use the FQDN hostname for LOCAL_LISTENER parameter and I'd somehow skipped setting that properly on the host install.

      So after adding a new /etc/hosts entry for the VM ip with short and long versions of the hostname, changing (and simplifying) the listener.ora entry, and also using the VM network IP instead of hostname, the configure worked fine.

      The configure took less than ten minutes. Its an AMD 64 host, perhaps 2.2 or maybe its 2.4GHz, not a dual nor quad core processor. And couldn't tell you what flavor of VMWare, it was downloaded maybe two years ago, if that might tell you something about the shameful neglect on my vm testing platform ;0

      To summarize the details on the fixes:
      $ sudo vi /etc/hosts
      ... add line: myvm1 myvm1.mydomain
      ... :w!q
      $ sudo passwd oracle
        ... set something reasonably strong ...
      $ su - oracle
      ... $ vi xe_env
      ... create lines:
      export ORACLE_HOME=/u01/.../xe
      export PATH=$ORACLE_HOME/bin:$PATH
      export ORACLE_SID=XE
      ... :w!q
      $ . ./xe_env
      $ cd $ORACLE_HOME/network/admin
      $ vi listener.ora
      ... this is ALL that is required for LISTENER = in listener.ora:
      LISTENER =
        (ADDRESS_LIST =
           (ADDRESS =
              (PROTOCOL = TCP)
              (Host =
              (Port = 1521)
      # this is optional too
      ... w!q
      $ exit  # return to regular admin user shell
      $ sudo ...oracle-xe configure
      And can't forget adding the local (admin) user login to the dba group too.

      What I did find surprising is the configure process did set a LOCAL_LISTENER parameter somewhere along the way. And that LOCAL_LISTENER has much of any sort of validity check on it at startup, beyond a syntax/matching parenthesis check. When 1521 is the port of choice, automatic instance registration can override the need to set LOCAL_LISTENER, and a listener isn't required for a database startup either.

      The other "out of the box" configuration lines in listener.ora are only needed if you're interested in ipc and extproc connections. If you don't need it, don't turn it on- a good guideline to follow.

      Edited by: clcarter on Jul 11, 2011 11:43 AM
      corrected oracle-xe configure syntax