This discussion is archived
2 Replies Latest reply: Jul 13, 2011 12:48 AM by 872106 RSS

Corrupt label on T5240

872106 Newbie
Currently Being Moderated
On a T5240 with 6 disks I decided to mirror the 1st disk (with Solaris 10 on it) on the 2nd one. Things seemed to go well at the beginning:

# boot cdrom -s

# raidctl -c c1t0d0 c1t1d0
Creating RAID volume will destroy all data on spare space of member disks, proceed (yes/no)? yes
/pci@400/pci@0/pci@8/scsi@0 (mpt0):
Physical disk 0 created.
/pci@400/pci@0/pci@8/scsi@0 (mpt0):
Physical disk 1 created.
/pci@400/pci@0/pci@8/scsi@0 (mpt0):
Volume 0 created.
/pci@400/pci@0/pci@8/scsi@0 (mpt0):
Physical disk (target 1) is |out of sync||online|
/pci@400/pci@0/pci@8/scsi@0 (mpt0):
Volume 0 is |enabled||degraded|
/pci@400/pci@0/pci@8/scsi@0 (mpt0):
Volume 0 is |enabled||resyncing||degraded|
WARNING: /pci@400/pci@0/pci@8/scsi@0/sd@0,0 (sd0):
Corrupt label - bad geometry

Label says 286718976 blocks; Drive says 286607360 blocks
WARNING: /pci@400/pci@0/pci@8/scsi@0/sd@0,0 (sd0):
Corrupt label - bad geometry

Label says 286718976 blocks; Drive says 286607360 blocks
Volume c1t0d0 is created successfully!

# raidctl -l c1t0d0
Volume Size Stripe Status Cache RAID
Sub Size Level
Disk
----------------------------------------------------------------
c1t0d0 136.6G N/A SYNC OFF RAID1
0.0.0 136.6G GOOD
0.1.0 136.6G GOOD
# format
Searching for disks...WARNING: /pci@400/pci@0/pci@8/scsi@0/sd@0,0 (sd0):
Corrupt label - bad geometry

Label says 286718976 blocks; Drive says 286607360 blocks
WARNING: /pci@400/pci@0/pci@8/scsi@0/sd@0,0 (sd0):
Corrupt label - bad geometry

Label says 286718976 blocks; Drive says 286607360 blocks
done

c1t0d0: configured with capacity of 136.49GB


AVAILABLE DISK SELECTIONS:
0. c1t0d0 <LSILOGIC-LogicalVolume-3000 cyl 65533 alt 2 hd 16 sec 273>
/pci@400/pci@0/pci@8/scsi@0/sd@0,0
1. c1t2d0 <HITACHI-H103014SCSUN146G-A2A8-136.73GB>
/pci@400/pci@0/pci@8/scsi@0/sd@2,0
2. c1t3d0 <HITACHI-H103014SCSUN146G-A2A8-136.73GB>
/pci@400/pci@0/pci@8/scsi@0/sd@3,0
3. c1t4d0 <HITACHI-H103014SCSUN146G-A2A8-136.73GB>
/pci@400/pci@0/pci@8/scsi@0/sd@4,0
4. c1t5d0 <HITACHI-H103014SCSUN146G-A2A8-136.73GB>
/pci@400/pci@0/pci@8/scsi@0/sd@5,0
Specify disk (enter its number): 0
selecting c1t0d0
[disk formatted]
WARNING: /pci@400/pci@0/pci@8/scsi@0/sd@0,0 (sd0):
Corrupt label - bad geometry

Label says 286718976 blocks; Drive says 286607360 blocks
Disk not labeled. Label it now? yes
WARNING: /pci@400/pci@0/pci@8/scsi@0/sd@0,0 (sd0):
Corrupt label - bad geometry

Label says 286718976 blocks; Drive says 286607360 blocks
WARNING: /pci@400/pci@0/pci@8/scsi@0/sd@0,0 (sd0):
Corrupt label - bad geometry

Label says 286718976 blocks; Drive says 286607360 blocks
WARNING: /pci@400/pci@0/pci@8/scsi@0/sd@0,0 (sd0):
Corrupt label - bad geometry

Label says 286718976 blocks; Drive says 286607360 blocks
Warning: error writing VTOC.
Warning: no backup labels
Write label failed

So the mirroring process seemed to work fine, but I get this corrupt label and format does not accept to change it.

Any suggestion ?
  • 1. Re: Corrupt label on T5240
    Nik Expert
    Currently Being Moderated
    Hi.
    When you create mirror on this server you lost data on disks.
    After reboot You should be available label this disk.


    Regards.
  • 2. Re: Corrupt label on T5240
    872106 Newbie
    Currently Being Moderated
    I thought that creating the mirror did not affect the 1st disk. But obviously it was not exploitable any more.

    So I ran format -e and labeled the disk 3 times, first time with SMI format, then labeled it with an EFI label, and then labeled it again with an SMI label. Explanation for this is given on http://sunsolve.espix.org/bugid/id/6901327

    Of course the step of labeling with EFI destroyed the partition table for good and all data was lost but the "Corrupt label" message has now gone.

    Edited by: 869103 on 12-Jul-2011 03:19

    Edited by: 869103 on 13-Jul-2011 00:48

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points