1 Reply Latest reply: Jul 13, 2011 2:15 AM by René van Wijk RSS

    Cannot start managed server after create domain from template

    Cuong Pham
      Hello everyone.
      I'm a newbie on WebLogic Server world. After reading some tutorial, I've tried to create a weblogic domain that contains one Admin Server and two Managed Server.

      After creating domain on machine_a (this machine host Admin Server), I created a template of that domain for cloning on remote machine named machine_b. I used pack.sh to create managed template (with -managed=true option)

      On machine_b, I want to create two managed servers (MS_1, MS_2). I used unpack.sh to create domain from template which is copied from machine_a.

      After all, I tried to start two managed servers with script startManagedWebLogic.sh on bin folder of domain. But this error message always appears and start up process failed:
      <Critical> <WebLogicServer> <BEA-000386> <Server subsystem failed. Reason: weblogic.ldap.EmbeddedLDAPException: Empty initial replica
      weblogic.ldap.EmbeddedLDAPException: Empty initial replica
           at weblogic.ldap.EmbeddedLDAP.getInitialReplicaFromAdminServer(EmbeddedLDAP.java:1301)
           at weblogic.ldap.EmbeddedLDAP.start(EmbeddedLDAP.java:221)
           at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
           at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:516)
           at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
           Truncated. see log file for complete stacktrace
      On Admin Console terminal, I found that log:
      <Error> <EmbeddedLDAP> <BEA-000000> <Database Export Failed: null>
      Anyone can tell em what's happened with these managed servers?

      Any suggestion is appreciated.

      Cuong Pham

      Edited by: Doubt_Man on Jul 13, 2011 11:54 AM