5 Replies Latest reply on Nov 30, 2012 6:32 PM by 580288

    ORABPEL-10902 'undefined part element' after importing schema


      I am running SOA Suite Version: (with MLR 2) on Windows XP and using JDeveloper

      I am trying to resolve a problem where I receive the error 'Missing <wsse:Security> in SOAP Header' when calling a secure web service implemented by the Integrated SOA Gateway in E-Business Suite.

      A service request has pointed to the following link where I need to import the schema http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd.


      When I import the schema everything works fine and I can then browse the schema and create variables based on the relevant elements.

      All files compile successfully however when I try and deploy the files or do a re-build I receive the following error:

      [Error ORABPEL-10902]: compilation failed
      [Description]: in "bpel.xml", XML parsing failed because "undefined part element.
      In WSDL at "file:/C:/Oracle/JDeveloper/jdevhome/jdev/mywork/RBS_SOA/DemoPS1/bpel/DemoPS1.wsdl", message part element "{http://xmlns.oracle.com/DemoPS1}DemoPS1ProcessRequest" is not defined in any of the schemas.
      Please make sure the spelling of the element QName is correct and the WSDL import is complete.

      If I remove the entry in the WSDL file for the imported schema (after obviously deleting any referencing variables) then the build/deployment is successful.

      I can add this URL via Tools --> Preferences --> XML Schemas --> User Schemas so I don't think it is a problem with the connection to the URL via the proxy server I am using for my connection. I have tried removing the proxy server option under 'Web Browser and Proxy' but still no joy.

      Any ideas greatly appreciated.

      Has anyone tried to import this schema before?