This discussion is archived
2 Replies Latest reply: Sep 20, 2006 2:08 AM by 534770 RSS

REP-1800: Formatter error. VGS-1701: Not enough memory

407258 Newbie
Currently Being Moderated
When i run the report which is having a bit large query, it is running when i specify less data to be fetched in From & To dates, say for 2 days. When, i run the same report for a month, it is showing "Unable to run report". The error which is showing is :

REP-1800: Formatter error. VGS-1701: Not enough memory

I do not know the reason for this error. Please help me in solving this doubt as it is very urgent.
  • 1. Re: REP-1800: Formatter error. VGS-1701: Not enough memory
    384471 Newbie
    Currently Being Moderated
    I do not know which Reports version are you using . Assuming you are using Reports 6i (even for 9i solution will be
    similar)

    1) Check if there is enough disk space for a temporary file in the temp file location.

    The temp file location is specified in REPORTS60_TMP (for 9i REPORTS_TMP) registry variable
    HKLM\Software\Oracle\Home<x>

    2) See the following note, straight from metalink

    Problem Description
    -------------------

    You are running a very large report to screen or preview and
    you get the following errors:

    rep-1800 formatter error
    vgs-1701 not enough memory


    Solution Description
    --------------------

    Increase the size of the buffer for the report.

    Reports has a runtime parameter called BUFFERS; if you are
    running the report in Report Builder then do the following:

    1. Click on Tools --> Preferences (Tools --> Tools Options for 2.5.x)
    2. Go to "Runtime Settings" TAB
    3. Increase the size of the BUFFERS (you might need to double
    the size depending on the size of your report)

    From the command line, do as follows:

    rwrun60 report=<..> userid=<..> ... buffers=<size>

    where size is a number from 1 through 9,999. For some
    operating systems, the upper limit may be lower.


    Explanation
    -----------

    BUFFERS is the size of the virtual memory cache in kilobytes.
    You should tune this setting to ensure that you have enough
    space to run your reports, but not so much that you are using
    too much of your system's resources.

    Usage Notes
    -----------
    If this setting is changed in the middle of your session,
    the change does not take effect until the next time the report is run.

    References
    ----------

    See online help --> KEYWORD: buffers


    Thanks
    The Oracle Reports Team
  • 2. oracle in dual processor (urgent)
    534770 Newbie
    Currently Being Moderated
    i have using oracle in dual processor in my server, but some of my report (5 user using these report) run very slowly. i have 2 Gb memory. i have already checked the index and i did the export import to make sure there's not chain row. but still this report run very slowly. do i have to defragment my server? because yesterday. i did long processing that took 58 hours.

    i do not know the reason. please help me to solve this as it is very urgent

    Thanks in advance

    Widhi