2 Replies Latest reply: Aug 15, 2011 5:01 AM by 856627 RSS

    Unable to see replication group indexes at view site


      I have added some tables and their indexes to a materialized view group at the master site

      I can look in user_repobject at the master site and can see all tables and indexes

      I then created some simple fast refresh materialized views at the view site

      I cannot see the indexes that i had added at the master site when i am logged into the view site

      So if i query the materialized views at the view site the explain plan does not show that the indexes are available

      Is there a process that i need to follow to make the master site indexes available at the view site?

      Any help would be great thanks

      The version of oracle server is
      The client is

      Best regards

        • 1. Re: Unable to see replication group indexes at view site
          Hemant K Chitale
          See http://download.oracle.com/docs/cd/E11882_01/server.112/e10706/reptrouble.htm#i9450

          You would had to add the Master_RepObject and and call Generate_Replication_Support between the SUSPEND and RESUME.
          The actual creation would be pushed through the DBMS_DEFER_SYS.

          Do you have the jobs running in the background ? Have you queried DBA_REPCATALOG to see if the request to create the indexes has been pushed and executed ?

          (BTW : I have done this for MultiMaster Replication. Not sure if Indexes on MVs are handled similarly or actually need to be manually created).

          Hemant K Chitale
          • 2. Re: Unable to see replication group indexes at view site
            Hi Hemant

            Many thanks for the reply

            I have been able to create the indexes at the view site and this is fine for me (the amount of data is small so i dont think there will be a performance hit)

            The links were useful thanks

            Best regards