This discussion is archived
4 Replies Latest reply: Sep 26, 2011 2:04 PM by MattMilella RSS

Smartview keeps poping up the "decompression failed" error after upgrade

883103 Newbie
Currently Being Moderated
Hi,

2 weeks ago we upgraded our Windows server where essbase is running from 2003 to 2008 R2. After upgrade users keep receiving the "decompression failed" error when working with Essbase. They currently use client versions 11.1.2.0 and 11.1.2.1.

We have tried to key in the registry settings for connection timeout on the client side to 180000 and later to 900000 ms with no success (http://essbaselabs.blogspot.com/2010/02/smart-view-timeout-settings.html). The "decompression failed" error comes always after session timeout.

It looks like the "decompression failed" error replaced the previously thrown "connection timed out" error.

Does anyone have any ideas?

Thanks for every ideas...
  • 1. Re: Smartview keeps poping up the "decompression failed" error after upgrade
    606783 Newbie
    Currently Being Moderated
    Were you able to resolve the problem ? I am receiving this error after I increase the row limit in APS essbase properties. Please let me know

    - Ap
  • 2. Re: Smartview keeps poping up the "decompression failed" error after upgrade
    Jasmine Pauline-Oracle Expert
    Currently Being Moderated
    If your users have IE 7 installed, the default timeout is 30 seconds. The following two Microsoft articles will assist in increasing the timeout:

    http://support.microsoft.com/kb/813827
    http://support.microsoft.com/kb/181050

    Prior to any installation, upgrade or modification, it is advised that a full backup be done of all related environments. This includes servers, file systems, registry keys, repositories and databases within the related environments.

    It is strongly recommended to engage your Systems Administrator to assist with the following steps.

    The following client side registry keys need to be added:

    1. Click Start, click Run, type RegEdit, and then click OK.

    2. Locate and then click the following key in the registry:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\InternetSettings

    3. On the Edit menu, point to New, and then click DWORD Value.

    4. Type KeepAliveTimeout and then press ENTER.

    5. On the Edit menu, click Modify.

    6. In the Base panel, ensure that decimal is selected.

    7. Type the appropriate time-out value (in milliseconds). It is recommended that you enter 180000 (3 minutes) or longer if required.

    8. Click OK.

    9. Repeat steps 3-8 above to add ReceiveTimeout and ServerInfoTimeout per below information:

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]\
    "ReceiveTimeout"=dword:00dbba00
    "KeepAliveTimeout"=dword:0002BF20
    "ServerInfoTimeout"=dword:0002BF20

    After making the changes, the client machine must be rebooted.

    These registry changes are the recommended settings from Microsoft. In some cases (for example, slower connection speeds), you may need to increase the KeepAliveTimeout if these settings do not work.

    Refer: Decompression Error In Smart View on a Refresh (Doc ID 1333061.1) on My Oracle Support.

    HTH-
    Jasmine.
  • 3. Re: Smartview keeps poping up the "decompression failed" error after upgrade
    user8628169 Explorer
    Currently Being Moderated
    Did you try the following:

    update following entry as true in essbase.properties file:
    smartview.webservice.gzip.compression.disable= true

    This was the setting in versions prior to 11.1.2, so it should not hamper any of your existing sheets
    try it
  • 4. Re: Smartview keeps poping up the "decompression failed" error after upgrade
    MattMilella Journeyer
    Currently Being Moderated
    The last post is correct this is an issue with compression and disabling it will get rid of this message. When the session times out the user will still get an error but the error will not fail decompression.

    So if you turn compression off you will get the proper error message but the users will still have to log back in.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points