This discussion is archived
3 Replies Latest reply: Oct 4, 2011 10:43 AM by abrante RSS

libc.so.1 Updated Version?

885507 Newbie
Currently Being Moderated
I've got a php installation which claims to need version 1.22 for libc.so.1
# /modules/libphp5.so | grep not <
libc.so.1 (SUNW_1.22) => (version not found)

I currently have version 1.21.2
# pvs /usr/lib/libc.so.1
libdl.so.1 (SUNW_1.4, SUNWprivate_1.1);
libc.so.1;
SUNW_1.21.2;
SUNW_1.21.1;
SUNW_1.21;
SUNW_1.20.4;
SUNW_1.20.1;
SUNW_1.20;
SUNW_1.19;
SUNW_1.18.1;
SUNW_1.18;
SUNW_1.17;
SUNW_1.16;
SUNW_1.15;
SUNW_1.14;
SUNW_1.13;
SUNW_1.12;
SUNW_1.11;
SUNW_1.10;
SUNW_1.9;
SUNW_1.8;
SUNW_1.7;
SUNW_1.6;
SUNW_1.5;
SUNW_1.4;
SUNW_1.3;
SUNW_1.2;
SUNW_1.1;
SUNW_0.9;
SUNW_0.8;
SUNW_0.7;
SISCD_2.3;
SYSVABI_1.3;
SUNWprivate_1.2;
SUNWprivate_1.1;

Does anyone know where I could find the 1.22 version of libc.so.1? The server is currently patched to Generic_122300-54.

Thanks for your time!
  • 1. Re: libc.so.1 Updated Version?
    abrante Pro
    Currently Being Moderated
    Well, the updated libraries comes with the patches, but its a bit hard to tell exactly which library version which comes with which patch.

    One solution is to just apply the latest recommended cluster, othervise the latest libc patch for Solaris 9 is 112874-47, which also require a later kernel patch.

    .7/M.
  • 2. Re: libc.so.1 Updated Version?
    Karoly Vegh Newbie
    Currently Being Moderated
    Hi,

    have you found a cure for the issue?
    I have a very similar request, Solaris 9 again. They need a suggestion to gain time for a Solaris 10/11 update.

    Does a patchcluster update the libc.so.1 to 1.22?

    TIA,

    wbr,

    c.
  • 3. Re: libc.so.1 Updated Version?
    abrante Pro
    Currently Being Moderated
    Well,

    if there is something compiled for Solaris 9 which uses libc.so.1 1_22 there is definitively a patch which included the desired version, otherwise it would not be possible to build the application with that version.. So yes.

    But then again, its hard to tell exactly which patch which updates it to that version. The latest patch should do the trick though.

    .7/M.§

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points