1 2 Previous Next 21 Replies Latest reply: Sep 26, 2011 8:55 AM by Bruce Go to original post RSS
      • 15. Re: VM Manager fails with "hardnofiles should be set to 8192 but was 0"  error
        mzp
        I had the same issue(one of many) while trying to install VM manager on 5.5

        I was able to fix it by disabling autofs and ypbind. Removed all nis entries from nsswitch.conf. Removed all dba,oinstall,oracle ids from passwd, group and shadow.
        I then ran the createOracle.sh script, verified everything was created correctly and then ran the runInstaller.sh script which installed the manager
        • 16. Re: VM Manager fails with "hardnofiles should be set to 8192 but was 0"  error
          Bruce
          Thanks for the suggestions,

          ypbind was stopped, i stopped autofs


          [root@s08 misc]# /etc/init.d/ypbind status
          ypbind is stopped
          [root@s08 misc]# /etc/init.d/autofs status
          automount (pid 2907) is running
          [root@s08 misc]# /etc/init.d/autofs stop
          Stopping automount: [  OK 

          I the commented out NIS services in /etc/nsswitch.conf (from what i can tell a reboot is not needed)

          Still no luck. Removing oracle user presents a problem as we use this server for production apex http server and i'm not sure what effect this will have on it.

          Bruce
          • 17. Re: VM Manager fails with "hardnofiles should be set to 8192 but was 0"  error
            887284
            The problem seems to be with python24, at least in OEL 5.7. I upgraded to python26 from EPEL repository and run python26 setup.py in the /tmp subdirectory created by the failed installation process. You also might need to rename components/oracle-xe-11.2.0-1.0.x86_64.rpm to oracle-xe-11.2.0.0-0.3.x86_64.rpm and export the components directory as /ovm-bits on your localhost web server.
            • 18. Re: VM Manager fails with "hardnofiles should be set to 8192 but was 0"  error
              821215
              I hit the same problem - the root cause was that in my .bash_profile for the oracle user, it was calling a script which echoed a message.

              Make sure that when you log in as 'oracle" there is no MOTD or similar that is displayed, and that you aren't calling any scripts which will echo something.
              • 20. Re: VM Manager fails with "hardnofiles should be set to 8192 but was 0"  error
                890509
                Hi,
                I am also facing the same issue. Can you please help me out!!
                Bruce, can you please tell me what did you do to avoid these failures.
                I have the exact install log that you have pasted.

                uname -a (Oracle Linux 6.0)
                Linux 2.6.32-100.34.1.el6uek.i686

                Trying to install OracleVM-Manager-3.0.1.iso

                1. /etc/init.d/autofs status
                automount is stopped
                2. /etc/init.d/ypbind status
                ypbind is stopped
                3. ran sudo sh createOracle.sh
                Adding group 'oinstall' with gid '54321' ...
                Adding group 'dba'
                Adding user 'oracle' with user id '54321', initial login group 'dba', supplementary group 'oinstall' and home directory '/home/oracle' ...
                useradd: warning: the home directory already exists.
                Not copying any file from skel directory into it.
                Creating mailbox file: File exists
                Changing ownership of '/home/oracle' to oracle:dba
                Creating user 'oracle' succeeded ...
                Verifying user 'oracle' OS prerequisites for Oracle VM Manager ...
                oracle soft nofile 8192
                oracle hard nofile 8192
                oracle soft nproc 4096
                oracle hard nproc 4096
                oracle soft core unlimited
                oracle hard core unlimited
                Setting user 'oracle' OS limits for Oracle VM Manager ...
                Altered file /etc/security/limits.conf
                Original file backed up at /etc/security/limits.conf.orabackup
                Verifying & setting of user limits succeeded ...
                Modifying iptables
                Adding rules to enable access to :
                7001 : Oracle VM Manager http
                7002 : Oracle VM Manager https
                15901 : Oracle VM Manager VM console proxy
                54321 : Oracle VM Manager core
                iptables: No chain/target/match by that name.
                iptables: No chain/target/match by that name.
                iptables: No chain/target/match by that name.
                iptables: No chain/target/match by that name.
                Saving old iptables config file to /etc/sysconfig/iptables.ovmm
                4. Then ran runInstaller.sh
                It exits without any specific error.
                It exits exactly with same install log that has been posted in this mail chain.

                Thanks in advance.
                • 21. Re: VM Manager fails with "hardnofiles should be set to 8192 but was 0"  error
                  Bruce
                  Hi,
                  I renamed my .bash_profile (which had some echo commands) as in this post


                  "I hit the same problem - the root cause was that in my .bash_profile for the oracle user, it was calling a script which echoed a message.

                  Make sure that when you log in as 'oracle" there is no MOTD or similar that is displayed, and that you aren't calling any scripts which will echo something."
                  1 2 Previous Next