This discussion is archived
2 Replies Latest reply: Feb 4, 2013 2:40 AM by 973520 RSS

Problem on closing bpm task form from custom worklist application

781777 Newbie
Currently Being Moderated
Hi all,

following some material i found on the web, mainly these two articles:

http://soadev.blogspot.com/2011/07/custom-bpm-applicationsinitiabletasks.html
http://redstack.wordpress.com/2011/03/09/creating-the-domain-layer-for-the-worklist/

I successed in realizing a traditional Fusion Web App able to remotely open BPM human task forms in an inline-frame (or pop-up or whatever...).
Anyway, i'm encountering the following problem: whenever i close any of the task forms approving or rejecting the task, the task is pushed forward in the BPM process, but the task form remains opened in the browser and i get the following error:

Caused By: java.lang.NullPointerException
at oracle.bpel.services.workflow.worklist.adf.ADFWorklistBeanUtil.getURLTORedirect(ADFWorklistBeanUtil.java:416)
at oracle.bpel.services.workflow.worklist.adf.InvokeActionBean.getParentURL(InvokeActionBean.java:1048)
at oracle.bpel.services.workflow.worklist.adf.InvokeActionBean.invokeScript(InvokeActionBean.java:1063)

By investigating the matter, i discovered the problem was i didn't provide the "parentURL" parameter to the task flow in the hash map passed to the getTaskDisplayURL method, but even if i provide that parameter the human task form doesn't close itself which is quite annoying. I even tried to pass the "bpmBrowserWindowStatus" parameter with value "close" or "keep", and in that case i get no error but the browser shows an error pop-up with no message and the task form keeps to stay open: arrrrrghhh!!!
Does anybody has any clue on this behavior?

Thanks in advance,
Fabio.
  • 1. Re: Problem on closing bpm task form from custom worklist application
    775041 Newbie
    Currently Being Moderated
    Hello,

    I don't know if you already found solution for your problem, but recently I've found note on metalink: 1364437.1

    Solution (Workaround)
    +1. In your application, locate and open the <HumanTaskName>_TaskFlow.xml file.+

    +2. Remove/comment the finalizer method binding as follows+
    +<!-- <finalizer id="__111">#{invokeActionBean.invokeScript}</finalizer> .... -->+

    +3. Redeploy the human task and test.+

    Rgds,
    W.
  • 2. Re: Problem on closing bpm task form from custom worklist application
    973520 Newbie
    Currently Being Moderated
    Hi Fabio,

    I saw your post and see that you have worked on something similar to my problem.

    I have created an ADF application for human task and integrated manually. I could trigger my UI form BPEL human task but when i invoke any action, it is going to 404 page not found error.

    When i verified the URL, i could see the parentURL mentioned in the parameter list to task flow. Could you please shed some light on this?

    Thanks in advance for the help

    Thanks,
    Pradeep

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points