4 Replies Latest reply on Sep 2, 2011 1:27 PM by 868312

    iBot runs but the cache doesn't gets seeded

    868312
      Hi All,

      I am running an iBot to seed cache. However, when I run the iBot and go to cache, I see only one entry and for which the query is:

      SELECT Logon, Email, "Email Type", "Email Priority", "Cell Phone", "Cell Phone Priority", Pager, "Pager Priority", Handheld, "Handheld Priority", Locale, Language, "Time Zone" FROM "SA System" WHERE Logon IN ('administrator')
      +/* type='delivers' */;+


      But there is no cache entry created for the report that I am running thru iBot. Can anyone give any pointers as to why this is happening?

      Thanks in Anticipation,
      Karan Chadha

      Edited by: kchadha2 on Sep 2, 2011 4:02 PM
        • 1. Re: iBot runs but the cache doesn't gets seeded
          628531
          Reasons Why a Query is Not Added to the Cache:

          * Non-cacheable SQL element. If a SQL request contains Current_Timestamp, Current_Time, Rand, Populate, or a parameter marker then it is not added to the cache.
          * Non-cacheable table. Physical tables in the Oracle BI Server repository can be marked 'non cacheable'. If a query references any non-cacheable table then the query results will not be added to the cache.
          Cache hit. In general, if the query gets a cache hit on a previously cached query, then the results of the current query are not added to the cache. The exception is query hits that are aggregate roll-up hits.
          * Result set is too big.
          * Query is cancelled. This can happen by explicit cancellation from Oracle BI Presentation Services or the Administration Tool, or implicitly through timeout.
          * Oracle BI Server is clustered. Queries that fall into the ‘cache seeding’ family are propagated throughout the cluster. Other queries continue to be stored locally. Therefore, even though a query may be put into the cache on Oracle BI Server node 1, it may not be on Oracle BI Server node 2.

          See http://obiee101.blogspot.com/2008/07/obiee-cache-management.html

          Regards

          John
          http://obiee101.blogspot.com
          http://www.obiee11g.com
          • 2. Re: iBot runs but the cache doesn't gets seeded
            868312
            Hi John,

            But if I run the same report independently, it gets cached. So, guess the issue lies somewhere else.

            Thanks,
            Karan
            • 3. Re: iBot runs but the cache doesn't gets seeded
              Deepak Gupta
              Did u check the cache seeding checkbox while configuring the iBot??
              http://www.artofbi.com/index.php/2010/03/obiee-ibots-obi-caching-strategy-with-seeding-cache/
              • 4. Re: iBot runs but the cache doesn't gets seeded
                868312
                Yes Deepak, I did.

                I am also not able to see the query (for the report that am running thru iBot) in the nqsquery.log file.

                Rgds,
                Karan