8 Replies Latest reply: Sep 7, 2011 8:01 PM by handat RSS

    Problem when intalled Glassfish application server on Ubuntu

    886360
      Hi all,
      i am instaling Glassfish application server, before old version runs well but now i removed and re-installed newest version. It appears problems.
      Step by step
      1. I am using Linux 64
      2. Java jdk 1.7

      dermfx@dermfx:~$ java -version+
      java version "1.7.0"+
      Java(TM) SE Runtime Environment (build 1.7.0-b147)+
      Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)+

      3. I downloaded and run ./java_ee_sdk-6u3-unix-ml.sh
      4. It appears errors


      PERFORMING THE REQUIRED CONFIGURATIONS+
      ______________________________________+

      CREATING DOMAIN+
      _______________+
      *Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin user admin passwordfile - create-domain savelogin checkports=false adminport 4848 instanceport 8080 --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920 domain1*+
      +*/home/dermfx/glassfish3/glassfish/bin/asadmin user admin passwordfile - create-domain savelogin checkports=false adminport 4848 instanceport 8080 --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920 domain1 Warning: You do not have permission to use port 4848 for domain1. Ignoring since the checkports option is set to false.*+
      Warning: You do not have permission to use port 8080 for domain1. Ignoring since the checkports option is set to false.+
      Using port 4848 for Admin.+
      Using port 8080 for HTTP Instance.+
      Using port 7676 for JMS.+
      Using port 3700 for IIOP.+
      Using port 8181 for HTTP_SSL.+
      Using port 3820 for IIOP_SSL.+
      Using port 3920 for IIOP_MUTUALAUTH.+
      Using port 8686 for JMX_ADMIN.+
      Using default port 6666 for OSGI_SHELL.+
      Using default port 9009 for JAVA_DEBUGGER.+
      Distinguished Name of the self-signed X.509 Server Certificate is:+
      +*[CN=dermfx,OU=GlassFish,O=Oracle Corporation,L=Santa Clara,ST=California,C=US]*+
      Distinguished Name of the self-signed X.509 Server Certificate is:+
      +*[CN=dermfx-instance,OU=GlassFish,O=Oracle Corporation,L=Santa Clara,ST=California,C=US]*+
      No domain initializers found, bypassing customization step+
      Domain domain1 created.+
      Domain domain1 admin port is 4848.+
      Domain domain1 allows admin login as user "admin" with no password.+
      *Admin login information for host [localhost] and port [4848]*+
      is being overwritten with credentials provided because the+
      --savelogin option was used during the create-domain command.*+
      *Login information relevant to admin user name [admin]*+
      *for this domain [domain1] stored at*+
      +*[root/.asadminpass] successfully.*+
      Make sure that this file remains protected.+
      Information stored in this file will be used by+
      asadmin commands to manage this domain.+
      Command create-domain executed successfully.+


      STARTING DOMAIN+
      _______________+
      Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin start-domain domain1+

      */home/dermfx/glassfish3/glassfish/bin/asadmin start-domain domain1*
      There is a process already using the admin port 4848 -- it probably is another instance of a GlassFish server.+
      Command start-domain failed.+



      What happens with me ? Please help me.

      Thanks in advance,
      Diego

      Edited by: 883357 on 08:51 05-09-2011