1 2 Previous Next 22 Replies Latest reply on Feb 12, 2013 2:44 PM by 990605 Go to original post
      • 15. Re: Upgrade from XE10 to XE11
        It is not just you. I just copied all of the 179 files in the "xsl/" on Oracle Standard One 11gR2 ( My missing file is also "kupostdt.xsl". I get the same error on my Oracle Express 11.2 trying to run "execute sys.dbms_metadata_util.load_stylesheets".

        Rob-Bob Ceglinski
        Adaptive Planning, Inc.

        Edited by: user11202931 on Sep 30, 2011 5:14 PM
        • 16. Re: Upgrade from XE10 to XE11
          Etore Schiavini
          Guys, I confirmed again: there are *180* files on xsl directory, not 179 ( Linux).
          • 17. Re: Upgrade from XE10 to XE11
            It is interesting that some of the .xsl files are derived from others. A case in point: the kupostab.xsl file actually has in its header "kuprocac.xsl " and if you diff the two files, there are only a handful of changed sections. If it is safe to copy this xsl/ directory from any machine then would it be possible for you to post the contents of this file. I can only imagine it is based on some package that is installed on your Linux (mine is SLES 11.0 64-bit) that is missing on mine/ours. For a giggle, I copied the kuprocac.xsl to my missing kupostdt.xsl file and I was then able to successfully run the aforementioned stored procedure AND get my export to work in my XE11.2 installation... So I agree that with the presence of the complete set of 180 files that this work-around is the solution. I have 10 database machines in production and 7 in QA all on SLES 11.0 and every single one of these installations is missing this file. They are all built the same way (I have not gotten to the point of auto installations yet but I have a doc that explains what to do). They all use the same CD/DVD and downloaded software. It is too odd that this file has consistently not been created on any installation (I even peeked at some Windows 32-bit and 64-bit installtions as well as some older Oracle and it is on none of them either).

            Added 10/3, 10:12am PDT: I forgot that we also added an up-to-date Oracle 11.2 Enterprise as the underlying database for a Grid Control installation. It is on the Oracle RedHat distribution as a VM machine and it also only has 179 files -- missing the "kupostdt.xsl" file. I am beginning to wonder how you got one moreso than how did I have all of mine go missing... ;-)


            Edited by: user11202931 on Oct 3, 2011 10:12 AM
            • 18. Re: Upgrade from XE10 to XE11
              Etore Schiavini
              I have RHEL 5.5 on all servers, all are Standard Editions.

              Only the oldest Oracle Home, a, have 179 files on xsl (missing kupostdt.xsl).

              All others are and have 180 files.

              This is the content of kupostdt.xsl:
              <?xml version="1.0"?>
                  XSLT stylesheet for XML => DDL conversion of ku$_post_data_table_t ADTs
                  Do NOT modify this file under any circumstance. Copy the file
                  if you wish to use this stylesheet with an external XML/XSL parser
              MODIFIED        MM/DD/YY
                  sdavidso 06/08/09 - new stylesheet - for minimize records_per_bock
              <xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
               <!-- Import required scripts -->
               <xsl:import href="kucommon.xsl"/>
               <!-- Top-level parameters -->
               <xsl:param name="PRETTY">1</xsl:param>
               <xsl:param name="SQLTERMINATOR">1</xsl:param>
               <!-- params for parse -->
               <xsl:param name="PRS_DDL">0</xsl:param>
               <xsl:param name="PRS_DELIM">\{]`</xsl:param>
               <xsl:param name="PRS_VERB">0</xsl:param>
               <xsl:param name="PRS_OBJECT_TYPE">0</xsl:param>
               <xsl:param name="PRS_SCHEMA">0</xsl:param>
               <xsl:param name="PRS_NAME">0</xsl:param>
               <xsl:param name="PRS_GRANTEE">0</xsl:param>
               <xsl:param name="PRS_GRANTOR">0</xsl:param>
               <xsl:param name="PRS_BASE_OBJECT_TYPE">0</xsl:param>
               <xsl:param name="PRS_BASE_OBJECT_SCHEMA">0</xsl:param>
               <xsl:param name="PRS_BASE_OBJECT_NAME">0</xsl:param>
               <xsl:template match="POST_DATA_TABLE_T">
                <!-- *******************************************************************
              Template: POST_DATA_TABLE_T - template for table attributes
              which can only be set after table data is loaded.
              ******************************************************************** -->
                <xsl:call-template name="DoParse">
                 <xsl:with-param name="Verb">ALTER</xsl:with-param>
                 <xsl:with-param name="ObjectType">POST_DATA_TABLE</xsl:with-param>
                 <xsl:with-param name="SchemaNode" select="SCHEMA_OBJ/OWNER_NAME"/>
                 <xsl:with-param name="NameNode" select="SCHEMA_OBJ/NAME"/>
                <xsl:if test="(SPARE1 mod 65536)>=32768">
                 <xsl:text> ALTER TABLE </xsl:text>
                 <xsl:apply-templates select="SCHEMA_OBJ"/>
                 <xsl:text>MINIMIZE RECORDS_PER_BLOCK</xsl:text>
              • 19. Re: Upgrade from XE10 to XE11
                Spectacular!! Thank you!!

                Here is my current output when running the aforementioned store procedure:

                oracle@l10n:~> sqlplus sys as sysdba

                SQL*Plus: Release Production on Mon Oct 3 19:49:30 2011

                Copyright (c) 1982, 2011, Oracle. All rights reserved.

                Enter password:

                Connected to:
                Oracle Database 11g Express Edition Release - 64bit Production

                SQL> execute sys.dbms_metadata_util.load_stylesheets;

                PL/SQL procedure successfully completed.


                Even MORE importantly, here is output from running the expdp utility:

                oracle:~/datapump> expdp system/system schemas=STARTER directory=datapump_dir logfile=api_STARTER_export.log dumpfile=api_STARTER.dp

                Export: Release - Production on Mon Oct 3 19:54:14 2011

                Copyright (c) 1982, 2009, Oracle and/or its affiliates. All rights reserved.

                Connected to: Oracle Database 11g Express Edition Release - 64bit Production
                Starting "SYSTEM"."SYS_EXPORT_SCHEMA_01": system/******** schemas=STARTER directory=datapump_dir logfile=api_STARTER_export.log dumpfile=api_STARTER.dp
                Estimate in progress using BLOCKS method...
                Processing object type SCHEMA_EXPORT/TABLE/TABLE_DATA
                Total estimation using BLOCKS method: 2.554 MB
                Processing object type SCHEMA_EXPORT/USER
                Processing object type SCHEMA_EXPORT/SYSTEM_GRANT
                Processing object type SCHEMA_EXPORT/DEFAULT_ROLE
                Processing object type SCHEMA_EXPORT/PRE_SCHEMA/PROCACT_SCHEMA
                Processing object type SCHEMA_EXPORT/SYNONYM/SYNONYM
                Processing object type SCHEMA_EXPORT/TYPE/TYPE_SPEC
                Processing object type SCHEMA_EXPORT/SEQUENCE/SEQUENCE
                Processing object type SCHEMA_EXPORT/TABLE/TABLE
                Processing object type SCHEMA_EXPORT/TABLE/INDEX/INDEX
                Processing object type SCHEMA_EXPORT/TABLE/CONSTRAINT/CONSTRAINT
                Processing object type SCHEMA_EXPORT/PACKAGE/PACKAGE_SPEC
                Processing object type SCHEMA_EXPORT/FUNCTION/FUNCTION
                Processing object type SCHEMA_EXPORT/PROCEDURE/PROCEDURE
                Processing object type SCHEMA_EXPORT/FUNCTION/ALTER_FUNCTION
                Processing object type SCHEMA_EXPORT/PROCEDURE/ALTER_PROCEDURE
                Processing object type SCHEMA_EXPORT/VIEW/VIEW
                Processing object type SCHEMA_EXPORT/PACKAGE/PACKAGE_BODY
                Processing object type SCHEMA_EXPORT/TYPE/TYPE_BODY
                Processing object type SCHEMA_EXPORT/TABLE/CONSTRAINT/REF_CONSTRAINT
                Processing object type SCHEMA_EXPORT/TABLE/TRIGGER
                Processing object type SCHEMA_EXPORT/VIEW/TRIGGER
                Processing object type SCHEMA_EXPORT/EVENT/TRIGGER
                Processing object type SCHEMA_EXPORT/TABLE/STATISTICS/TABLE_STATISTICS
                . . exported "STARTER"."TABLE01" 8.070 KB 2 rows
                . . exported "STARTER"."TABLE02" 6.914 KB 2 rows
                . . exported "STARTER"."TABLE03" 12.56 KB 16 rows
                . . exported "STARTER"."TABLE04" 19.19 KB 24 rows
                . . exported "STARTER"."TABLE05" 7.273 KB 2 rows
                . . exported "STARTER"."TABLE06" 6.890 KB 36 rows
                . . exported "STARTER"."TABLE07" 7.828 KB 25 rows
                . . exported "STARTER"."TABLE08" 6.851 KB 1 rows
                . . exported "STARTER"."TABLE09" 8.914 KB 1 rows
                . . exported "STARTER"."TABLE10" 5.453 KB 1 rows
                . . exported "STARTER"."TABLE11" 8.468 KB 199 rows
                . . exported "STARTER"."TABLE12" 5.437 KB 2 rows
                . . exported "STARTER"."TABLE13" 8.070 KB 2 rows
                . . exported "STARTER"."TABLE14" 5.546 KB 6 rows
                . . exported "STARTER"."TABLE15" 6.382 KB 1 rows
                . . exported "STARTER"."TABLE16" 5.851 KB 26 rows
                . . exported "STARTER"."TABLE17" 5.515 KB 1 rows
                . . exported "STARTER"."TABLE18" 5.523 KB 1 rows
                . . exported "STARTER"."TABLE19" 7.187 KB 2 rows
                . . exported "STARTER"."TABLE20" 5.515 KB 3 rows
                . . exported "STARTER"."TABLE21" 5.835 KB 33 rows
                . . exported "STARTER"."TABLE22" 9.406 KB 2 rows
                . . exported "STARTER"."TABLE23" 5.984 KB 2 rows
                . . exported "STARTER"."TABLE24" 7.171 KB 1 rows
                . . exported "STARTER"."TABLE25" 6.890 KB 4 rows
                . . exported "STARTER"."TABLE26" 5.523 KB 1 rows
                . . exported "STARTER"."TABLE27" 9.367 KB 1 rows
                . . exported "STARTER"."TABLE28" 5.515 KB 1 rows
                . . exported "STARTER"."TABLE29" 5.492 KB 2 rows
                . . exported "STARTER"."TABLE30" 11.48 KB 2 rows
                . . exported "STARTER"."TABLE31" 0 KB 0 rows
                . . exported "STARTER"."TABLE32" 0 KB 0 rows
                . . exported "STARTER"."TABLE33" 0 KB 0 rows
                Master table "SYSTEM"."SYS_EXPORT_SCHEMA_01" successfully loaded/unloaded
                Dump file set for SYSTEM.SYS_EXPORT_SCHEMA_01 is:
                Job "SYSTEM"."SYS_EXPORT_SCHEMA_01" successfully completed at 19:55:02

                Yippee!! Thank you, again.

                • 20. Re: Upgrade from XE10 to XE11
                  Hi Etore,

                  i tried different things:

                  a) I copied kupostab.xsl to kupostdt.xsl,
                  execute dbms_metadata_util.load_stylesheet
                  and: success?! Strange.
                  But the upgrade failed, the datafiles, i created before, were not registered anymore.
                  b) I did a normal exp/imp and all my data where in!
                  My prerequisite where to create a empty schema and the datafiles before and changed
                  the character set i had in XE10 (Western European) :
                  shutdown immediate;
                  startup mount;
                  alter system enable restricted session;
                  alter database open;
                  alter database character set internal_use WE8MSWIN1252;
                  shutdown immediate;

                  I only want to export/import my schema.

                  But i will try the upgrade-method with your kupostdt.xsl, thanks a lot.


                  Edited by: Achim Klausmann on 04.10.2011 21:03

                  Edited by: Achim Klausmann on 05.10.2011 09:47

                  Edited by: Achim Klausmann on 05.10.2011 09:47
                  • 21. Re: Upgrade from XE10 to XE11

                    so, it's been a while and today tried the upgrade procedure again.

                    export XE10 Western European:
                    This is running like several weeks ago.
                    I got a 3 Files generated:
                    gen_apps.sql (4 lines)
                    install.sql (4 lines)
                    ws.sql (empty)

                    imp XE11 Universal:
                    character set is AL32UTF8 , not WE8MSWIN1252, which choose before
                    execute sys.dbms_metadata_util.load_stylesheets;

                    ORA-39006: internal error
                    ORA-39213: Metadata processing is not available

                    Is it possible to upgrade from "XE10 Western European" to " XE11 Universa"l at all?
                    Or are there some difficulties between CHAR and NCHAR in the different databases
                    which avoid this?

                    Best regards
                    • 22. Re: Upgrade from XE10 to XE11
                      Hi everybody,

                      If you don't have an installation of Oracle where you can get the XSL directory you can extract it from the file: win32_11gR2_database_1of2.zip. This is downloadable from the Oracle website. When you open this file with 7-Zip and drill down to the following path: \database\stage\Components\oracle.rdbms\\1\DataFiles and select the filegroup21.jar file you can open this JAR file also with 7-Zip. In this JAR file is the XSL directory. Extract only the contents of this JAR file to your drive.

                      In this JAR file are 179 files. :( so you need to copy the text above for the kupostdt.xsl file to get the 180 files needed.

                      Good luck. It worked for me.
                      1 2 Previous Next