3 Replies Latest reply: Sep 27, 2011 2:04 PM by 890613 RSS

    Problems with JDeveloper's Subversion extension

    890613
      I've been working on making JDeveloper's subversion extension play nice with our subversion server for the past couple days, but I haven't had any luck making it work. I keep coming up with the following error:


      Testing read access for repository https://<repo address>...
      svn: authentication failed.
      Please check the username and password stored in the Subversion connection.
      svn: authentication failed.
      Please check the username and password stored in the Subversion connection.
      Access refused.
      Verify user name, password and URL are valid.


      I've checked and rechecked that the username/password/URL are all correct, and I do have access to the repo. I'm using JDeveloper 11.1.2.1.0 with SVNKit 1.3.5 (I've also tried various native clients) and the repo is on a server running version 1.5.3 (r33570), and so far it's the only server with which I've had trouble making a connection (Sourceforge, Google code, external servers, other internal servers, etc. all work just fine).

      I've tried the stock versions of SVNKit/svnClientAdapter, as well as building both from source against SlikSVN 1.6.17 (Windows, amd_64 arch) and then providing the resulting jars to JDeveloper; neither seems to work. I've successfully connected JDeveloper to another server running v1.5.3, so I don't think it's a version mismatch problem. Moreover, I'm able to use the binaries (jsvn) form the SVNKit builds to check out the repo, so I don't think it's an issue with SVNKit.

      I've been scouring the forums and google for solutions, but I haven't found anything yet. I'm at wit's end, so I thought I'd ask here to see if someone could suggest something I might have overlooked. Any suggestions, either how to fix it or how I might obtain more information about what specifically is going wrong, would be more than welcome.